Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Errors 0x800F0900 and 0x800B0100

19 Aug 2013   #11
Mentos

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by NoelDP View Post
The base folder structure should be

C:\mtsaa\<long foldername>\<longfilename>
For completeness, here's the structure I currently have:
Code:
C:\Windows\system32>dir C:\mtsab /S
 Volume in drive C has no label.
 Volume Serial Number is B4DF-125D

 Directory of C:\mtsab

08/19/2013  09:10 AM    <DIR>          .
08/19/2013  09:10 AM    <DIR>          ..
08/18/2013  05:13 PM    <DIR>          amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996
               0 File(s)              0 bytes

 Directory of C:\mtsab\amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996

08/18/2013  05:13 PM    <DIR>          .
08/18/2013  05:13 PM    <DIR>          ..
07/14/2009  02:38 AM           777,728 autochk.exe
               1 File(s)        777,728 bytes

     Total Files Listed:
               1 File(s)        777,728 bytes
               5 Dir(s)   3,077,718,016 bytes free

C:\Windows\system32>dir C:\Windows\winsxs\mtsab
 Volume in drive C has no label.
 Volume Serial Number is B4DF-125D

 Directory of C:\Windows\winsxs\mtsab

08/18/2013  09:18 PM    <DIR>          .
08/18/2013  09:18 PM    <DIR>          ..
08/18/2013  09:18 PM    <DIR>          amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996
               0 File(s)              0 bytes
               3 Dir(s)   3,077,718,016 bytes free
I've also tried running SFC with the amd64_[...]autochk[...]\ directory moved up a level (to \winsxs\amd64_[...]autochk[...]\).

I could be missing some simple yet crucial step.

Edit: just to make sure, it should be mtsab, not mtsaa, correct?


My System SpecsSystem Spec
.
19 Aug 2013   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That explains the problem with Autochek then

You appear to have been xcopying the mtsab folder, rather than its content (C:\Windows\Winsxs\mtsab should not exist)
Please review my instructions again and follow them exactly
My System SpecsSystem Spec
19 Aug 2013   #13
Mentos

Windows 7 Pro x64
 
 

Uploaded a new CBS.log.
My System SpecsSystem Spec
.

19 Aug 2013   #14
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Still the same error

Maybe it's a registry problem? - maybe it's still a file problem.....

Please run the following commands...

COPY C:\Windows\Winsxs\amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996 %userprofile%\desktop\mtsnp1
REG QUERY "HKEY_LOCAL_MACHINE\COMPONENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFamilies\amd64_microsoft-windows-autochk_31bf3856ad364e35_none_e006b9b4b9af9929" /S

Post the results.

You'll fined that the first command put a file on your desktop - 'mtsnp1'
Please zip it and attach it to your results as well - then I can check it against the normal file.
My System SpecsSystem Spec
19 Aug 2013   #15
Mentos

Windows 7 Pro x64
 
 

Results of commands:
Code:
C:\Windows\system32>COPY C:\Windows\Winsxs\amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996 %userprofil
e%\desktop\mtsnp1
C:\Windows\Winsxs\amd64_microsoft-windows-autochk_31bf3856ad364e35_6.1.7600.16385_none_3de8def0db722996\autochk.exe
        1 file(s) copied.

C:\Windows\system32>REG QUERY "HKEY_LOCAL_MACHINE\COMPONENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFa
milies\amd64_microsoft-windows-autochk_31bf3856ad364e35_none_e006b9b4b9af9929" /S
ERROR: The system was unable to find the specified registry key or value.

C:\Windows\system32>REG QUERY "HKEY_LOCAL_MACHINE\COMPONENTS\DerivedData\VersionedIndex\6.1.7601.17592(win7sp1_gdr.110408-1631)\ComponentFam
ilies\amd64_microsoft-windows-autochk_31bf3856ad364e35_none_e006b9b4b9af9929" /S
ERROR: The system was unable to find the specified registry key or value.
HKEY_LOCAL_MACHINE\COMPONENTS\ doesn't appear to exist when looking through regedit.

I also searched for 'autochk' using RegScanner - these are the results:
My System SpecsSystem Spec
19 Aug 2013   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The file is very definitely not being properly replaced - all hashes run on it are different to the standard.
Somehow, you appear not to be following the proper procedure for replacement of the file.

Please try again, and this time note the EXACT XCOPY command you are using, and post it in your reply.
My System SpecsSystem Spec
19 Aug 2013   #17
Mentos

Windows 7 Pro x64
 
 

The exact command I entered was:
Code:
XCOPY C:\mtsab C:\Windows\winsxs /y /i /s /v /h
with the result "1 File(s) copied".

For comparison, I've zipped the autochk.exe files from both the source mtsab folder and the destination folder in winsxs (files are renamed to source_autochk and destination_autochk). Perhaps the autochk.exe in the mtsab folder is the incorrect version?
My System SpecsSystem Spec
19 Aug 2013   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The destination_autocheck file is infected with a virus....
https://www.virustotal.com/en/file/0...is/1376947283/


Please download and install Malwarebytes Anti-malware (free version) from http://www.malwarebytes.org/products/malwarebytes_free/ - UNtick 'Enable free trial of MBAM PRO' at the end of the installation - and update it, then run a FULL Scan in your main account, and Quick scans in any other user accounts.

Delete everything it finds
My System SpecsSystem Spec
19 Aug 2013   #19
Mentos

Windows 7 Pro x64
 
 

Ah I see, thanks. Running a scan now, I'll check back when it's done.
My System SpecsSystem Spec
20 Aug 2013   #20
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I checked, and MBAM doesn't actually detect it (yet) - but it may find other things, including the control program that keeps reverting it.
My System SpecsSystem Spec
Reply

 Errors 0x800F0900 and 0x800B0100




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Errors 0x800B0100 and 9C59 when trying to install Windows Updates
So I have 3 updates that are failing: KB3003057 KB3008923 Internet Explorer 11 for Windows 7 for x64-based Systems I've tried the following with no success: Utilizied the System Update Readiness tool (that gets hung up on KB947821) Ran the Windows Update Troubleshooter Tryed "sfc /scannow"...
Windows Updates & Activation
CBS MUM Corrupt 0x800F0900 and other AMD x64 related update errors
new ASUS sabertooth99fx rev2, AMD 8 core 4gz, 16gig ram lost ability to add delete windows components Checking Package Manifests and Catalogs (f) CBS MUM Corrupt 0x00000000 ...
Windows Updates & Activation
CBS MUM Corrupt 0x800F0900
Hello, Trying to fix some issues with windows update. Ran the sfc and readiness tool. Repaired most of the corruption but the attached report shows it cant repair some of the files. Windows updates fails with 0x800F0900. Windows 7 64bit (no SP1) Any help would be appreciated.
Windows Updates & Activation
SP 1 fails - CBS MUM Corrupt 0x800F0900
Win 7 Home Prem 32bit - had a virus - clean now, but SP1 will not install (either safe or normal) Update Readiness : ================================= Checking System Update Readiness. Binary Version 6.1.7601.21645 Package Version 18.0 2013-04-24 14:24 Checking Windows Servicing Packages ...
Windows Updates & Activation
SP1 error code 0x800f0900???
Can anybody shed any light on this error code please? I have searched the internet and tried many of the suggestions but to no avail. :(
Windows Updates & Activation
W7 Prof. 32 bit Windows Update errors: 0x800b0100 and 9C47
Hi, I'm having trouble installing this updates: Update KB2454826:--> Error: 800B0100 SP1 for Windows 7 Professional 32bit:--> Error: 0x800b0100 Internet Explorer 9 for Windows 7:--> Error: 9C47 I've run System Update Readiness, and SFC Scan, no positive results... Really tired of...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App