Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to get any updates at all: Error 800f0900

20 Aug 2013   #1

Windows 7 Professional 64 bit
 
 
Unable to get any updates at all: Error 800f0900

Since I last built my computer almost 1 year ago, I've encountered a weird error message whenever I try to update:







I already tried downloading the system readiness tool and it couldn't repair the problems, I even tried downloading service pack 1 and installing it but I get this error message:





I have absolutely no idea what to do know and seeing that little red flag at the bottom of my screen is driving me a bit crazy.

My System SpecsSystem Spec
.

20 Aug 2013   #2

Windows 7 Professional x64 SP1
 
 

Hi RayDawg

First are your Date, time and region settings correct ?, and you could run > What is the System Update Readiness Tool?
My System SpecsSystem Spec
21 Aug 2013   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Please follow the Windows Update Posting Instructions and post the requested data
My System SpecsSystem Spec
.


21 Aug 2013   #4

Windows 7 Professional 64 bit
 
 

Ok, I've enclosed the image and the CBS folder.


Attached Thumbnails
Unable to get any updates at all: Error 800f0900-can-t-update.jpg  
Attached Files
File Type: zip CBS.zip (6.37 MB, 1 views)
My System SpecsSystem Spec
22 Aug 2013   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

There are a number of errors showing with the manifest files in the WindowsUpdateAgent - and these are notoriously difficult to fix.
here's a sample...
Code:
 Line 161: 2013-07-18 21:03:51, Error                 CBS    Failed to check whether package is partially installed, package: WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256 [HRESULT = 0x800f0900 - CBS_E_XML_PARSER_FAILURE]
 Line 382: 2013-07-19 08:25:41, Error                 CBS    Failed to shred identity: Microsoft-Windows-InternetExplorer-LanguagePack [HRESULT = 0x80070057 - E_INVALIDARG]
 Line 638: 2013-07-19 08:25:42, Error                 CBS    Failed to shred identity: Microsoft-Windows-InternetExplorer-LanguagePack [HRESULT = 0x80070057 - E_INVALIDARG]
 Line 690: 2013-07-19 08:25:45, Error                 CBS    Failed to parse package manifest: \\?\C:\Windows\Servicing\Packages\WUClient-SelfUpdate-Core-CoreComp~31bf3856ad364e35~amd64~~7.6.7600.256.mum [HRESULT = 0x800f0900 - CBS_E_XML_PARSER_FAILURE]
 Line 697: 2013-07-19 08:25:45, Error                 CBS    Delay Initialization Failed [HRESULT = 0x800f0900 - CBS_E_XML_PARSER_FAILURE]
The CheckSUR scan is clear, surprisingly.

I think your best hope for a quick solution is going to be a repair install of Windows.
See here...
http://www.sevenforums.com/tutorials/3413-repair-install.html
My System SpecsSystem Spec
22 Aug 2013   #6

Windows 7 Professional 64 bit
 
 

Just my luck. I'll try repairing the install and see what happens. I'll keep you guys posted.
My System SpecsSystem Spec
22 Aug 2013   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Good Luck with it!
My System SpecsSystem Spec
22 Aug 2013   #8

Windows 7 Professional 64 bit
 
 

Update: I got the security updates but now the USB root hub registry isn't fully configured so almost all of the USB ports aren't working. I managed to find one single USB port that works and got my keyboard to work, but oddly, my mouse isn't working when plugged into said port. I'm writing this on my backup laptop at the moment. More updates later.

Edit:

Update 2: I'm going to do another repair install since the registries and drivers for the USB 3.0 hub and the normal USB hub seems to have an issue. I'm starting to think that I would have been better off without doing the repair install in the first place as I've been updating and trying to fix my security issue for over 12 hours now.
My System SpecsSystem Spec
23 Aug 2013   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Did you update the USB drivers from the motherboard manufacturer's website?
My System SpecsSystem Spec
23 Aug 2013   #10

Windows 7 Professional 64 bit
 
 

I did update, but I keep getting a message that says the USB 3.0 registry configuration is missing or incomplete.
My System SpecsSystem Spec
Reply

 Unable to get any updates at all: Error 800f0900




Thread Tools



Similar help and support threads for2: Unable to get any updates at all: Error 800f0900
Thread Forum
Unable to run SFCscan,Windows Updates error 80004002,IE,Troubleshooter Windows Updates & Activation
Unable to check for updates, error 0x800b0100 Windows Updates & Activation
Unable to install Windows Updates, error code 80071A91 Windows Updates & Activation
Windows Update Error 800F0900, my logs. Windows Updates & Activation
Unable to install updates in windows 7 error 800B0100 update KB976932 Windows Updates & Activation
Solved Cannot Update KB2691442 & KB2732500 - Error Codes 800B0100 & 800F0900 Windows Updates & Activation
Unable to install Windows Updates, error 80246008 Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:27 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33