Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Update to IE 10 Attempt Gives Error 9c59


01 Sep 2013   #1

Window 7 Home Premium 64-bit
 
 
Update to IE 10 Attempt Gives Error 9c59

Updating from IE 9 to IE 10 fails whether I do it directly from Windows Update or attempt it during shutdown. In addition to the 9c59 error code Windows Update cites, Event Viewer returns an Event ID of 20 and a code of 0x80070643.



Attached Thumbnails
Update to IE 10 Attempt Gives Error 9c59-error_9c59.png  
Attached Images
 
Attached Files
File Type: zip CheckSUR.zip (5.53 MB, 1 views)
File Type: zip FilterList.zip (175 Bytes, 0 views)
My System SpecsSystem Spec
.

02 Sep 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums fc2357. Until the experts come along, I'll post some reading for you. Forgive me if you've "been there, done that"

Troubleshooting a failed installation of Internet Explorer 10

And, perhaps more specifically

Internet Explorer 10 fails to install | The knack

Windows Update code 9c59. - Microsoft Community

Good luck. A Guy
My System SpecsSystem Spec
02 Sep 2013   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

CheckSUR found and fixed a few errors.

The SFC found nothing - but the background CBS log found a few errors....
Code:
2013-09-01 16:02:45, Info                  CBS    Appl: Partial install Status testing, package: Package_for_KB976933~31bf3856ad364e35~amd64~~6.1.7601.17514, partially installed (true/false), 0
2013-09-01 16:02:45, Info                  CBS    Failed to find package from aggreated XML string, package: Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-09-01 16:02:45, Info                  CBS    Failed to find package from deployment update [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-09-01 16:02:45, Error                 CBS    Failed to check whether package is partially installed, package: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-09-01 16:02:45, Info                  CBS    Failed to evaluate external applicability for package update: 976933-0_neutral_PACKAGE [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-09-01 16:02:45, Error                 CBS    Failed to call external evaluate applicability on package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, Update: 976933-0_neutral_PACKAGE [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-09-01 16:28:03, Info                  CBS    Exec: Resolving Package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514, Update: Internet-Explorer-amd64, PinDeployment: amd64_microsoft-windows-i..explorer-deployment_31bf3856ad364e35_8.0.7601.17514_none_c6a79c0da6ac8a8c
2013-09-01 16:28:03, Error                 CSI    0000031a@2013/9/1:20:28:03.690 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
[gle=0x80004005]
2013-09-01 16:28:03, Error                 CSI    0000031b (F) STATUS_SXS_ASSEMBLY_MISSING #8437347# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2013-09-01 16:28:03, Error                 CSI    0000031c (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #8437232# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-InternetExplorer-Deployment, Version = 8.0.7601.17514, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [105]"Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514.Internet-Explorer-amd64", rah = (null), manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2013-09-01 16:28:03, Info                  CBS    Failed to pin deployment while resolving Update: Internet-Explorer-amd64 from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:28:03, Info                  CBS    Failed to resolve item[0] in Package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514, Update: Internet-Explorer-amd64 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:28:03, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:28:03, Error                 CBS    Failed to resolve execution package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:28:03, Info                  CSI    0000031d@2013/9/1:20:28:03.971 CSI Transaction @0x18673d0 destroyed
2013-09-01 16:47:27, Info                  CBS    Exec: Resolving Package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514, Update: Internet-Explorer-amd64, PinDeployment: amd64_microsoft-windows-i..explorer-deployment_31bf3856ad364e35_8.0.7601.17514_none_c6a79c0da6ac8a8c
2013-09-01 16:47:28, Error                 CSI    00000106@2013/9/1:20:47:28.171 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
[gle=0x80004005]
2013-09-01 16:47:29, Error                 CSI    00000107 (F) STATUS_SXS_ASSEMBLY_MISSING #676206# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2013-09-01 16:47:29, Error                 CSI    00000108 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #676091# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-InternetExplorer-Deployment, Version = 8.0.7601.17514, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [105]"Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514.Internet-Explorer-amd64", rah = (null), manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2013-09-01 16:47:29, Info                  CBS    Failed to pin deployment while resolving Update: Internet-Explorer-amd64 from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:47:29, Info                  CBS    Failed to resolve item[0] in Package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514, Update: Internet-Explorer-amd64 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:47:29, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-09-01 16:47:29, Error                 CBS    Failed to resolve execution package: Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~amd64~~8.0.7601.17514 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
...and a few others as well.

I've seen the Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514 error before - but never really understood where it comes from in an English install.

Please open an Elevated Command Prompt, and run the following commands...

REG LOAD HKLM\COMPONENTS C:\Windows\System32\config\COMPONENTS
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514"
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Package_for_KB976933~31bf3856ad364e35~amd64~~0.0.0.0"
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageIndex\Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~0.0.0.0"

post the results....

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
.


03 Sep 2013   #4

Window 7 Home Premium 64-bit
 
 
Results of command prompt processing

Thanks Noel. Here are the results. I thought they were still diagnostic in intent so I haven't tried the update.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Windows\system32>REG LOAD HKLM\COMPONENTS C:\Windows\System32\config\COMPONEN
TS
The operation completed successfully.
C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\Packages\Package_for_KB976933~31bf3856ad364e35~amd64~fr-
FR~6.1.7601.17514"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Ser
vicing\Packages\Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514
InstallClient REG_SZ WindowsUpdateAgent
InstallName REG_SZ Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6
.1.7601.17514.mum
InstallLocation REG_SZ \\?\C:\Windows\SoftwareDistribution\Download\a8
8203c5831df77ae060d14f2bd14310\
CurrentState REG_DWORD 0x70
SelfUpdate REG_DWORD 0x0
Visibility REG_DWORD 0x2
Trusted REG_DWORD 0x1
InstallTimeHigh REG_DWORD 0x1cc3cef
InstallTimeLow REG_DWORD 0xf57ce066
InstallUser REG_SZ S-1-5-21-2076602307-1459237599-3679390017-1000
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Ser
vicing\Packages\Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514
\Owners
C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\PackageDetect\Package_for_KB976933~31bf3856ad364e35~amd6
4~~0.0.0.0"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Ser
vicing\PackageDetect\Package_for_KB976933~31bf3856ad364e35~amd64~~0.0.0.0
Microsoft-Windows-PlatformUpdate-Windows 7-SRV08R2-Package~31bf3856ad364e35~amd64
~~7.1.7601.16492 REG_DWORD 0x2
Microsoft-Windows-UIAnimation-WinIP-Package~31bf3856ad364e35~amd64~~7.1.7601
.16492 REG_DWORD 0x2
Win8IP-Microsoft-Windows-Graphics-Package~31bf3856ad364e35~amd64~~7.1.7601.1
6492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-Multimedia-Package~31bf3856ad364e35~amd64~~7.1.7601
.16492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-Printing-Package~31bf3856ad364e35~amd64~~7.1.7601.1
6492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-DownlevelApisets-WinIP-Package~31bf3856ad364e35~amd
64~~7.1.7601.16492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-DownlevelApisets-Base-WinIP-Package~31bf3856ad364e3
5~amd64~~7.1.7601.16492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-DownlevelApisets-Com-WinIP-Package~31bf3856ad364e35
~amd64~~7.1.7601.16492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-DownlevelApisets-Shell-WinIP-Package~31bf3856ad364e
35~amd64~~7.1.7601.16492 REG_DWORD 0x3
Win8IP-Microsoft-Windows-DownlevelApisets-Windows-WinIP-Package~31bf3856ad36
4e35~amd64~~7.1.7601.16492 REG_DWORD 0x3
Microsoft-Windows-RemoteDesktopClient-WinIP-Package~31bf3856ad364e35~amd64~~
7.1.7601.16398 REG_DWORD 0x2

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\PackageIndex\Package_for_KB976933~31bf3856ad364e35~amd64
~fr-FR~0.0.0.0"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Ser
vicing\PackageIndex\Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~0.0.0.0
Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514 REG_DWOR
D 0x0

C:\Windows\system32>
My System SpecsSystem Spec
04 Sep 2013   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

There appear to be a number of entries missing from the "Package_for_KB976933~31bf3856ad364e35~amd6
4~~0.0.0.0" subkey - I'll have to play and see what that does to various things.

It may take a day or two - shout if you've not heard by Saturday.
My System SpecsSystem Spec
07 Sep 2013   #6

Window 7 Home Premium 64-bit
 
 

Find anything, Noel?
My System SpecsSystem Spec
07 Sep 2013   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

FWIW - I too had a failure when going from IE9 to IE10. Went in circles with a tech over at MS support. No joy. Eventually, upon visiting the site where I grabbed some custom themes, and stumbling upon this same situation on one of their forums, the culprit turned out to be in some part of the theme installation. I reverted back to IE9 until they fixed their end. As a test, and before their fix was completed, I removed the custom theme and IE10 installed w/o incident. Again, fwiw.

- cheers
My System SpecsSystem Spec
07 Sep 2013   #8

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Yes, 7tsp themes have issues with IE10. Since the OP has run SFC, that should not be an issue. Waiting for Noel to leave the pub find his way back here

A Guy
My System SpecsSystem Spec
08 Sep 2013   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You know me too well

Playing with the entries at the moment - nothing enlightening so far
My System SpecsSystem Spec
08 Sep 2013   #10

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Seems I was wrong - all the registry entries are OK.
The difference is because I was originally looking at a system updated from RTM to SP1, while your system appears to have been installed as SP1.
Back to the drawing-board.
My System SpecsSystem Spec
Reply

 Update to IE 10 Attempt Gives Error 9c59




Thread Tools



Similar help and support threads for2: Update to IE 10 Attempt Gives Error 9c59
Thread Forum
IE 10 Update Failed - Windows 7 - Error Code 9C59 Windows Updates & Activation
Solved IE10 Update Fail on Win 7 Pro x64 - error code 9C59 Windows Updates & Activation
cannot update to IE 10, error Code 9C59 Windows Updates & Activation
Windows 7 HP x64 Update IE10 Error Code 9C59 Windows Updates & Activation
IE10 can't install from Windows Update, error 9C59 Browsers & Mail
Solved IE 10 update failure Windows 7 error 9C59 Windows Updates & Activation
Error 9C59 when using Windows Update to install IE10 Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33