Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error 126: cannot start service - Windows Modules Installer

16 Sep 2013   #1
ThierryS

Windows 7 Professional SP1 64bit
 
 
Error 126: cannot start service - Windows Modules Installer

Hi All,

I've been having a problem installing Windows updates and certain other software packages lately.

It seems the Windows Module Installer Module cannot be started, as below - so I've taken the liberty to push diagnostics a bit further, all below as well. Apologies for the French, let me know if you need anything translated. The last step is ICACLS command saying
"c:\windows\CSC\trustedinstaller.*: Access Denied"
... and stopping there.

Any help would be greatly appreciated from this side of the pond!

Thank you in advance,

Kind regards,

Thierry



Code:
C:\Windows\System32>net start trustedinstaller
Le service Programme d'installation pour les modules Windows démarre.
Le service Programme d'installation pour les modules Windows n'a pas pu être lan
cé.

Une erreur système s'est produite.

L'erreur système 126 s'est produite.

Le module spécifié est introuvable.


C:\Windows\System32>sc qc trustedinstaller
[SC] QueryServiceConfig réussite(s)

SERVICE_NAME: trustedinstaller
        TYPE               : 10  WIN32_OWN_PROCESS
        START_TYPE         : 2   AUTO_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : C:\Windows\servicing\TrustedInstaller.exe
        LOAD_ORDER_GROUP   : ProfSvc_Group
        TAG                : 0
        DISPLAY_NAME       : Programme d'installation pour les modules Windows
        DEPENDENCIES       :
        SERVICE_START_NAME : localSystem

C:\Windows\System32>dir c:\windows\trustedinstaller.* /S
 Le volume dans le lecteur C n'a pas de nom.
 Le numéro de série du volume est FABE-83BD

 Répertoire de c:\windows\servicing

20/11/2010  15:25           194 048 TrustedInstaller.exe
               1 fichier(s)          194 048 octets

 Répertoire de c:\windows\servicing\fr-FR

20/11/2010  15:01             7 680 TrustedInstaller.exe.mui
               1 fichier(s)            7 680 octets

 Répertoire de c:\windows\winsxs\amd64_microsoft-windows-t..installer.resources_
31bf3856ad364e35_6.1.7600.16385_fr-fr_65a25b82cf55a422

04/08/2010  18:12             7 168 TrustedInstaller.exe.mui
               1 fichier(s)            7 168 octets

 Répertoire de c:\windows\winsxs\amd64_microsoft-windows-t..installer.resources_
31bf3856ad364e35_6.1.7601.17514_fr-fr_67d36f4acc4427bc

20/11/2010  15:01             7 680 TrustedInstaller.exe.mui
               1 fichier(s)            7 680 octets

 Répertoire de c:\windows\winsxs\amd64_microsoft-windows-trustedinstaller_31bf38
56ad364e35_6.1.7600.16385_none_ed02252b66d7bca2

14/07/2009  03:39           194 048 TrustedInstaller.exe
               1 fichier(s)          194 048 octets

 Répertoire de c:\windows\winsxs\amd64_microsoft-windows-trustedinstaller_31bf38
56ad364e35_6.1.7601.17514_none_ef3338f363c6403c

20/11/2010  15:25           194 048 TrustedInstaller.exe
               1 fichier(s)          194 048 octets

     Total des fichiers listés :
               6 fichier(s)          604 672 octets
               0 Rép(s)  11 966 898 176 octets libres

C:\Windows\System32>icacls c:\windows\trustedinstaller.* /T
c:\windows\CSC\trustedinstaller.*: Accès refusé.
0 fichiers correctement traités ; échec du traitement de 1 fichiers

C:\Windows\System32>



My System SpecsSystem Spec
18 Sep 2013   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

That error is common - and nothing to worry about.
Use these commands instead...

DIR C:\Windows\servicing\TrustedInstaller.* /S
ICACLS C:\Windows\servicing\TrustedInstaller.* /T
My System SpecsSystem Spec
18 Sep 2013   #3
ThierryS

Windows 7 Professional SP1 64bit
 
 

Thank you Noel, the result is below. So those "read & execute" permissions look normal - is that error 126 due to something else then?

Best regards,

Thierry


Code:
Microsoft Windows [version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

C:\Windows\system32>DIR C:\Windows\servicing\TrustedInstaller.* /S
 Le volume dans le lecteur C n'a pas de nom.
 Le numéro de série du volume est FABE-83BD

 Répertoire de C:\Windows\servicing

20/11/2010  15:25           194 048 TrustedInstaller.exe
               1 fichier(s)          194 048 octets

 Répertoire de C:\Windows\servicing\fr-FR

20/11/2010  15:01             7 680 TrustedInstaller.exe.mui
               1 fichier(s)            7 680 octets

     Total des fichiers listés :
               2 fichier(s)          201 728 octets
               0 Rép(s)  10 497 679 360 octets libres

C:\Windows\system32>ICACLS C:\Windows\servicing\TrustedInstaller.* /T
C:\Windows\servicing\TrustedInstaller.exe NT SERVICE\TrustedInstaller:(F)
                                          BUILTIN\Administrateurs:(RX)
                                          AUTORITE NT\Système:(RX)
                                          BUILTIN\Utilisateurs:(RX)

C:\Windows\servicing\fr-FR\TrustedInstaller.exe.mui NT SERVICE\TrustedInstaller:
(F)
                                                    BUILTIN\Administrateurs:(RX)

                                                    AUTORITE NT\Système:(RX)
                                                    BUILTIN\Utilisateurs:(RX)

2 fichiers correctement traités ; échec du traitement de 0 fichiers

C:\Windows\system32>
My System SpecsSystem Spec
18 Sep 2013   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

WMI frequently cannot start because other services are failing to start as well - check your Event Viewer and see if there's any signs of that (or post the Application and System .evtx files)
My System SpecsSystem Spec
18 Sep 2013   #5
ThierryS

Windows 7 Professional SP1 64bit
 
 

Here you go: System and Application events from yesterday from 16:00 to 16:59 CET:
- An unsuccessful attempt to launch Windows Module Installer at 16:15:59 CET
- A "WindowsUpdateFailure" event at 16:16:34 CET

Many thanks,

Thierry

(had to rename to .log to get the uploader to accept the files)
My System SpecsSystem Spec
18 Sep 2013   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

It looks to me like this is the problem....
Code:
 
Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Accès refusé.

. This is often caused by incorrect security settings in either the writer or requestor process. 

Opération :

   Données du rédacteur en cours de collecte

Contexte :

   ID de classe du rédacteur: {e8132975-6f93-4464-a53e-1050253ae220}

   Nom du rédacteur: System Writer

   ID d’instance du rédacteur: {92273446-3268-402c-bf6e-0545aef8919e}
Event ID 8194 refers.
My System SpecsSystem Spec
18 Sep 2013   #7
ThierryS

Windows 7 Professional SP1 64bit
 
 

Ok, so I've stopped ShadowBackup, a third-party application, and indeed those VSS events stop occurring, as confirmed in Event Viewer.

After that I stopped the VSS service, as below, and tried to start TrustedInstaller, which still refuses to start with the same 126 error code.

Anything else I should try?

Many thanks,

Thierry


Code:
C:\Windows\system32>sc stop vss

SERVICE_NAME: vss
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 3  STOP_PENDING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

C:\Windows\system32>sc queryex vss

SERVICE_NAME: vss
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 0
        FLAGS              :

C:\Windows\system32>sc queryex trustedinstaller

SERVICE_NAME: trustedinstaller
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 126  (0x7e)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 0
        FLAGS              :

C:\Windows\system32>sc start trustedinstaller

SERVICE_NAME: trustedinstaller
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 2  START_PENDING
                                (NOT_STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x7d0
        PID                : 4168
        FLAGS              :

C:\Windows\system32>sc queryex trustedinstaller

SERVICE_NAME: trustedinstaller
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 126  (0x7e)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 0
        FLAGS              :

C:\Windows\system32>
My System SpecsSystem Spec
18 Sep 2013   #8
ThierryS

Windows 7 Professional SP1 64bit
 
 

Sorry, meant "QuickShadow" (QuicklyTech: QuickShadow Backup), not ShadowBackup.
My System SpecsSystem Spec
18 Sep 2013   #9
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

My System SpecsSystem Spec
18 Sep 2013   #10
ThierryS

Windows 7 Professional SP1 64bit
 
 

Hi Noel,

Adding the Version subkey to Component Servicing did the trick, now TrustedInstaller is happy again - many thanks for all the support, and pointing me in the right direction, much appreciated!

Now 45 updates installed, but I am running into an IE9 update 94C8 error... I'll start a different thread if I can't manage to fix that myself after reading the abundant literature on the topic.

Many thanks once again, and I owe you a beer (or a glass of wine) next time you visit Paris.

Best regards,

Thierry
My System SpecsSystem Spec
Reply

 Error 126: cannot start service - Windows Modules Installer




Thread Tools



Similar help and support threads for2: Error 126: cannot start service - Windows Modules Installer
Thread Forum
Windows installer service error 1719 Software
Getting Error 1053 where trying to start a windows service General Discussion
error 1719 The windows installer service could not be accessed....... General Discussion
Windows Modules Installer Error 1017 General Discussion
Windows installer service error Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:08 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App