Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7:can't install SP1 x64. Error:TRUST_E_NOSIGNATURE(0x800b0100)

13 Oct 2013   #1
bubur

Windows 7 home premium 64 bits
 
 
Windows 7:can't install SP1 x64. Error:TRUST_E_NOSIGNATURE(0x800b0100)

Hi,

Each time I try to update my Windows 7 to sp1, I get this error: TRUST_E_NOSIGNATURE(0x800b0100)

I have tried to run the System Update Readiness Tool and logfile reports these missing manifest and mum files, that I don't know where to find.

Does anyone know a website where I can download them please?

I have attached the CheckSUR.log logfile

Many thanks,

Bubur


My System SpecsSystem Spec
.

13 Oct 2013   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Here's the summary from your CheckSUR log...
Code:
Summary:
Seconds executed: 1797
 Found 105 errors
  CSI Manifest Missing Total count: 103
  CBS MUM Missing Total count: 2
It's right on the limit or practicality for manual fixing - but we'll give it a go and see what happens

I'll post the first fix protocol shortly.
My System SpecsSystem Spec
13 Oct 2013   #3
bubur

Windows 7 home premium 64 bits
 
 
Thanks

Hi Noel,

Thanks for your help.

Bubur
My System SpecsSystem Spec
.


13 Oct 2013   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Took a little longer than I expected -I had to download a few files to get the right versions....

I've included a number of files which aren't strictly required by the current output - but I suspect that they may be required later, so it'll reduce the lead time


I've uploaded afile - bbraa.zip - to my SkyDrive at Noel's SkyDrive

Please downloadand save it.

Right-click onthe downloaded file, and select Extract all…

Extract to thedefault location - which will create a new folder CWBFilesin the same place.

Open this folder- there should be two folders inside it (Manifests,and Packages)



Copy the content of the Packages folder to thefolder

C:\Windows\Temp\CheckSur\Servicing\Packages



Andthe content of the manifestsfolder (.manifest files) into this folder:



C:\Windows\Temp\CheckSur\Winsxs\Manifests



Nowrun the CheckSUR tool again (it may take a while)



Postthe new CheckSUR.log file, and the CheckSUR.persist.log file.


(note that it may take a while for my file to appear in the Skydrive - depending on my internet connection!)
My System SpecsSystem Spec
13 Oct 2013   #5
bubur

Windows 7 home premium 64 bits
 
 
SP1 installed correctly

Hi Noel,

By re running the CheckSUR tool again with all the files in the right place, I managed to install SP1.
I have enclosed the 2 log files for information.

By the way, simple curiosity, how can we explain these files were missing on my computer and why SP1 would need these files for? and last question: can we find these files on the windows DVD?

Many thanks for your help

Bubur
My System SpecsSystem Spec
14 Oct 2013   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I see that a few payload file errors crept into the report.
Code:
  CSI Payload File Missing Total count: 8
CheckSUR seems to have managed to fix those as well.

This all seems to be down to a single failed IE9 update, which possibly was interrupted by a power failure or crash?

You can't find most of the files on the DVD - they are almost all from the update itself.
My System SpecsSystem Spec
17 Oct 2013   #7
bubur

Windows 7 home premium 64 bits
 
 

Hi Noel,

You are right, there was a power failure when updating the computer to IE9.

I also managed to update to IE 10.

Thanks for all your help!

Bubur
My System SpecsSystem Spec
17 Oct 2013   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You're welcome - good luck!
My System SpecsSystem Spec
Reply

 Windows 7:can't install SP1 x64. Error:TRUST_E_NOSIGNATURE(0x800b0100)




Thread Tools





Similar help and support threads
Thread Forum
Windows 7 - SP 1 Install Error: Trust_E_NOSIGNATURE(0x800b0100)
Have tried unsuccessfully to install SP1 for Windows 7 x64 system on my PC on numerous occasions. Decided to try and solve problem once and for all and have scoured the forum which appears to have offered helpful advice to other people with similar difficulties. I have downloaded and installed...
Windows Updates & Activation
Win7 Ultimate x64 - SP1 install error: TRUST_E_NOSIGNATURE(0x800b0100)
I am having a problem installing SP1 onto my Windows 7 Ultimate x64 machine, and I've seen on this forum that I am not the only one. I've tried installing SP1 via Windows Update and manually by downloading and running the SP1 ISO. I keep receiving the error: "Error on SP1 installation :...
Windows Updates & Activation
TRUST_E_NOSIGNATURE(0x800b0100) windows 7 sp1 install failed
I have been receiving this error message every time I attempt to install new updates. I randomly get the 8024200D error code as well. I have ran the SFC /SCANNOW command and there were no files found during the scan. I have disabled my firewall and anti virus and tried installing the updates. I...
Windows Updates & Activation
Windows 7 Updates Not installing Error TRUST_E_NOSIGNATURE(0x800b0100
Hi I recently Installed Windows 7 Ultimate 64bit and when updates and SP1 try to install i get this error TRUST_E_NOSIGNATURE(0x800b0100). Please don't tell me to re install windows because i only just did after my old hard drive failed.I found a thread on these forums where somone had a very...
Windows Updates & Activation
Windows 7 Updates Not installing Error TRUST_E_NOSIGNATURE 0x800b0100
Hi, I've been trying to update a PC running Win 7 HP x64 to SP1 and it keeps failing giving me the error in the thread title. I've done all the standard stuff for this error (ran System Update Readiness Tool etc...) and nothing is fixing it. I've attached the CheckSUR.log to this post. If...
Windows Updates & Activation
Windows 7 - Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100)
Hello everyone, Cannot install SP1 for Windows 7 no matter what I tried. Not sure what files I need to restore CBS catalog, Need help. I attached CheckSUR.log Thanks everyone for the help.
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App