Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to update to Windows 7 SP1. TRUST_E_NOSIGNATURE (0x800b0100)

10 Dec 2013   #1

Windows 7 64-bit
 
 
Unable to update to Windows 7 SP1. TRUST_E_NOSIGNATURE (0x800b0100)

Hi All,

I just joined.

After trying almost every method listed on the Internet, I give up trying to install Windows 7 SP1.

Here's what I've done so far:

-I've run sfc /scannow and it came back OK.
-Turned off all AV, Malware, Firewalls.
-Updated every driver I could.
-Applied every hotfix I could
-Downloaded and tried to run the SP1 from ISO image. Still nothing.
-Ran Lenovo Toolbox to updated whatever else I could. But I'll still get the "Trust error".

I've never had such an issue before updating. Really frustrating.

I ran the readiness tool and attached the persist log in the C:Windows\Logs\CBS directory.

Any help is appreciated. And if I need to add any additional information, please let me know and I will do so.

Thanks in advance.




Attached Files
File Type: zip CBS.zip (661.9 KB, 1 views)
My System SpecsSystem Spec
.

11 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

The CheckSUR log reveals the following problems...
Code:
Unavailable repair files:
 winsxs\manifests\msil_system_b77a5c561934e089_6.1.7600.20960_none_9847e45631eced47.manifest
 winsxs\manifests\msil_system.resources_b77a5c561934e089_6.1.7600.20960_en-us_50b433a8b08e3fda.manifest
 winsxs\manifests\amd64_netfx-system_b03f5f7f11d50a3a_6.1.7600.20960_none_a88b599c1721191c.manifest
 winsxs\manifests\amd64_netfx-system_b03f5f7f11d50a3a_6.1.7600.16809_none_bf523197fd8007b5.manifest
 winsxs\manifests\msil_system.resources_b77a5c561934e089_6.1.7600.16809_en-us_677b0ba496ed2e73.manifest
 winsxs\manifests\msil_system_b77a5c561934e089_6.1.7600.16809_none_af0ebc52184bdbe0.manifest
 servicing\packages\Package_1_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_1_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_2_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_2_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_4_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_4_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_for_KB2539634_RTM~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_for_KB2539634_RTM~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.mum
 servicing\packages\Package_1_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_1_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_2_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_2_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_4_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_4_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_for_KB2539634_RTM~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_for_KB2539634_RTM~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
 servicing\packages\Package_for_KB2539634~31bf3856ad364e35~amd64~~6.1.1.0.cat
SFC found nothing of note.

I'll post a fix protocol for the CheckSUR failures later.
My System SpecsSystem Spec
11 Dec 2013   #3

Windows 7 64-bit
 
 
Looking forward to it. Thanks

Thanks Noel. Looking forward to trying it out when you post it.

If you have time, to satisfy my engineering curiosity (and maybe others as well)...how come these packages go missing? I didn't really do much to this particular machine, so I was surprised when it had such issues.
My System SpecsSystem Spec
.


11 Dec 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

It's not that the files are missing as such - they are present, but all appear to be empty
This usually occurs where an update install gets interrupted suddenly for some reason (at least that's my guess)- possibly a power outage or a crash at just the wrong time.

back later.
My System SpecsSystem Spec
11 Dec 2013   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I've uploaded a file - gk7aa.zip - to my SkyDrive at Noel's SkyDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder gk7aa in the same place.
Open this folder - there should be two folders inside it (Manifests, and Packages)

Copy the content of the Packages folder to the folder
C:\Windows\Temp\CheckSur\Servicing\Packages

And the content of the manifests folder (.manifest files) into this folder:

C:\Windows\Temp\CheckSur\Winsxs\Manifests

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.
My System SpecsSystem Spec
11 Dec 2013   #6

Windows 7 64-bit
 
 

Ok, followed you instructions. Ran the CheckSUR tool and logs are attached below.

Tried to run the ISO again from DVD, same Trust E No Sig error.

Here are the latest logs:


Attached Files
File Type: zip CBS.zip (34.7 KB, 1 views)
My System SpecsSystem Spec
12 Dec 2013   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

CheckSUR is clear now.
Odd that you should be getting the same error still, but it may be that a dll file has become unregistered somehow...

Open an Elevated Command Prompt, and run the following commands...

Code:
 
net stop wuauserv 
regsvr32 wuapi.dll /s 
regsvr32 wups.dll /s 
regsvr32 wuaueng.dll /s 
regsvr32 wucltui.dll /s 
regsvr32 wuweb.dll /s 
regsvr32 msxml.dll /s 
regsvr32 msxml2.dll /s 
regsvr32 msxml3.dll /s 
regsvr32 urlmon.dll /s 
regsvr32 softpub.dll /s 
regsvr32 initpki.dll /s 
regsvr32 mssip32.dll /s 
regsvr32 wintrust.dll /s 
regsvr32 dssenh.dll /s 
regsvr32 rsaenh.dll /s 
regsvr32 gpkcsp.dll /s 
regsvr32 sccbase.dll /s 
regsvr32 slbcsp.dll /s 
regsvr32 cryptdlg.dll /s 
regsvr32 jscript.dll /s
net start wuauserv 

.
then reboot, and try the update again - from the standalone installer, would probably be best.
My System SpecsSystem Spec
12 Dec 2013   #8

Windows 7 64-bit
 
 
Windows SP1 Installation Error Resolved.

Thanks Noel. I tried installation from the ISO image and it was a no-go.

However, on a whim I tried it through Windows Update. It worked and installed no problems.

Thanks very much for your help!! Worked perfectly.



Just an FYI to others reading this. You'll want to run "Check Updates" several times and reboot several more after installation of SP1. I think there were close to 90 various "important updates", most being Security fixes. Overall it took about 2 hours or so after installation of SP1. It is a slow process, but just let it run until it's happy.

Good luck to all that have this annoying issue.
My System SpecsSystem Spec
12 Dec 2013   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

From the sound of it, you may have fallen into the trap of attempting to run the installer from a virtual CD/DVD?? If so, that may have been what stalled it the last time - Windows doesn't much like that type of thing for major updates like Service Packs

If you actually created a physical disk, then it's possible that either the download was corrupt, or the burn failed.


Whatever, You have got a nice new updated OS to play with - have fun!
My System SpecsSystem Spec
Reply

 Unable to update to Windows 7 SP1. TRUST_E_NOSIGNATURE (0x800b0100)




Thread Tools



Similar help and support threads for2: Unable to update to Windows 7 SP1. TRUST_E_NOSIGNATURE (0x800b0100)
Thread Forum
Solved Windows 7:can't install SP1 x64. Error:TRUST_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
trust_e_nosignature 0x800b0100 windows 7 Windows Updates & Activation
Windows 7 - SP 1 Install Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
TRUST_E_NOSIGNATURE(0x800b0100) windows 7 sp1 install failed Windows Updates & Activation
Windows 7 - Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:11 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33