Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 9C59 error when installing IE10

10 Jan 2014   #11
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Sorry about the delay - I've been fighting a Cryptolocker infection on a friend's machine

Let's check the permissions on that folder (if it still exists) and the folder above it...
Open an Elevated Command Prompt and run the following commands..

ATTRIB C:\Windows\Temp
ICACLS C:\Windows\Temp
ATTRIB C:\Windows\TEMP\IE1ED3B.tmp
ICACLS C:\Windows\TEMP\IE1ED3B.tmp

post the results.

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.


My System SpecsSystem Spec
.
10 Jan 2014   #12
bwideman

Windows 7 32bit
 
 

Here are the results I got:


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Windows\system32>ATTRIB C:\Windows\Temp
C:\Windows\Temp
C:\Windows\system32>ICACLS C:\Windows\Temp
C:\Windows\Temp BUILTIN\UsersCI)(S,WD,AD,X)
BUILTIN\AdministratorsF)
BUILTIN\AdministratorsOI)(CI)(IO)(F)
NT AUTHORITY\SYSTEMF)
NT AUTHORITY\SYSTEMOI)(CI)(IO)(F)
CREATOR OWNEROI)(CI)(IO)(F)
Successfully processed 1 files; Failed processing 0 files
C:\Windows\system32>ATTRIB C:\Windows\TEMP\IE1ED3B.tmp
File not found - C:\Windows\TEMP\IE1ED3B.tmp
C:\Windows\system32>ICACLS C:\Windows\TEMP\IE1ED3B.tmp
C:\Windows\TEMP\IE1ED3B.tmp: The system cannot find the file specified.
Successfully processed 0 files; Failed processing 1 files
C:\Windows\system32>



The second temp file does not appear to be there.
My System SpecsSystem Spec
10 Jan 2014   #13
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

All that output is as expected - the folder should have been deleted when WU failed (but I was hoping that something had prevented it).

I'll do some research and get back to you in a day or so.
My System SpecsSystem Spec
.

10 Jan 2014   #14
bwideman

Windows 7 32bit
 
 

Ok sounds good!
My System SpecsSystem Spec
14 Jan 2014   #15
bwideman

Windows 7 32bit
 
 

Just checking in to see if you had come up with anything new.
My System SpecsSystem Spec
14 Jan 2014   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Run the fixit from here....
http://support.microsoft.com/kb/971058

This should reset WU.
Once complete, reboot, then do a manual check for updates - attempt to install only the oldest update found and see what happens.
If it installs, try with the rest.

If it fails, post the new windowsupdate.log and csb.log files.
My System SpecsSystem Spec
14 Jan 2014   #17
bwideman

Windows 7 32bit
 
 

Still failed. I have attached the files that you requested.
My System SpecsSystem Spec
14 Jan 2014   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

This appears to be the critical failure point...
Code:
2014-01-14 13:15:31, Info                  CBS    Exec: Staging Package: Package_4_for_KB2744842~31bf3856ad364e35~x86~~6.1.1.0, Update: 2744842-36_neutral_GDR, PinDeployment: x86_187ef6b6de3745e82a45395135f533c4_31bf3856ad364e35_8.0.7601.17940_none_daae4ba5a7ec6e7e
2014-01-14 13:15:32, Info                  CBS    Failed to find file: x86_microsoft-windows-ie-iecompat_31bf3856ad364e35_8.0.7601.21789_none_bdf42a481f80149c\iecompat.dll [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2014-01-14 13:15:32, Info                  CBS    Failed to gather all required files. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2014-01-14 13:15:32, Info                  CBS    Failed to gather all missing files for package: Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~10.2.9200.16521 [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2014-01-14 13:15:32, Info                  CSI    0000015f@2014/1/14:18:15:32.077 CSI Transaction @0x389e00 destroyed
2014-01-14 13:15:32, Error                 CBS    Failed to pre- stage package: Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~10.2.9200.16521 [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2014-01-14 13:15:32, Info                  CBS    Perf: Stage chain complete.
2014-01-14 13:15:32, Info                  CBS    Failed to stage execution chain. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
This correlates with the following error in the WU log
Code:
2014-01-14 13:15:39:480 4040 9c4 Handler   : WARNING: Command line install completed. Return code = 0x00009c59, Result = Failed, Reboot required = false
2014-01-14 13:15:39:480  972 17c AU >>##  RESUMED  ## AU: Installing update [UpdateId = {87E13ECB-C669-43BE-9E2A-01E567285031}]
2014-01-14 13:15:39:480  972 17c AU   # WARNING: Install failed, error = 0x80070643 / 0x00009C59
2014-01-14 13:15:39:480 4040 9c4 Handler   : WARNING: Exit code = 0x8024200B
The odd thing is that WU seems to be saying that all updates were already downloaded - and yet the fixit was supposed to rename the folder that contains them...

...and earlier in the report, there's three updates which DID install?
Code:
2014-01-14 13:13:47:409  972 8e4 Report REPORT EVENT: {B3994C6F-864C-4C17-B5D9-06DADC592CB3} 2014-01-14 13:13:46:942-0500 1 183 101 {D3421098-9E58-422C-9916-B64E06C5BC7B} 201 0 AutomaticUpdates Success Content Install Installation Successful: Windows successfully installed the following update: Security Update for Windows 7 (KB2913602)
2014-01-14 13:13:47:409  972 8e4 Report REPORT EVENT: {11A11196-D09B-42C5-8558-4030EFDA8D6A} 2014-01-14 13:13:46:957-0500 1 183 101 {359E8043-3A90-419F-9B14-EC76A1F08D47} 200 0 AutomaticUpdates Success Content Install Installation Successful: Windows successfully installed the following update: Update for Windows 7 (KB2913431)
2014-01-14 13:13:47:409  972 8e4 Report REPORT EVENT: {2BD42C86-0603-4CAC-B43E-26DBEA13F23C} 2014-01-14 13:13:46:988-0500 1 183 101 {0D8BC70F-BB18-4ED0-A960-7BAC8D81A1B2} 202 0 AutomaticUpdates Success Content Install Installation Successful: Windows successfully installed the following update: Security Update for Windows 7 (KB2862330)
2014-01-14 13:13:47:409  972 8e4 Report REPORT EVENT: {239EEBF9-6CDD-42E6-8FE1-D4DBED844FE3} 2014-01-14 13:13:47:409-0500 1 188 102 {00000000-0000-0000-0000-000000000000} 0 0 AutomaticUpdates Success Content Install Installation Ready: The following updates are downloaded and ready for installation. This computer is currently scheduled to install these updates on €ŽThursday, €ŽJanuary €Ž16, €Ž2014 at 2:00 PM:  - Internet Explorer 10 for Windows 7
So the problem is not with the WU system, but with that specific update/install.

Please attempt installation using the standalone update from here.
Download Internet Explorer 10 - Microsoft Windows
Make sure that you pick the Win 7 x86 32-bit version, and your base language.
My System SpecsSystem Spec
14 Jan 2014   #19
bwideman

Windows 7 32bit
 
 

I have been able to install all of the other updates that I had besides IE10. I pulled those 3 from the web just to make sure it wasn't an update stopping me. They installed fine. I have tried the standalone and tried again, still not working.
My System SpecsSystem Spec
14 Jan 2014   #20
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

The missing file appears to be from IE8

Please open an Elevated Command Prompt, and run the following commands...

Code:
 
DIR C:\Windows\x86_microsoft-windows-ie-iecompat_31bf3856ad364e35_8.0.7601.21789_none_bdf42a481f80149c
ICACLS C:\Windows\x86_microsoft-windows-ie-iecompat_31bf3856ad364e35_8.0.7601.21789_none_bdf42a481f80149c /T
.
.
post the results.
My System SpecsSystem Spec
Reply

 9C59 error when installing IE10




Thread Tools




Similar help and support threads
Thread Forum
IE10 & IE 11 installation error 9C59
Hello everybody, I've got a user at work on a Dell Windows 7 Pro 32 bit (OEM) machine. It is up to date on pretty much everything except Internet Explorer and I'm trying to fix that by installing the new versions but to no avail. I followed the sticky and ran SURT and the SFC Scan. Attached...
Windows Updates & Activation
Loading IE10 via WSUS gives me a 9c59 error
I read another thread that you guys help someone out with where he was having the same issue I am having: http://www.sevenforums.com/windows-updates-activation/282495-cannot-install-ie10-update.html You guys suggested for anyone else to start a new thread so here I am. I have tried numerous...
Windows Updates & Activation
Cannot install IE10 Update - Error 9C59
Hello, I've installed Windows 7 64 bit home premium new on my laptop after it had a virus. All updates worked fine except IE 10. Here are the log file. Can you help me please? I've installed Windows6.1-KB947821-v28-x64 already two times. I've tried already to install the IE 10 like 5...
Windows Updates & Activation
Error code 9c59 and 0x80070643 when installing IE10 in Win 7 64-bit
Hi guys, I am getting the error 9c59 when installing IE 10 in Windows 7 Home Premium 64-bit. In event viewer the error code 0x80070643 is shown, reading up on this Microsoft suggests it has something to do with .net framework 4 and that this should have a repair install run. I did this but it...
Windows Updates & Activation
IE10 error:9C59
This error is driving me mad. I have been through pretty much every search result I can find and still no luck solving it. I have followed the posting instructions. Sfc was fine, but my SURT has 3 issues that I'm not sure how to fix. I would really appreciate it if I could get some help with...
Windows Updates & Activation
Error 9C59 While trying to install IE10 on Win7
I have tried to use Windows update to install IE10 (it was offered as an update). Downloaded ok, but failed with error 9C59. Followed instructions for manually installing all prerequisite for this update. Only one that failed was 2533623 (said it was not available for this environment). Ran the...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App