Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 64 bit SP1 Problem

05 Jan 2014   #31
CowboyJunkie

Windows 7 64 bit
 
 

Well I have tried to install SP1 via the manual installer and got the same error message! File not found. Shall I attempt to install the readiness update again?

I have uploaded the latest windowsupdate log for you to check.


My System SpecsSystem Spec
.
06 Jan 2014   #32
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the error sequence...
Code:
2014-01-05 13:52:35:146 1204 e94 Misc Validating signature for C:\Windows\SoftwareDistribution\WuRedir\7971F918-A847-4430-9279-4A52D1EFE18D\wuredir.cab:
2014-01-05 13:52:35:158 1204 e94 Misc  Microsoft signed: Yes
2014-01-05 13:52:35:173 1204 e94 DnldMgr Regulation server path: https://update.microsoft.com/v6/Upda...egulation.asmx.
2014-01-05 13:52:36:249 1204 e94 DnldMgr   * Regulation call complete. 0x00000000
2014-01-05 13:52:36:289 1204 e94 DnldMgr ***********  DnldMgr: New download job [UpdateId = {E7919EF5-4E2A-4EBE-B5C2-F3FB72C1F451}.103]  ***********
2014-01-05 13:52:36:306 1204 e94 DnldMgr   * All files for update were already downloaded and are valid.
2014-01-05 13:52:36:306 1204 e94 DnldMgr ***********  DnldMgr: New download job [UpdateId = {0BC76EFA-678D-4351-A718-77B8A6D7B32A}.103]  ***********
2014-01-05 13:52:36:574 1204 e94 DnldMgr   * All files for update were already downloaded and are valid.
2014-01-05 13:52:36:574 1204 e94 DnldMgr ***********  DnldMgr: New download job [UpdateId = {F9164872-3E27-4410-B4FC-038814549BB1}.103]  ***********
2014-01-05 13:52:36:575 1204 e94 DnldMgr   * Queueing update for download handler request generation.
2014-01-05 13:52:36:575 1204 e94 DnldMgr ***********  DnldMgr: New download job [UpdateId = {ADC2C441-677D-4C62-BEC4-3CA015C769C3}.103]  ***********
2014-01-05 13:52:36:596 1204 e94 DnldMgr   * All files for update were already downloaded and are valid.
2014-01-05 13:52:36:596 1204 e94 DnldMgr Generating download request for update {F9164872-3E27-4410-B4FC-038814549BB1}.103
2014-01-05 13:52:50:136 1204 1170 AU Launched new AU client for directive 'Download Progress', session id = 0x1
2014-01-05 14:00:19:336 1204 e94 Handler Generating request for CBS update F9164872-3E27-4410-B4FC-038814549BB1 in sandbox C:\Windows\SoftwareDistribution\Download\fd0c7235ea199c91f68801d3ffaa13a5
2014-01-05 14:00:19:405 1204 e94 Handler Selected payload type is ptExpress
2014-01-05 14:00:19:511 1204 e94 Handler UH: DpxRestoreJob returned 0x80070002
2014-01-05 14:00:19:511 1204 e94 Handler Detected download state is dsHavePackage

... for some reason, it's still demanding that non-existent file, but claims that all necessary files have been downloaded.


However, earlier in the log, it shows that the folder is definitely present...
Code:
2014-01-02 13:03:51:585 1212 fbc Misc Validating signature for C:\Windows\SoftwareDistribution\Download\fd0c7235ea199c91f68801d3ffaa13a5\windows6.1-kb976932-x64-express.cab:
2014-01-02 13:03:55:833 1212 fbc Misc  Microsoft signed: Yes
2014-01-02 13:03:55:848 1212 fbc DnldMgr   Download job bytes total = 77199427, bytes transferred = 42311941
Note that this is from a few days ago, though.


I wonder.. are you using any form of automated cleanup tool?
Let's check the permissions etc on the Download folder...

Please run the following commands, and post the results.

ICACLS C:\Windows\SoftwareDistribution\Download
ATTRIB C:\Windows\SoftwareDistribution\Download
My System SpecsSystem Spec
06 Jan 2014   #33
CowboyJunkie

Windows 7 64 bit
 
 

There was a few suspicious pc tune up apps installed but I removed them a couple of weeks ago when I was given the laptop. The only cleanup program I have is CCleaner (which I used to clean the registry but it's not on a scheduled scan).

I'll post the results when I log onto the other laptop.
My System SpecsSystem Spec
.

06 Jan 2014   #34
CowboyJunkie

Windows 7 64 bit
 
 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ICACLS C:\Windows\SoftwareDistribution\Download
C:\Windows\SoftwareDistribution\Download BUILTIN\AdministratorsI)(F)
BUILTIN\AdministratorsI)(OI)(CI)(IO)(
F)
NT AUTHORITY\SYSTEMI)(F)
NT AUTHORITY\SYSTEMI)(OI)(CI)(IO)(F)
BUILTIN\UsersI)(OI)(CI)(RX)
NT AUTHORITY\Authenticated UsersI)(M)

NT AUTHORITY\Authenticated UsersI)(OI
)(CI)(IO)(M)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ATTRIB C:\Windows\SoftwareDistribution\Download
C:\Windows\SoftwareDistribution\Download

C:\Windows\system32>
My System SpecsSystem Spec
06 Jan 2014   #35
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Ah - I see no TrustedInstaller entry there!

Please open an Elevated Command Prompt and run the following commands

ICACLS C:\Windows\SoftwareDistribution /grant "NT Service\TrustedInstaller":(F)
ICACLS C:\Windows /grant "NT Service\TrustedInstaller":(F)
ICACLS C:\Windows /grant "NT Service\TrustedInstaller":(CI)(IO)(F)
ICACLS C:\Windows\SoftwareDistribution\Download /grant "NT Service\TrustedInstaller":(F)

Post the results, then reboot, and try SP1 again.
My System SpecsSystem Spec
07 Jan 2014   #36
CowboyJunkie

Windows 7 64 bit
 
 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ICACLS C:\Windows\SoftwareDistribution /grant "NT Service\Tr
ustedInstaller"F)
processed file: C:\Windows\SoftwareDistribution
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows /grant "NT Service\TrustedInstaller"F)
processed file: C:\Windows
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows /grant "NT Service\TrustedInstaller"CA)(
IO)(F)
Invalid parameter "NT Service\TrustedInstallerCA)(IO)(F)"

C:\Windows\system32>ICACLS C:\Windows\SoftwareDistribution\Download /grant "NT S
ervice\TrustedInstaller"F)
processed file: C:\Windows\SoftwareDistribution\Download
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>
C:\Windows\system32>I
'I' is not recognized as an internal or external command,
operable program or batch file.

C:\Windows\system32>
C:\Windows\system32>
C:\Windows\system32>

Not sure whether I pressed "I" when the commands were running! I'll try the SP1 installer now and let you know.
My System SpecsSystem Spec
07 Jan 2014   #37
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I made a small typo - but I don't think it's likely to affect things too much.

Whether it works or not, please run the following commands afterwards, and post the results

ICACLS C:\Windows
ICACLS C:\Windows\SoftwareDistribution
ICACLS C:\Windows\SoftwareDistribution\Download
My System SpecsSystem Spec
07 Jan 2014   #38
CowboyJunkie

Windows 7 64 bit
 
 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ICACLS C:\Windows
C:\Windows NT SERVICE\TrustedInstallerF)
BUILTIN\AdministratorsI)(F)
BUILTIN\AdministratorsI)(OI)(CI)(IO)(F)
NT AUTHORITY\SYSTEMI)(F)
NT AUTHORITY\SYSTEMI)(OI)(CI)(IO)(F)
BUILTIN\UsersI)(OI)(CI)(RX)
NT AUTHORITY\Authenticated UsersI)(M)
NT AUTHORITY\Authenticated UsersI)(OI)(CI)(IO)(M)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\SoftwareDistribution
C:\Windows\SoftwareDistribution NT SERVICE\TrustedInstallerF)
BUILTIN\AdministratorsI)(F)
BUILTIN\AdministratorsI)(OI)(CI)(IO)(F)
NT AUTHORITY\SYSTEMI)(F)
NT AUTHORITY\SYSTEMI)(OI)(CI)(IO)(F)
BUILTIN\UsersI)(OI)(CI)(RX)
NT AUTHORITY\Authenticated UsersI)(M)
NT AUTHORITY\Authenticated UsersI)(OI)(CI)(IO)
(M)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\SoftwareDistribution\Download
My System SpecsSystem Spec
07 Jan 2014   #39
CowboyJunkie

Windows 7 64 bit
 
 

Ok, I ran the manual update before i saw this and I got a different error message (screen 2), I then ran the commands (results in previous post). I re ran the manual update and I got the file missing error again (screen 3). I have zipped a new Windows update log for you to review.
My System SpecsSystem Spec
07 Jan 2014   #40
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The final command in that set didn't run - and it's possibly the most important one, even if it is for information only..

Please run this command and post the results....

ICACLS C:\Windows\SoftwareDistribution\Download
My System SpecsSystem Spec
Reply

 Windows 7 64 bit SP1 Problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Printer problem needs guru. Looks like Windows not Brother problem.
Windows 7 Professional Haven't had the need to use my printer in a couple of weeks, so I don't know when the problem started. It is a Brother HL-2270DW that has been problem free. There are tests that can be tried using the printer itself and it says it has a good connection and should be...
General Discussion
UI Problem/ minimized windows Display problem
Hi windows 7 community, I have a problem with windows 7 since the first day i've installed the OS (couple of years), and i haven't been able to solve it yet. The problem is that when i have a main application window, and different documents(windows) open in that main application window, when i...
General Discussion
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Windows 7 Not genuine Problem. And 404 error (security?) Problem.
Hi, ive had both of these problems for about two weeks and have tried to fix it myself. No luck at all. Dont no of their connected. Help on how to fix it would be greatly appreciated.
BSOD Help and Support
Windows Media Player Problem - Sound/skipping problem.
Oh look, another windows media player problem, lol. Well, it's something really weird, at first i thought it was just my computer being all slow or the file was messed up, No matter what movie or format i play it makes this weird screeching noise. It also lags pretty bad. I tried the scans, i did...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App