Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Home Premium 32bit SP1 Update is failing, error 0x800f0900

08 Feb 2014   #21
waleslie

Windows 7 Home Premium 32bit
 
 

Okay. Looks like it went well...

C:\Windows\system32>ICACLS C:\Windows
C:\Windows NT SERVICE\TrustedInstallerF)
NT SERVICE\TrustedInstallerCI)(IO)(F)
NT AUTHORITY\SYSTEMM)
NT AUTHORITY\SYSTEMOI)(CI)(IO)(F)
BUILTIN\AdministratorsM)
BUILTIN\AdministratorsOI)(CI)(IO)(F)
BUILTIN\UsersRX)
BUILTIN\UsersOI)(CI)(IO)(GR,GE)
CREATOR OWNEROI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\winsxs
C:\Windows\winsxs BUILTIN\AdministratorsOI)(CI)(F)
NT SERVICE\TrustedInstallerOI)(CI)(F)
NT AUTHORITY\SYSTEMOI)(CI)(F)
BUILTIN\UsersOI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\winsxs\x86_volume.inf_31bf3856ad364e35_6.1
.7600.17122_none_15cad1ba5d3abbe6
C:\Windows\winsxs\x86_volume.inf_31bf3856ad364e35_6.1.7600.17122_none_15cad1ba5d
3abbe6 BUILTIN\AdministratorsI)(OI)(CI)(F)

NT SERVICE\TrustedInstallerI)(OI)(CI)(F)

NT AUTHORITY\SYSTEMI)(OI)(CI)(F)

BUILTIN\UsersI)(OI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\winsxs\x86_avc.inf_31bf3856ad364e35_6.1.76
00.16385_none_ac2fa38af371acee
C:\Windows\winsxs\x86_avc.inf_31bf3856ad364e35_6.1.7600.16385_none_ac2fa38af371a
cee BUILTIN\AdministratorsI)(OI)(CI)(F)

NT SERVICE\TrustedInstallerI)(OI)(CI)(F)

NT AUTHORITY\SYSTEMI)(OI)(CI)(F)

BUILTIN\UsersI)(OI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>


LOL. I like that all of the ": ("s became frowny faces.


My System SpecsSystem Spec
.
08 Feb 2014   #22
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That's normal - it's the forums software trying to be helpful :)
You could almost get away with the current permissions - but we'd better reset the ownership and reduce the access a little.

Open an Elevated Command Prompt, and run the following commands.

ICACLS C:\Windows\winsxs /remove Users
ICACLS C:\Windows\winsxs /grant Users:(OI)(CI)(RX)
ICACLS C:\Windows\winsxs /remove "NT AUTHORITY\SYSTEM"
ICACLS C:\Windows\winsxs /grant "NT AUTHORITY\SYSTEM":(OI)(CI)(RX)
ICACLS C:\Windows\winsxs /remove Administrators
ICACLS C:\Windows\winsxs /grant Administrators:(OI)(CI)(RX)
ICACLS C:\Windows\Winsxs /setowner "NT SERVICE\TrustedInstaller" /T /C /Q
ICACLS C:\Windows\Winsxs

Post the results, and then reboot. (note that the /setowner one could take a fair while to complete!)

then run the earlier commands (from post #20) again so we can check the results.
My System SpecsSystem Spec
09 Feb 2014   #23
waleslie

Windows 7 Home Premium 32bit
 
 

I watched for a bit, and the first several commands appeared successful.

The ICACLS C:\Windows\Winsxs /setowner "NT SERVICE\TrustedInstaller" /T /C /Q command failed with Access is denied errors on every file. The results of the earlier commands scrolled back too far. Here's the end of it:

C:\Windows\Winsxs\x86_xnacc.inf_31bf3856ad364e35_6.1.7600.16385_none_b381dfe1d4d
a7da9\xnacc.inf: Access is denied.
C:\Windows\Winsxs\x86_xnacc.inf_31bf3856ad364e35_6.1.7600.16385_none_b381dfe1d4d
a7da9\xnacc.sys: Access is denied.
Successfully processed 0 files; Failed processing 61605 files

C:\Windows\system32>ICACLS C:\Windows\Winsxs
C:\Windows\Winsxs NT AUTHORITY\SYSTEMOI)(CI)(RX)
BUILTIN\UsersOI)(CI)(RX)
NT SERVICE\TrustedInstallerOI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files


Shall I still reboot and run the commands from post #20? Or do we need to fix what happened here first?
My System SpecsSystem Spec
.

09 Feb 2014   #24
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

We definitely need to fix this - there's something amiss, as the winsxs folder has lost permissions for the Administrators!

Please run the following commands in an Elevated Command Prompt...

TAKEOWN /F C:\Windows\WinSXS /A
ICACLS C:\Windows\Winsxs /grant Administrators:(OI)(CI)(RX)
ICACLS C:\Windows\Winsxs /setowner "NT SERVICE\TrustedInstaller"
ICACLS C:\Windows\Winsxs

post the results before rebooting.
My System SpecsSystem Spec
09 Feb 2014   #25
waleslie

Windows 7 Home Premium 32bit
 
 

Here are the results from that. Reboot now? What next?

C:\Windows\system32>TAKEOWN /F C:\Windows\WinSXS /A

SUCCESS: The file (or folder): "C:\Windows\WinSXS" now owned by the administrato
rs group.

C:\Windows\system32>ICACLS C:\Windows\Winsxs /grant AdministratorsOI)(CI)(RX)
processed file: C:\Windows\Winsxs
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\Winsxs /setowner "NT SERVICE\TrustedInstal
ler"
C:\Windows\Winsxs: Access is denied.
Successfully processed 0 files; Failed processing 1 files

C:\Windows\system32>ICACLS C:\Windows\Winsxs
C:\Windows\Winsxs BUILTIN\AdministratorsOI)(CI)(RX)
NT AUTHORITY\SYSTEMOI)(CI)(RX)
BUILTIN\UsersOI)(CI)(RX)
NT SERVICE\TrustedInstallerOI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files
My System SpecsSystem Spec
09 Feb 2014   #26
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Yep - you can reboot now

I'm not sure why the setowner command failed again - try running that one again after the reboot.
My System SpecsSystem Spec
09 Feb 2014   #27
waleslie

Windows 7 Home Premium 32bit
 
 

Still comes back with Access Denied.
My System SpecsSystem Spec
09 Feb 2014   #28
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Locate the folder in Explorer and right-click on it - select Properties.

click on the Security tab then the Advanced button then the Owner tab - who is the owner now?
My System SpecsSystem Spec
10 Feb 2014   #29
waleslie

Windows 7 Home Premium 32bit
 
 

The current owner of C:\Windows\winsxs is "Administrators (PCSE-Server\Administrators)"
My System SpecsSystem Spec
10 Feb 2014   #30
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Aaarrgghh!! - I just realised what the problem is - I'm restricting permissions before passing over ownership!

Let's try it this way instead....

TAKEOWN /F C:\Windows\WinSXS /A
ICACLS C:\Windows\Winsxs /grant Administrators:(OI)(CI)(F)
ICACLS C:\Windows\Winsxs /setowner "NT SERVICE\TrustedInstaller" /C /T /Q
ICACLS C:\Windows\Winsxs /grant:r Administrators:(OI)(CI)(RX)
ICACLS C:\Windows\Winsxs

post the results (assuming it doesn't scroll off the page!), then reboot, and run the following commands...

ICACLS C:\Windows\winsxs
ICACLS C:\Windows\winsxs\x86_volume.inf_31bf3856ad364e35_6.1.7600.17122_none_15cad1ba5d3abbe6
ICACLS C:\Windows\winsxs\x86_avc.inf_31bf3856ad364e35_6.1.7600.16385_none_ac2fa38af371acee


post those results, and we'll see where we are.
My System SpecsSystem Spec
Reply

 Windows 7 Home Premium 32bit SP1 Update is failing, error 0x800f0900




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Home Premium SP1 - repeated update error 0x80073712
Hey all, I have a lenovo tower running windows 7 home premium service pack 1, all seems to be working great except when I go to do updates, every update is installed except this one nagging one that fails repeatedly. The Update is Security Update KB2847927 and the error code is 0x80073712 ...
Windows Updates & Activation
Windows 7 Home Premium SP1 Update error 0x800B0100
Noel ... I received "again" the “Windows Not Genuine” message screen! System Properties show me “Windows 7 Home Premium”, Windows activation: “Windows is activated, Product ID: 00359-OEM-8882432-58635, The MGADiagnostics tool responds my version is “Genuine” (see below!) Today I received...
Windows Updates & Activation
Update error 800B0100 on Win 7 Home premium 32bit
I have battled this error for awhile and could use some help. I ran SFC with no errors and Check Disk with no errors. I have run the CheckSUR several times with no luck. Here is the output of the CBS.persist.log file: ================================= Checking System Update Readiness. Binary...
Windows Updates & Activation
Windows 7 Home Premium 64bit update error 80073712
Hi, I have encountered an update error while updating my new pc and I would like to have a solution. I downloaded the SURT and installed the hotfix, did the SFC scan as an administrator, tried to do a repair install and failed. The repair install itself cannot be accomplished. Before I...
Windows Updates & Activation
Windows 7 home premium x64 update error 800b0100 for sp1
Keep geting error the error code 800b0100 when I try to update window 7 home premium x64 for service pack 1 when i try to update with the file KB976932 have used surt still no sucess. Hope you can help thanks a bunch. Vicky
Windows Updates & Activation
Windows 7 Home Premium 64bit Update Error
I am running Win 7 Home Premium, 64 bit on a Dell laptop studio xps 16. I am having trouble with Windows Updates. "Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer." No Antivirus installed on the computer. Windows Update...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App