Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows update service not running


02 Feb 2014   #1

Windows 7 ultimate x32
 
 
Windows update service not running

I am running windows 7 ultimate. Windows update says the service is not running, please restart. I have restarted and the problem has persisted.I have checked sevices to see if it is stopped. The windows update service doesn't even show up.... I even tried the command prompt commands but the following happens

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Users\Princess>NET START BFE
The requested service has already been started.
More help is available by typing NET HELPMSG 2185.

C:\Users\Ryan>NET START BITS
The service name is invalid.
More help is available by typing NET HELPMSG 2185.

C:\Users\Ryan>NET START WUAUSERV
The service name is invalid.
More help is available by typing NET HELPMSG 2185.

C:\Users\Ryan>NET START TRUSTEDINSTALLER
The Windows Modules Installer service is starting.
The Windows Modules Installer service was started successfully.


Please help me....


My System SpecsSystem Spec
.

02 Feb 2014   #2

Windows 7 Home Premium 64bit
 
 

My System SpecsSystem Spec
02 Feb 2014   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

A good start - but we need a little more data before attempting a first-fix...

Please download the Farbar Service Scanner from

http://www.bleepingcomputer.com/download/farbar-service-scanner/

Right-click on the saved file and select 'Run as Administrator', and tick all the options, then click on the Scan button - copy and paste the report to your response.

My System SpecsSystem Spec
.


02 Feb 2014   #4

Windows 7 ultimate x32
 
 

Thanks Irene but I have already tried it out and it doesn't work...
My System SpecsSystem Spec
02 Feb 2014   #5

Windows 7 ultimate x32
 
 

Thanks NoelDP. I am posting the report here..

Farbar Service Scanner Version: 02-02-2014
Ran by Princess (administrator) on 02-02-2014 at 22:38:42
Running from "D:\Downloads"
Microsoft Windows 7 Ultimate (X86)
Boot Mode: Normal
****************************************************************

Internet Services:
============

Connection Status:
==============
Localhost is accessible.
LAN connected.
Google IP is accessible.
Google.com is accessible.
Yahoo.com is accessible.


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

wscsvc Service is not running. Checking service configuration:
The start type of wscsvc service is set to Disabled. The default start type is Auto.
The ImagePath of wscsvc service is OK.
The ServiceDll of wscsvc service is OK.

Action Center Notification Icon =====> Unable to open HKLM\...\ShellServiceObjects\{F56F6FDD-AA9D-4618-A949-C1B91AF43B1A} key. The key does not exist.


Windows Update:
============
wuauserv Service is not running. Checking service configuration:
The start type of wuauserv service is set to Disabled. The default start type is Auto.
The ImagePath of wuauserv service is OK.
The ServiceDll of wuauserv service is OK.

BITS Service is not running. Checking service configuration:
The start type of BITS service is OK.
The ImagePath of BITS service is OK.
The ServiceDll of BITS service is OK.


Windows Autoupdate Disabled Policy:
============================


Windows Defender:
==============

Other Services:
==============
Checking FirewallRules of SharedAccess: ATTENTION!=====> Unable to open "SharedAccess\Defaults\FirewallPolicy\FirewallRules" registry key. The key does not exist.


File Check:
========
C:\Windows\system32\nsisvc.dll => MD5 is legit
C:\Windows\system32\Drivers\nsiproxy.sys => MD5 is legit
C:\Windows\system32\dhcpcore.dll => MD5 is legit
C:\Windows\system32\Drivers\afd.sys => MD5 is legit
C:\Windows\system32\Drivers\tdx.sys => MD5 is legit
C:\Windows\system32\Drivers\tcpip.sys
[2013-01-20 11:28] - [2010-04-09 12:54] - 1285000 ____A (Microsoft Corporation) 63170B9EE1D0EF0032F0408605671D1A

C:\Windows\system32\dnsrslvr.dll => MD5 is legit
C:\Windows\system32\mpssvc.dll => MD5 is legit
C:\Windows\system32\bfe.dll => MD5 is legit
C:\Windows\system32\Drivers\mpsdrv.sys => MD5 is legit
C:\Windows\system32\SDRSVC.dll => MD5 is legit
C:\Windows\system32\vssvc.exe => MD5 is legit
C:\Windows\system32\wscsvc.dll => MD5 is legit
C:\Windows\system32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\system32\wuaueng.dll => MD5 is legit
C:\Windows\system32\qmgr.dll => MD5 is legit
C:\Windows\system32\es.dll => MD5 is legit
C:\Windows\system32\cryptsvc.dll => MD5 is legit
C:\Program Files\Windows Defender\MpSvc.dll => MD5 is legit
C:\Windows\system32\ipnathlp.dll => MD5 is legit
C:\Windows\system32\iphlpsvc.dll => MD5 is legit
C:\Windows\system32\svchost.exe => MD5 is legit
C:\Windows\system32\rpcss.dll => MD5 is legit


**** End of log ****
My System SpecsSystem Spec
02 Feb 2014   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

That's an unusual set of errors - it looks like you've had a partial infestation from some variant of the ZeroAccess worm/Trojan.

Before we even attempt to fix this, please check the system over for malware....


Please download and install Malwarebytes Anti-malware (free version) from http://www.malwarebytes.org/products/malwarebytes_free/ - UNtick 'Enable free trial of MBAM PRO' at the end of the installation - and update it, then run a full scan in your main account, and Quick scans in any other user accounts.

Delete everything it finds
My System SpecsSystem Spec
02 Feb 2014   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Once you've run MBAM, we can start rebuilding the system.
First, let's see if we can get the two basic services running - WSCSVC and WUAUSERV
Please run the following commands in a Elevated Command Prompt, and post the results.

SC CONFIG WUAUSERV /start= auto
SC CONFIG WSCSVC /start= auto
NET START WUAUSERV
NET START WSCSVC

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.

I'll work up a patch for the remaining errors and post that in a few minutes.
My System SpecsSystem Spec
16 Feb 2014   #8

Windows 7 ultimate x32
 
 

There was another virus in my system... So i had to format the system and so the other problems were also solved.... thanks... and anti-malware helped a lot.....
My System SpecsSystem Spec
Reply

 Windows update service not running




Thread Tools



Similar help and support threads for2: Windows update service not running
Thread Forum
Windows Update Service Not Running Windows Updates & Activation
Windows Update Service Not Running Windows Updates & Activation
Solved Windows Update, service not running Windows Updates & Activation
windows update service is not running !!! Windows Updates & Activation
Windows Update service not running Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33