Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Updates loop, SFC won't run, SURT doesn't work, Can't System Restore

29 May 2014   #1
TalbotM

Windows 7 Pro 64bit
 
 
Updates loop, SFC won't run, SURT doesn't work, Can't System Restore

How's that for a Topic?

I first noticed the problem while trying to install QuickBooks.
It complained about the .NET framework.
When I went to Add/Remove Windows components, it was blank.
I googled and studied more.
I tried SFC /scan now. "Windows Resource Protection could not perform the requested operation."
Notice Application log is full of 1001 - Windows Error reporting with the following:
WindowsWcpOtherFailure3Not available06.1.7601base\wcp\componentstore\storelayout.cpp

SURT appears to install, but really doesn't run.
There are more symptoms, but that's enough for starters.

CBS logs attached.

I appreciate any help you can offer.
TalbotM


My System SpecsSystem Spec
.
30 May 2014   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The CheckSUR reports this...
Code:
Checking Packages
(f) CSI Unable to Query Store Version 0x00000002
This means that there is a major problem with your registry.

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or OneDrive) and post a link.
My System SpecsSystem Spec
30 May 2014   #3
TalbotM

Windows 7 Pro 64bit
 
 

My System SpecsSystem Spec
.

30 May 2014   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Oh Dear
The file should have been around 40MB uncompressed and 10MB compressed. It was only 704 bytes compressed, and 256KB uncompressed.
This effectively means that unless you are very lucky and have a restore point to which you can return which has the registry hive in it, then your only option is a Repair install of Windows.

See this tutorial for details. - Repair Install
My System SpecsSystem Spec
30 May 2014   #5
TalbotM

Windows 7 Pro 64bit
 
 

System restore is not functioning properly, I'm sad to say. Off to a repair install. Thank you very much for looking at my situation. I appreciate it.
My System SpecsSystem Spec
30 May 2014   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You're welcome - good luck!
My System SpecsSystem Spec
30 May 2014   #7
TalbotM

Windows 7 Pro 64bit
 
 

I just can't win today. "An error prevented a required compliance check from completing. Cancel the installation and try upgrading again."

Incidentally, this is Windows 7 Enterprise. I erred when I said Pro earlier. Of course my installation media matches.
My System SpecsSystem Spec
31 May 2014   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Ouch! - possibly your disk is for RTM and you have SP1 installed?
My System SpecsSystem Spec
02 Jun 2014   #9
TalbotM

Windows 7 Pro 64bit
 
 

Well, I managed to dig up a pretty ancient backup and restore my COMPONENTS store, and things seem to have improved greatly. I can now run SFC (at least to about 54%), and I have re-run SURT. My latest CBS folder is ZIPed here: https://onedrive.live.com/redir?resid=EDDBF4CF74633D11%21642 , would you mind giving it another look? I'm still having a few update issues, but maybe it is just down to missing manifests and such now.
Thanks,
Talbot
My System SpecsSystem Spec
02 Jun 2014   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I can't access the file? - "This item might have been deleted, expired or you might not have permission to view it." - did you remember to Share it?
My System SpecsSystem Spec
Reply

 Updates loop, SFC won't run, SURT doesn't work, Can't System Restore




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Restart loop, system restore doesn't solve the issue
So about a day ago my desktop began displaying the blue screen upon login and then instant restart. I tried startup repair, memory diagnostics tool, system recovery, nothing worked. so i cleared everything on my drive (unforunately) only to find once i got to "set up is preparing your computer for...
Backup and Restore
Win7 HP 64b system restore doesn't work
First time poster here. I'm running Win7 Home Premium 64bit. When I try to do a System Restore, it seems to run to completion, reboots the system and then issues the following message: "System Restore did not complete successfully. Your computer's system files and settings were not...
Backup and Restore
Previous Versions doesn't work (System restore)
Hello, I'm doing everything as said, and the "previous versions" doesn't work. Why? I also did manually a system restore, and it doesn't create a copy of files (for previous versions). What can I do? Thank you, Patrick
Backup and Restore
Windows Update doesn't work after OEM System Restore
New Acer Aspire, but I pitched the box, so can't return it. Anyway, It initially worked fine for about a week, including Windows Update. Got to a point where every window would say (Not Responding) and resources were maxed out. I couldn't isolate the problem and didn't have any valuable info on the...
Windows Updates & Activation
Won't sleep; system restore doesn't work
I noticed about a week ago that my system won't go to sleep unless I force it to sleep using the using the Function and F1 buttons on the keyboard. I also noticed about the same time that I tried to set it to use the ribbon screen saver and that doesn't work either. The screen saver looks fine in...
Backup and Restore
System Restore doesn't work
My Win 7 was installed in February 2010 and at first I could use System Restore without problems. However, after some time it stopped working due to unknown reasons and now when I try to do a System Restore it looks as if it is going to be OK, but when it restarts I see the following error message:...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App