Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot run ie10, cannot install ie9/11 (ie10 installed)

26 Jun 2014   #1
chrisloup

Windows 7 Pro 64 bit / 6.1.7601 Service Pack 1 Build 7601
 
 
Cannot run ie10, cannot install ie9/11 (ie10 installed)

ok, I believe this is due to some bad windows update, but there isn't a list that i can locate to uninstall.

I've already tried force uninstall all remnants,

using:
---
FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*11.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"

FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*10.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"


FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*9.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"
---



after a reboot, I will get IE8., then I am able to only install ie10. (I've already tried installing ie9/ie11 with the antivirus uninstalled with no effect)

in the windows update screen.
ie11 fails with 9c59,
ie9 fails with 3715


---
When I run IE10, it will load up, for a while (white completely devoid of any text/icons/menu) then close with no error message (even in eventlog) , I've tried reset to default settings/restore advanced settings from control panel\internet options\advanced tab.

KB2846071 does not appear to be installed.


My System SpecsSystem Spec
.
26 Jun 2014   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The CBS log shows this problem...
Code:
2014-06-26 23:34:44, Info                  CSI    0000033b Couldn't find the hash of component: Microsoft-Windows-IE-HTMLRenderingMedia, Version = 11.2.9600.16428, pA = PROCESSOR_ARCHITECTURE_IA32_ON_WIN64 (10), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the catalog [l:192{96}]"\SystemRoot\WinSxS\Catalogs\f967e3adade5a1edc1e6d622347f3de0c670e610d5a708a65aa0059ef98a0455.cat".
2014-06-26 23:34:44, Error                 CSI    0000033c@2014/6/26:15:34:44.100 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_winners.cpp(1302): Error 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] originated in function CCSDirectTransaction::AddImplicationsToCatalogsAndVerifyComponentHashes expression: (null)
[gle=0x80004005]
2014-06-26 23:34:44, Error                 CSI    0000033d (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #6917973# from CCSDirectTransaction::PrepareForCommit(...)[gle=0x90092004]
2014-06-26 23:34:44, Error                 CSI    0000033e (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #6917972# from CCSDirectTransaction::ExamineTransaction(...)[gle=0x90092004]
2014-06-26 23:34:44, Error                 CSI    0000033f (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #6917971# from CCSDirectTransaction_IRtlTransaction::ExamineTransaction(...)[gle=0x90092004]
2014-06-26 23:34:44, Error                 CSI    00000340 (F) CRYPT_E_NOT_FOUND #6917651# from Windows::COM::CPendingTransaction::IStorePendingTransaction_Analyze(...)[gle=0x80092004]
2014-06-26 23:34:44, Error                 CSI    00000341 (F) CRYPT_E_NOT_FOUND #6917116# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_Commit(Flags = 38 (0x00000026), pSink = NULL, disp = 0, coldpatching = FALSE)[gle=0x80092004]
2014-06-26 23:34:44, Error                 CSI    00000342 (F) CRYPT_E_NOT_FOUND #6917115# 948045 us from Windows::ServicingAPI::CCSITransaction_ICSITransaction::Commit(flags = 0x00000026, pSink = NULL, disp = 0)
[gle=0x80092004]
2014-06-26 23:34:44, Error                 CBS    Exec: Failed to commit CSI transaction to resolve execution chain. [HRESULT = 0x80092004 - CRYPT_E_NOT_FOUND]
The SFC and CheckSUR scans are both clear.


The IE11Main log shows the same error...
Code:
00:04.914: INFO:    Installing with the downloaded package. C:\Windows\TEMP\IE192BD.tmp\IE11-neutral.Downloaded.cab
00:04.914: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE192BD.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
00:22.730: INFO:    Process exit code 0x80092004 (-2146885628) [Cannot find object or property. ]
00:22.730: ERROR:   Neutral package installation failed (exit code = 0x80092004 (2148081668)).

Have you tried installing from the standalone IE11 installer?
Download Internet Explorer 11 - Microsoft Windows
My System SpecsSystem Spec
26 Jun 2014   #3
chrisloup

Windows 7 Pro 64 bit / 6.1.7601 Service Pack 1 Build 7601
 
 

ok. the weird thing here is that I already have a downloaded copy of the offline copy. my previous ie11 log was generated from that installation log, however, I followed your link and downloaded again and it installed.

Quote:
D:\users\chrisloup\Downloads>fc /b "D:\users\chrisloup\Downloads\IE11-Windows6.1
-x64-en-us (1).exe" d:\download\IE11-Windows6.1-x64-en-us.exe
Comparing files D:\USERS\CHRISLOUP\DOWNLOADS\IE11-Windows6.1-x64-en-us (1).exe a
nd D:\download\IE11-WINDOWS6.1-X64-EN-US.EXE
FC: no differences encountered
Quote:
00:05.086: INFO: The neutral pack was successfully downloaded from the internet. Installation will continue using the downloaded package.
00:05.086: INFO: Waiting for 0 language pack downloads.
00:05.086: INFO: Language pack downloads completed. (exit code = 0xffffffff (4294967295)).
00:05.102: INFO: No reboot logic message NrApiStart(0), lParam=0x00021010 returned 0x00000000.
00:05.476: INFO: No reboot logic message NrApiScan(1), lParam=0x00000000 returned 0x00000000.
00:07.956: INFO: No reboot logic message NrApiDecisionDialog(2), lParam=0x00000001 returned 0x00000000.
00:07.956: INFO: No reboot logic message NrApiStartInstall(4), lParam=0x00000001 returned 0x00000014.
00:07.956: INFO: Installing with the downloaded package. C:\Windows\TEMP\IE13100.tmp\IE11-neutral.Downloaded.cab
00:07.988: INFO: Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE13100.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
01:47.547: INFO: Process exit code 0x00000BC2 (3010) [The requested operation is successful. Changes will not be effective until the system is rebooted. ]
01:47.547: INFO: Setting registry to check if Internet Explorer is the default browser on first run: SUCCESS.
01:47.547: INFO: Preparing to install Spelling_en.msu using C:\Windows\TEMP\IE13100.tmp\Spelling_en.msu
01:47.547: INFO: Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE13100.tmp\Spelling_en\Windows6.3-KB2849696-x86.cab /quiet /norestart
02:00.012: INFO: Process exit code 0x00000BC2 (3010) [The requested operation is successful. Changes will not be effective until the system is rebooted. ]
02:00.012: INFO: Preparing to install Hyphenation_en.msu using C:\Windows\TEMP\IE13100.tmp\Hyphenation_en.msu
02:00.012: INFO: Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE13100.tmp\Hyphenation_en\Windows6.3-KB2849697-x86.cab /quiet /norestart
02:12.242: INFO: Process exit code 0x00000BC2 (3010) [The requested operation is successful. Changes will not be effective until the system is rebooted. ]
02:12.242: INFO: No reboot logic message NrApiInstallDone(7), lParam=0x00000bc2 returned 0x00000000.
02:12.242: INFO: No reboot logic message NrApiStartFinish(11), lParam=0x00000000 returned 0x00000000.
02:12.242: INFO: No reboot logic message NrApiFinish(12), lParam=0x00000000 returned 0x00000016.
02:12.242: INFO: Verifying that the Internet Explorer Optional Component is enabled.
02:16.813: INFO: PauseOrResumeAUThread: Successfully resumed Automatic Updates.
02:16.829: INFO: Setup exit code: 0x00000BC2 (3010) - Installation Succeeded. Reboot required.
02:17.032: INFO: Cleaning up temporary files in: C:\Windows\TEMP\IE13100.tmp
02:17.047: INFO: Unable to remove directory C:\Windows\TEMP\IE13100.tmp, marking for deletion on reboot.
02:17.047: INFO: Rebooting computer...
02:17.047: INFO: Released Internet Explorer Installer Mutex
however, ie 11 also experiencing the no loading like ie 10.

I then remembered reading an article about it and ran
Quote:
regsvr32 "D:\Program Files\Internet Explorer\ieproxy.dll"

regsvr32 "D:\Program Files (x86)\Internet Explorer\ieproxy.dll"
only after the x86 version was registered did it work flawlessly.
(ie: my os drive and my default program files are different)

problem solved.
My System SpecsSystem Spec
.

27 Jun 2014   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The change to the D: drive for the Program Files folder is the probable cause of your difficulties

Well done in finding the correct solution! Thanks for the detailed outcome.

Good luck.
My System SpecsSystem Spec
Reply

 Cannot run ie10, cannot install ie9/11 (ie10 installed)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
How to go to IE10 from IE11 if it was never installed
Hi, I am running into issues with IE11 not working well in my environment and would like to drop down to IE10. However IE10 was never installed via Windows Update, so when I uninstall IE11 in installed updates, I end up back on IE8. But then when I try to update to IE10 I get a 9c59 error, and...
Windows Updates & Activation
IE10 won't install and now IE9 won't either
We have a Windows 7 x86 box that won't install IE10, first via automatic updates, then through manual install. I took over the problem and removed IE10 in Windows Features, only to discover I was left with no IE at all. I attempted to reinstall 9, but got a message that a later version was...
Browsers & Mail
Cannot install IE10 on Win 7 x64
I am unable to install IE10 on my Win 7 x64 mamchine. I tried all the suggestions by MS, no luck. I am getting error code 9C59. Please help! Log attached.
Windows Updates & Activation
MIXDJ ???? installed IE10 in win7 and suddenly it shows up as search
page for every new tab in IE10? what is it and how to ged rid of it? How did it get there? I installed ie10 from the ms windows site
System Security
Who has installed ie10? and what do you think?
I installed it on a test machine running windows 7 pro sp1. I did not use windows updates. I went to windows IE10 site and picked it up there. I installed the 32bit because that machine only runs 32bit. I saw not much of a difference between ie9 and 10 but again I was on a test machine that...
Browsers & Mail
Problem reinstalling ie9 after ie10 installed
Good day all. I tried ie 10 on windows 7, was not satisfied. Tried to unistall it from control panel/turn windows features on or off by uncheck Internet explorer 10, after that no ie available, tried to install ie 9 or ie 10 again with no luck as it says "Internet Explorer did not finish...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App