Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Update keeps failing to update

09 Aug 2014   #11
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

Here's what happens when I run the previous commands locally:

Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>ICACLS C:\Windows\Temp
C:\Windows\Temp BUILTIN\Users:(CI)(S,WD,AD,X)
                BUILTIN\Administrators:(F)
                BUILTIN\Administrators:(OI)(CI)(IO)(F)
                NT AUTHORITY\SYSTEM:(F)
                NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
                CREATOR OWNER:(OI)(CI)(IO)(F)
                BUILTIN\Users:(OI)(CI)(RX)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ATTRIB C:\Windows\Temp\CheckSUR
File not found - C:\Windows\Temp\CheckSUR

C:\Windows\system32>ICACLS C:\Windows\Temp\CheckSUR
C:\Windows\Temp\CheckSUR: The system cannot find the file specified.
Successfully processed 0 files; Failed processing 1 files

C:\Windows\system32>ICACLS C:\Windows
C:\Windows NT SERVICE\TrustedInstaller:(F)
           NT SERVICE\TrustedInstaller:(CI)(IO)(F)
           NT AUTHORITY\SYSTEM:(M)
           NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
           BUILTIN\Administrators:(M)
           BUILTIN\Administrators:(OI)(CI)(IO)(F)
           BUILTIN\Users:(RX)
           BUILTIN\Users:(OI)(CI)(IO)(GR,GE)
           CREATOR OWNER:(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\System32
C:\Windows\System32 NT SERVICE\TrustedInstaller:(F)
                    NT SERVICE\TrustedInstaller:(CI)(IO)(F)
                    NT AUTHORITY\SYSTEM:(M)
                    NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
                    BUILTIN\Administrators:(M)
                    BUILTIN\Administrators:(OI)(CI)(IO)(F)
                    BUILTIN\Users:(RX)
                    BUILTIN\Users:(OI)(CI)(IO)(GR,GE)
                    CREATOR OWNER:(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files
There is no difference between the outputs of commands in either way.


My System SpecsSystem Spec
.
09 Aug 2014   #12
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

I think I changed administrator settings by mistake and I cannot find a way to correct this other than installing Windows 7 from scratch .
My System SpecsSystem Spec
10 Aug 2014   #13
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You could try a repair install - but I'm not sure how that'd work when trying it remotely.

Let's see what we can do with the permissions (the last set of data is fine)

Open an Elevated Command Prompt, and run the following commands

TAKEOWN /F C:\Windows\Temp /A
ICACLS C:\Windows\Temp /remove User
ICACLS C:\Windows\Temp /grant User:(CI)(S,WD,AD,X)
ICACLS C:\Windows\Temp

post the results.
My System SpecsSystem Spec
.

11 Aug 2014   #14
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
You could try a repair install - but I'm not sure how that'd work when trying it remotely.

Let's see what we can do with the permissions (the last set of data is fine)

Open an Elevated Command Prompt, and run the following commands

TAKEOWN /F C:\Windows\Temp /A
ICACLS C:\Windows\Temp /remove User
ICACLS C:\Windows\Temp /grant User:(CI)(S,WD,AD,X)
ICACLS C:\Windows\Temp

post the results.
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>TAKEOWN /F C:\Windows\Temp /A

SUCCESS: The file (or folder): "C:\Windows\Temp" now owned by the administrators
 group.

C:\Windows\system32>ICACLS C:\Windows\Temp /remove User
Successfully processed 0 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\Temp /grant User:(CI)(S,WD,AD,X)
User: No mapping between account names and security IDs was done.
Successfully processed 0 files; Failed processing 1 files

C:\Windows\system32>ICACLS C:\Windows\Temp
C:\Windows\Temp BUILTIN\Users:(CI)(S,WD,AD,X)
                BUILTIN\Administrators:(F)
                BUILTIN\Administrators:(OI)(CI)(IO)(F)
                NT AUTHORITY\SYSTEM:(F)
                NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
                CREATOR OWNER:(OI)(CI)(IO)(F)
                BUILTIN\Users:(OI)(CI)(RX)

Successfully processed 1 files; Failed processing 0 files
My System SpecsSystem Spec
11 Aug 2014   #15
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Bother! typo on my part, Sorry!

it should have been...

Open an Elevated Command Prompt, and run the following commands

TAKEOWN /F C:\Windows\Temp /A
ICACLS C:\Windows\Temp /remove Users
ICACLS C:\Windows\Temp /grant UsersCI)(S,WD,AD,X)
ICACLS C:\Windows\Temp


post the results.
My System SpecsSystem Spec
11 Aug 2014   #16
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Bother! typo on my part, Sorry!

it should have been...

Open an Elevated Command Prompt, and run the following commands

TAKEOWN /F C:\Windows\Temp /A
ICACLS C:\Windows\Temp /remove Users
ICACLS C:\Windows\Temp /grant UsersCI)(S,WD,AD,X)
ICACLS C:\Windows\Temp


post the results.
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>TAKEOWN /F C:\Windows\Temp /A

SUCCESS: The file (or folder): "C:\Windows\Temp" now owned by the administrators
 group.

C:\Windows\system32>ICACLS C:\Windows\Temp /remove Users
processed file: C:\Windows\Temp
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\Temp /grant Users:(CI)(S,WD,AD,X)
processed file: C:\Windows\Temp
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>ICACLS C:\Windows\Temp
C:\Windows\Temp BUILTIN\Administrators:(F)
                BUILTIN\Users:(CI)(S,WD,AD,X)
                BUILTIN\Administrators:(OI)(CI)(IO)(F)
                NT AUTHORITY\SYSTEM:(F)
                NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
                CREATOR OWNER:(OI)(CI)(IO)(F)
                NT SERVICE\TrustedInstaller:(I)(F)
                NT SERVICE\TrustedInstaller:(I)(CI)(IO)(F)
                NT AUTHORITY\SYSTEM:(I)(F)
                NT AUTHORITY\SYSTEM:(I)(OI)(CI)(IO)(F)
                BUILTIN\Administrators:(I)(F)
                BUILTIN\Administrators:(I)(OI)(CI)(IO)(F)
                BUILTIN\Users:(I)(RX)
                BUILTIN\Users:(I)(OI)(CI)(IO)(GR,GE)
                CREATOR OWNER:(I)(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>
My System SpecsSystem Spec
11 Aug 2014   #17
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Duh? what happened there?
It looks like something forced inheritance on the folder in the meantime - which was definitely not the intention or capability of my script.

Please undo that - then post the results of another

ICACLS C:\Windows\Temp
My System SpecsSystem Spec
11 Aug 2014   #18
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Duh? what happened there?
It looks like something forced inheritance on the folder in the meantime - which was definitely not the intention or capability of my script.

Please undo that - then post the results of another

ICACLS C:\Windows\Temp
How can I undo it (by right-clicking on the folder and modifying Security settings)?
My System SpecsSystem Spec
11 Aug 2014   #19
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Yep - UNtick the 'inherit permissions...' box in the Advanced area
My System SpecsSystem Spec
11 Aug 2014   #20
yildizabdullah

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Duh? what happened there?
It looks like something forced inheritance on the folder in the meantime - which was definitely not the intention or capability of my script.

Please undo that - then post the results of another

ICACLS C:\Windows\Temp
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>ICACLS C:\Windows\Temp
C:\Windows\Temp BUILTIN\Administrators:(OI)(CI)(F)
                NT AUTHORITY\SYSTEM:(OI)(CI)(F)
                CREATOR OWNER:(OI)(CI)(IO)(F)
                BUILTIN\Users:(CI)(S,WD,AD,X)

Successfully processed 1 files; Failed processing 0 files
My System SpecsSystem Spec
Reply

 Windows Update keeps failing to update




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Update Installer Update failing - Code 80073712
Logs attached. Attempting to update Windows results in attempt to update Windows Update Installer, which fails with Code 80073712. Logs attached. sfc /scannow reported no problems found. Windows 7 SP1 Home Premium x64 Thanks in advance! - Tim
Windows Updates & Activation
Why does Windows Update keep failing, and can I fix it?
OK, I've got a little problem here... A week or two ago, I had to install an overdose of updates. In fact, about 164 in one day. And, since Saturday, for the past four days, my computer kept telling me to install the one update. In those four days, I've been constantly shutting down the computer...
Windows Updates & Activation
windows update failing
hi all trying to update my laptop. windows update keeps failing , i even try to do it manually but keeps saying "windows cannot check for update because the service isnt running you may need to restart ur computor." ive tried restarting but nothing happens. hope u can help.
Windows Updates & Activation
Windows Update Failing
Windows update is failing with error code 643(see attached screen shot) I've installed and run the SURT screen shots and CBS log file is attached thanks in advance for your help
Windows Updates & Activation
Windows Update failing
AHHHH finally, someone or something that can help, niemiro, or Richard, i am having the same issue with my pc and am wondering if you could create a .zip fix for me to. I'm only new to the forum and odn't even know how to send a pm, so maybe you pm me first or send me your email address. I'll paste...
Windows Updates & Activation
My Windows Update kept failing...
Hello again, sorry for the trouble... But, today I decided to totally format my computer all over again. I have formated my PC with Windows 7 Ultimate, 32-bit. Everything was going smoothly... I installed my regular drivers, Acronis, Adobe then I connect to the net to do a Windows Update first......
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App