Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows update issues, CBS.log attached

07 Sep 2014   #1
joopjoop

win 7 pro
 
 
Windows update issues, CBS.log attached

Windows 7 pro and it won't update. So I saw other threads about this on this forum and it seems to be a corruption but I am stumped on how to fix it.

I've tried system update readiness tool and re-running SP1 installation but no success.


My System SpecsSystem Spec
.
07 Sep 2014   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You have a number of problems - not least some fairly widespread file corruption.
We really need the SFC scan, but I suspect that your best option is going to be a repair install.
I've never seen this type of error before, in a CheckSUR report...
Code:
(f) CBS Registry Error 0x800700EA   failed enumerating child package, index: 0
(f) CBS Registry Error 0x8007000D   failed enumerating child package, index: 1
(f) CBS Registry Error 0x800703E6   failed enumerating child package, index: 2
(f) CBS Registry Error 0x8007000D   failed enumerating child package, index: 3
(f) CBS Registry Error 0x800700EA   failed enumerating child package, index: 4
(f) CBS Registry Error 0x800705AA   failed enumerating child package, index: 5
(f) CBS Registry Error 0x800705AA   failed enumerating child package, index: 6
(f) CBS Registry Error 0x800700EA   failed enumerating child package, index: 7
I'm going to ask around to find out if anyone else knows anything about them -
please run SFC /SCANNOW and post the resulting CBS.log file (you'll have to copy it to the desktop first, and zip the copy for upload)
My System SpecsSystem Spec
07 Sep 2014   #3
joopjoop

win 7 pro
 
 

Issues installing Win 7 SP1, CSI payload files missing
[SOLVED] Windows update fails to install KB2809289 with error 80073712 - Sysnative Forums (user solves it in this post but not sure how to apply that to my log file readings)

I worked through methods 1-8 advised by MS here (method 5 didn't happen because I couldn't find HKEY_LOCAL_MACHINE\COMPONENTS). Now about to retry an install of SP1.
My System SpecsSystem Spec
.

07 Sep 2014   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Your first link has very different errors to the ones you're experiencing, and although the SFCFix tool they may have used in the second has evolved a lot in the past year, I don't think it deals with this type of problem. I've brought the errors to the attention of the tool's team, so hopefully I'll get some good advice from them.

As for the Payload file error that you have, CheckSUR only does a partial scan of the system, and SFC often picks up more errors (and give more detail on them anyhow)

Oddly, in this case, it only picks up one error.
Code:
 Line 110088: 2014-09-07 18:49:39, Info                  CSI    000003df [SR] Repairing 1 components
 Line 110089: 2014-09-07 18:49:39, Info                  CSI    000003e0 [SR] Beginning Verify and Repair transaction
 Line 110092: 2014-09-07 18:49:39, Info                  CSI    000003e2 [SR] Cannot repair member file [l:24{12}]"usbvideo.inf" of usbvideo.inf, Version = 6.1.7600.16543, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type = [l:24{12}]"driverUpdate", TypeName neutral, PublicKey neutral in the store, hash mismatch
 Line 110095: 2014-09-07 18:49:39, Info                  CSI    000003e4 [SR] Cannot repair member file [l:24{12}]"usbvideo.inf" of usbvideo.inf, Version = 6.1.7600.16543, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type = [l:24{12}]"driverUpdate", TypeName neutral, PublicKey neutral in the store, hash mismatch
 Line 110096: 2014-09-07 18:49:39, Info                  CSI    000003e5 [SR] This component was referenced by [l:150{75}]"Package_2_for_KB979538~31bf3856ad364e35~amd64~~6.1.1.0.979538-4_neutral_GDR"
 Line 110101: 2014-09-07 18:49:39, Info                  CSI    000003e7 [SR] Repair complete
This makes me suspect that the CheckSUR Payload results are false-positives - possibly a result of the registry failures.
My System SpecsSystem Spec
07 Sep 2014   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

There is NO POINT in attempting SP1 again - it will continue to fail until we have corrected both CheckSUR and SFC errors, or done a repair install.
My System SpecsSystem Spec
07 Sep 2014   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or OneDrive) and post a link.
My System SpecsSystem Spec
07 Sep 2014   #7
joopjoop

win 7 pro
 
 

uploaded here
My System SpecsSystem Spec
07 Sep 2014   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I asked for the COMPONENTS file (no extension) - you've uploaded a COMPONENTS.OLD2 file, which is no use to man or beast unless you renamed it specially for some reason.
How come you have such a file anyhow?
What happened to the original COMPONENTS file?
My System SpecsSystem Spec
07 Sep 2014   #9
joopjoop

win 7 pro
 
 

Yes I had to rename it to copy it out of the folder, windows was prompting that the file was in use.
My System SpecsSystem Spec
07 Sep 2014   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Ah - then the proper way to do it would have been to boot to Safe Mode and copy it there.
I can't see anything drastically wrong in it - but it's late now.
I'll have a closer look tomorrow.
My System SpecsSystem Spec
Reply

 Windows update issues, CBS.log attached




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows update error code 800F0900, logs attached (CBS and checksur)
Hello All, Before reinstalling Windows (on my 6 months old new laptop) I ask please for help. I see these issues for the last months (Windows update was fine, Snipping tool stopped working and then I discovered the CBS logs) and I hope no other (office files in example) files will be damaged. ...
Windows Updates & Activation
Windows Update error 800B0100 - log attached
Hi, I am having an issue where there are 2 important updates that will not proceed and come up with the Windows Update error 800B0100. I have tried disabling windows update service and then deleting the downloads folder under c:\windows\software distribution and running the system update...
Windows Updates & Activation
Windows 7 update issues when attempting to update
Ok I been searching around even removed the update files that are downloaded thinking ok maybe its a corrupt file issue which I have had once before and that resolved the issue by doing that and did that twice (with a reboot after each time) and my updates still fail, the code I get is the...
Windows Updates & Activation
Issues installing SP1 and Windows Update update
Hi everyone, I'm trying to help my Aunt with an issue with her computer but have ended up at a dead end. The initial problem was that she was having problems getting updates, including SP1 to install. I have read through various threads on this board to find tips on this and most seemed to...
Windows Updates & Activation
Windows Update failing, attached diagnostics log
Hello all, Windows 7 is failing to install around 10 updates, service pack 1 being one of them. I've read what I could, but most of the quick fixes aren't working. I've seen a few posts where someone provides files to install manually and it fixes it, but i don't know where they are getting...
Windows Updates & Activation
installing ie9 from windows update there is a virus attached
I downloaded and installed IE9 from windows update . After that I couldn't open hard drives C: and D: by double clicking but I could by right click and Open . Seaching the problem in Googgle the most topics refer that there is a virus which creates an autorun.inf file etc. They suggest the...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App