Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Pulling my hair out Trying to upgrade o windows 7 SP1

08 Sep 2014   #1
keico

Windows 7 Ultimate 64bit
 
 
Pulling my hair out Trying to upgrade o windows 7 SP1

Ok I have Windows 7 Ultimate.

Been trying to update tp SP! but no matter how many fixes I have tried I keep gettiong the error code error e_fail 0x80004005

I have tried System Update Readiness Tool
Microsoft fixit
SFC Scannow
turned off virus protection.

I do not know what else to do
I have attached the CBS.Log file

Please can someone help me





My System SpecsSystem Spec
.
09 Sep 2014   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Please post your CheckSUR logs - I suspect that they'll show at least a clue to the problem.
My System SpecsSystem Spec
09 Sep 2014   #3
DUNLEAe

win 7 pro 64
 
 

Hi Noel,issues with win update, complete noob here, do i need to start a thread of my own?
My System SpecsSystem Spec
.

09 Sep 2014   #4
keico

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Please post your CheckSUR logs - I suspect that they'll show at least a clue to the problem.

=================================
Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 25.0
2014-09-08 18:41

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Summary:
Seconds executed: 454
No errors detected
My System SpecsSystem Spec
09 Sep 2014   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Quote   Quote: Originally Posted by DUNLEAe View Post
Hi Noel,issues with win update, complete noob here, do i need to start a thread of my own?

Yes please -

Please follow the Windows Update Posting Instructions and post the requested data
If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)
My System SpecsSystem Spec
09 Sep 2014   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Quote   Quote: Originally Posted by keico View Post
Quote   Quote: Originally Posted by NoelDP View Post
Please post your CheckSUR logs - I suspect that they'll show at least a clue to the problem.

=================================
Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 25.0
2014-09-08 18:41

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Summary:
Seconds executed: 454
No errors detected
That surprises me in view of these errors in your CBS.log...
Code:
2014-09-08 18:19:55, Error                 CBS    SPI: (CheckForPendingFlag:90)Failed to open component hive at C:\Windows\System32\config\components er=0x0
2014-09-08 18:19:55, Error                 CBS    SPI: (SPIRegQueryDWORDValue:413)Failed to query registry value: ComponentsRemoved er=0x2
Code:
2014-09-08 18:31:15, Info                  CBS    Appl: Selfupdate, Component: x86_microsoft-windows-minkernelapinamespace_31bf3856ad364e35_0.0.0.0_none_2e8be5a3c3fa2f72 (6.1.7601.22209), elevation:3, lower version revision holder: 6.1.7600.17206
2014-09-08 18:31:15, Info                  CBS    Appl: Selfupdate, Component: x86_microsoft-windows-minkernelapinamespace_31bf3856ad364e35_0.0.0.0_none_2e8be5a3c3fa2f72 (6.1.7601.22209), elevation:17, lower version revision holder: 6.1.7600.17206
2014-09-08 18:31:15, Info                  CBS    WatchList: Add package Package_2_for_KB2790113~31bf3856ad364e35~amd64~~6.1.1.1.2790113-4_neutral_LDR to re-evaluation(install) due to the change on Component Family: x86_microsoft-windows-minkernelapinamespace_31bf3856ad364e35_0.0.0.0_none_2e8be5a3c3fa2f72, Version: 6.1.7600.16385, change: (Owner: Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.Microsoft-Windows-Client-Features-Update, Flag: 128, Action: 4)
2014-09-08 18:31:15, Error                 CBS    Failed. Attempted to uninstall a version of a non-driver component that is not installed, version: 0X600011db04001, component: x86_microsoft-windows-mail-core-dll_31bf3856ad364e35_6.1.7600.16385_none_585517a9869db81d, owner: Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.Microsoft-Windows-Client-Features-Update [HRESULT = 0x80004005 - E_FAIL]
2014-09-08 18:31:15, Info                  CBS    Failed to mergecomponent [HRESULT = 0x80004005 - E_FAIL]
2014-09-08 18:31:15, Info                  CBS    ComponentAnalyzerUninstallDeployment: Failed on update: Microsoft-Windows-Client-Features-Update [HRESULT = 0x80004005 - E_FAIL]
2014-09-08 18:31:15, Info                  CBS    Failed to execute item[0] in Package: Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, Update: Microsoft-Windows-Client-Features-Update [HRESULT = 0x80004005 - E_FAIL]
2014-09-08 18:31:15, Info                  CBS    Failed to execute execution update. [HRESULT = 0x80004005 - E_FAIL]
Do you perhaps have a hack installed to be able to use Windows Mail (from Vista) in Win7?
My System SpecsSystem Spec
09 Sep 2014   #7
keico

Windows 7 Ultimate 64bit
 
 

I have used microsoft outlook for email for as long as I can remember.

I do not use windows mail
My System SpecsSystem Spec
09 Sep 2014   #8
keico

Windows 7 Ultimate 64bit
 
 

1. System Update Readiness Tool (SURT) - showed no errors


2. SFC Scan - showed no errors


3. Windows Update Error Codes - do not have any windows update error codes. When I run the updates they run fine.


4. Log Collection - I posted my log

I am really hoping someone can help me with this.

The only difference was when I turned off my virus protection the SP1 update seemed to almost make it to the end
My System SpecsSystem Spec
09 Sep 2014   #9
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I've done a fair amount of research, and the errors in the CBS log haven't been satisfactorily explained anywhere.

I can only think that a repair install is going to be required.
My System SpecsSystem Spec
10 Sep 2014   #10
keico

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by NoelDP View Post
I've done a fair amount of research, and the errors in the CBS log haven't been satisfactorily explained anywhere.

I can only think that a repair install is going to be required.
Is there a way to do an windows upgrade, say windows 7 ultimate to windows 7 ultimate SP1
My System SpecsSystem Spec
Reply

 Pulling my hair out Trying to upgrade o windows 7 SP1




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD - I am pulling my hair out !!!
Hi guys, I am pulling my hair out trying to fix this can anyone help please. - Windows 7 Ultimate - x64 - retail version - System age approx 2 years - Age of OS installation 2 years also - not re-installed since initial installation. The original error seemed to indicate ntoskrnl.exe...
BSOD Help and Support
No Sound, Please I'm pulling hair out...
:info: The problem has been solved by me. :info: For further details read post below.:warn: Ok, I'm no stranger to computers. I just did a fresh install with Windows 7 Home Premium OEM x64 and after Asus RealTek Drivers sound worked good. Then started updating Windows, and have not had sound since....
Sound & Audio
Pulling my hair out
Hello all, Ive been working on a clients PC for a while now that is having a BSoD. The BSoD only happens when the PC is at his house. I bring it back to the shop to check it out and it never has any issues. Ive run in depth hardware checks and burn ins on individual components such as memory,...
BSOD Help and Support
Realtek 889A and Windows 7 Pulling my hair out
I have installed the latest drivers for this new MB and still it tells me in Device manager that HD Audio has been disabled and is using a M/S driver. OK it may be me with this new OS so bear with me, I have looked in control panel and it tells me no audio installed.... I then look at device...
Sound & Audio
Pulling my hair out!!
ok sorry i might sound to some as a buthead but i had it seaching for fixes that i cant seem to get a straight answer. the problem im having is..... i cant get my headphones and my speakers 5.1 to be plugged in and working. i use my headphones for a program called ventrilo which i use to play my...
Sound & Audio
Utorrent, and hair pulling
Hi all, well it seems i have come across my first problem with 7 :o im not complaining though if this is the worst i get then im lucky. lol Basically everytime i start utorrent my wireless drops. Not only does the signal go but 7 then says i have no wireless adapter lol. All works well again on...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App