Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 Service Pack 1 installation fails - AND messes up drive letters!

29 Sep 2014   #11
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I suspected that'd be the case with the drive letters - it implies that there may be a problem with your MBR.
SFC should take anywhere from 5 minutes (with an SSD) to an hour or so (slow machine)- an instantaneous completion is always a bad sign (which is why we always ask for the full CBS.log)

Here's the Summary output from SFC this time...

Code:
 Line 29820: 2014-09-29 11:21:56, Info                  CSI    000001d5 [SR] Repairing 9 components
 Line 29821: 2014-09-29 11:21:56, Info                  CSI    000001d6 [SR] Beginning Verify and Repair transaction
 Line 29824: 2014-09-29 11:21:57, Info                  CSI    000001d8 [SR] Cannot repair member file [l:24{12}]"M1033DSK.CSD" of Microsoft-Windows-MulanTTSVoiceENUDsk, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
 Line 29825: 2014-09-29 11:21:58, Info                  CSI    000001d9 [SR] Cannot repair member file [l:32{16}]"nete1g32.inf_loc" of nete1g32.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29826: 2014-09-29 11:21:58, Info                  CSI    000001da [SR] Cannot repair member file [l:32{16}]"netefe32.inf_loc" of netefe32.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29827: 2014-09-29 11:21:58, Info                  CSI    000001db [SR] Cannot repair member file [l:32{16}]"netevbdx.inf_loc" of netevbdx.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29828: 2014-09-29 11:21:58, Info                  CSI    000001dc [SR] Cannot repair member file [l:28{14}]"netgb6.inf_loc" of netgb6.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29829: 2014-09-29 11:21:58, Info                  CSI    000001dd [SR] Cannot repair member file [l:32{16}]"prnsv003.inf_loc" of prnsv003.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29830: 2014-09-29 11:21:58, Info                  CSI    000001de [SR] Cannot repair member file [l:32{16}]"prnrc002.inf_loc" of prnrc002.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29831: 2014-09-29 11:21:58, Info                  CSI    000001df [SR] Cannot repair member file [l:32{16}]"prnso002.inf_loc" of prnso002.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
 Line 29832: 2014-09-29 11:21:58, Info                  CSI    000001e0 [SR] Cannot repair member file [l:32{16}]"prnsv004.inf_loc" of prnsv004.inf.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
I'll post a fix protocol later - but it looks to me as if this is the same list as earlier (with 1 addition), at least at first glance.
If that's the case, then we may have a problem - there could be serious problems with the drive, or there may be a rootkit present.

Please run a full CHKDSK and see what it reports.

Click on Start > All Programs > Accessories
Right-click on the Command Prompt entry
Select Run as Administrator and accept the UAC prompt - the Elevated Command Prompt window should pop up.
At the Command prompt, type
CHKDSK C: /R
and hit the Enter key.
You will be told that the drive is locked, and the CHKDSK will run at the next boot - hit the Y key, and then reboot.
The CHKDSK will take a few hours depending on the size of the drive, so be patient!
After the CHKDSK has run, Windows should boot normally (possibly after a second auto-reboot)

Also, please run the Kaspersky TDSSKiller tool and see if that finds anything - TDSSKiller Free Download | Rootkit Remova | Kaspersky Lab US

Are you dual-booting with anything?


My System SpecsSystem Spec
.
29 Sep 2014   #12
chrisnd

windows 7 home premium
 
 

The TDSKiller tool found nothing.
I'm not dual booting.
Ran CHKDSK /R - but it had rebooted without reporting anything on screen. (When I had previously looked it was on stage 5/5 and 65% complete without finding anything amiss.)

Cheers, Chris D
My System SpecsSystem Spec
29 Sep 2014   #13
chrisnd

windows 7 home premium
 
 

The TDSKiller tool found nothing.
I'm not dual booting.
Ran CHKDSK /R - but it had rebooted without reporting anything on screen. (When I had previously looked it was on stage 5/5 and 65% complete without finding anything amiss.)

Cheers, Chris D
My System SpecsSystem Spec
.

30 Sep 2014   #14
chrisnd

windows 7 home premium
 
 

As an aside, I really don't think there is an HDD problem as such because I neglected to mention this is the second disk I have had in this laptop. When the first 160Gb one stated to fail (ie when I had already tried and failed to do the SP1 install a couple of times) I replaced it with the current 250Gb one - and the problem came with it...
My System SpecsSystem Spec
30 Sep 2014   #15
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The listed files are the same

Please open an Elevated COmmand Prompt and run the following commands...

DIR C:\cndaa
DIR C:\Windows\cndaa
DIR C:\Windows\winsxs\cndaa

post the results.

That'll hopefully give us a clue...
My System SpecsSystem Spec
01 Oct 2014   #16
chrisnd

windows 7 home premium
 
 

Attachment 335293

Here's the CBS file.
Running dir c:\cndaa ran some stuff
running dir c:\windows\cndaa & c:\windows\winsxs\cndaa reported 'file not found'

HTH

Chris D
My System SpecsSystem Spec
01 Oct 2014   #17
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

please run the fix again - as below - and make notes of exactly what happens as you do it.
Once complete, post the new CBS.log and your notes
Quote:
reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\cndaa
hit the enter key - if you get a 'Not Found' error try
DIR D:\cndaa
or
DIR E:\cndaa

The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...

XCOPY <drive>:\cndaa <drive>:\windows\winsxs /y /i /s /v /h

(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )

run the command (it should take almost no time) and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
My System SpecsSystem Spec
02 Oct 2014   #18
chrisnd

windows 7 home premium
 
 

Attachment 335383

Running dir c:\cndaa listed the directory
Then xcopy d:\cndaa d:\windows\winsxs /y /i /s /v /h
gave '12 files copied' - it only said '1' last time :-/

sfc /scannow gave same as before: "Windows Resource Protection found corrupt files but was unable to fix some of them"

Cheers again

Chris D
My System SpecsSystem Spec
02 Oct 2014   #19
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Hmmm - here's the important bits from the summary of the SFC...
Code:
 Line 33817: 2014-10-02 10:08:01, Info                  CSI    000001bf [SR] Repairing 8 components
 Line 33818: 2014-10-02 10:08:01, Info                  CSI    000001c0 [SR] Beginning Verify and Repair transaction
 Line 33819: 2014-10-02 10:08:01, Info                  CSI    000001c1 [SR] Cannot verify component files for Macrovision-Protection, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (FALSE)
 Line 33820: 2014-10-02 10:08:01, Info                  CSI    000001c2 [SR] Cannot verify component files for Macrovision-Protection-SafeDisc, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (FALSE)
 Line 33823: 2014-10-02 10:08:02, Info                  CSI    000001c4 [SR] Cannot repair member file [l:24{12}]"M1033DSK.CSD" of Microsoft-Windows-MulanTTSVoiceENUDsk, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
The fix appears to have done what it was supposed to do this time - but another error has appeared, which we'll have to use CheckSUR to fix, before we go back to fix the remaining file error.

Please run the CheckSUR tool again and post the new CheckSUR.log file,
My System SpecsSystem Spec
02 Oct 2014   #20
chrisnd

windows 7 home premium
 
 

CheckSUR? Not done that before. What & where is it please?

As another aside - I notice in the log the horror word 'macrovision'. I know what its for but as it continues to mess up some of my perfectly legitimate CD playing I remove every instance of it I find wherever it crops up - so that accounts for a couple of the 'missing' references.

Chris
My System SpecsSystem Spec
Reply

 Win 7 Service Pack 1 installation fails - AND messes up drive letters!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 service pack 1 install fails
been trying to install sp1 for some time now and keep getting a HRESULT = 0x80070005 - E_ACCESSDENIED I am currently trying to run the update readiness tool
Windows Updates & Activation
Windows 7 Service Pack 1 fails repeatedly
I had some trojan issues on this computer which have been completely resolved. All updates have installed except service pack one. I have run the update readiness tool and the log from the csi says payload file missing. I have run sfc /scannow that comes back with errors that cannot be fixed even...
Windows Updates & Activation
Service Pack 1 Fails, error 8004100E
I've spent a day and a half trying to get service pack 1 installed on a machine. I've tried shutting down my security programs, installing it manually, and the fixits from this post: http://www.sevenforums.com/windows-updates-activation/194500-win-7-sp1-fails-800b0100-error-2.html. I'm...
Installation & Setup
Windows 7 Service Pack 1 (SP1) consistently fails to install -80246007
SP1 consistently fails to install. I have tried all the usual suggestions including the System Readiness Tool. The CHECKSUR logs are included below. Can anyone help me correct the corrupted System Store? Thanks in advance. CHECKSUR.LOG ================================= Checking System...
Windows Updates & Activation
Service Pack 1 fails to install (error_file_not_found_0x80070002)
I've never been offered SP1 through windows update for some reason so i decided to download the standalone installer and i went through the following steps: 1. Ran the system update readiness tool - no errors found. 2. Went through following steps before installing - Steps to follow before you...
Windows Updates & Activation
Service pack 1 fails - error 80073712
Hello guys! I am having trouble installing sp1 despite other windows updates having been flawless so far. I tried following instructions found at the Windows site but the System Update Readiness Tool didn't find any errors and repair installation aborts. Sorry to bother you with another "sp1 fail"...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App