Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 Service Pack 1 installation fails - AND messes up drive letters!

02 Oct 2014   #21
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That the CheckSUR/SURT tool that you downloaded to run the Update Posting Instructions for post#4

(just a naming thing - 90% of people call it CheckSUR, but officially the name is the SURT)

The Macrovision entries should be left alone - it may be that your interfering with them messes some else up down the way.


My System SpecsSystem Spec
.
02 Oct 2014   #22
chrisnd

windows 7 home premium
 
 

Ok got it, done it.
New CBS.6.zip includes last update and SUR logs.

Cheers

Chris D Attachment 335431
My System SpecsSystem Spec
02 Oct 2014   #23
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the Summary from the CheckSUR log....
Code:
Summary:
Seconds executed: 1201
 Found 4 errors
 Fixed 3 errors
  CSI Manifest Missing Total count: 2
  Fixed: CSI Manifest Missing.  Total count: 2
  CSI Payload File Missing Total count: 1
  CSI Store Directory Missing Total count: 1
  Fixed: CSI Store Directory Missing.  Total count: 1
The remaining error is this....
Code:
(f) CSI Payload File Missing 0x00000000 secdrv.sys x86_macrovision-protection-safedisc_31bf3856ad364e35_6.1.7600.16385_none_5d832d711e99213d
This error is best dealt with using the SFC scan...
Code:
 Line 33817: 2014-10-02 10:08:01, Info                  CSI    000001bf [SR] Repairing 8 components
 Line 33818: 2014-10-02 10:08:01, Info                  CSI    000001c0 [SR] Beginning Verify and Repair transaction
 Line 33819: 2014-10-02 10:08:01, Info                  CSI    000001c1 [SR] Cannot verify component files for Macrovision-Protection, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (FALSE)
 Line 33820: 2014-10-02 10:08:01, Info                  CSI    000001c2 [SR] Cannot verify component files for Macrovision-Protection-SafeDisc, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (FALSE)
 Line 33823: 2014-10-02 10:08:02, Info                  CSI    000001c4 [SR] Cannot repair member file [l:24{12}]"M1033DSK.CSD" of Microsoft-Windows-MulanTTSVoiceENUDsk, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
I'll try and deal with that one tomorrow.
My System SpecsSystem Spec
.

03 Oct 2014   #24
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I've uploaded a file - cndab.zip - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\cndab
hit the enter key - if you get a 'Not Found' error try
DIR D:\cndab
or
DIR E:\cndab



The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...



XCOPY <drive>:\cndab <drive>:\windows\winsxs /y /i /s /v /h



(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )



run the command (it should take almost no time) and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
My System SpecsSystem Spec
06 Oct 2014   #25
chrisnd

windows 7 home premium
 
 

Attachment 335793

Ok, done "Windows Resource Protection did not find any integrity violations"
:-)

Chris D
My System SpecsSystem Spec
06 Oct 2014   #26
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Great!
with any luck Windows Update should work.

Do a new Check for Updates, and try installing only the oldest update found - if it fails, what is the KB number, and the error code?
My System SpecsSystem Spec
08 Oct 2014   #27
chrisnd

windows 7 home premium
 
 

I am afraid it failed again - but there is some progress: This time it did not just leave me looking at a black, blank screen but rebooted fully and gave me a proper error message, which read, "Installation was not successful(!). The referenced assembly could not be found. Error: ERROR_SXS_ASSEMBLY_MISSING(0x80073701)".

The SP1 has the update number KB976932 contained in the file windows6.1-KB976932-X86.exe

In the error message there was also 'Go online to seek further advice about this problem' which pointed me at Troubleshoot problems installing Service Pack 1 (SP1) for Windows 7 and Windows Server 2008 R2 - Windows Help

So, I am tempted to try again after disabling the AV etc etc - unless you have other ideas?
It seems strange that the update cannot find something though...
Do we still need to add things?

TIA

Chris d
My System SpecsSystem Spec
08 Oct 2014   #28
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That's an improvement, of sorts, at least!

The SXS_ASSEMBLY_MISSING error can be caused by a number of things - I doubt that it's interference from an AV.

Please post the new CBS.log files, and the C:\Windows\windowsupdate.log file.
My System SpecsSystem Spec
14 Oct 2014   #29
chrisnd

windows 7 home premium
 
 

Attachment 336692
Attachment 336693

Phew, here we are again! (lost the forum for a while?)
Files as requested

Chris D
My System SpecsSystem Spec
15 Oct 2014   #30
chrisnd

windows 7 home premium
 
 

Attachment 336879

Whoops, previous CBS file wrong - try this one.

Apols, Chris D
My System SpecsSystem Spec
Reply

 Win 7 Service Pack 1 installation fails - AND messes up drive letters!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 service pack 1 install fails
been trying to install sp1 for some time now and keep getting a HRESULT = 0x80070005 - E_ACCESSDENIED I am currently trying to run the update readiness tool
Windows Updates & Activation
Windows 7 Service Pack 1 fails repeatedly
I had some trojan issues on this computer which have been completely resolved. All updates have installed except service pack one. I have run the update readiness tool and the log from the csi says payload file missing. I have run sfc /scannow that comes back with errors that cannot be fixed even...
Windows Updates & Activation
Service Pack 1 Fails, error 8004100E
I've spent a day and a half trying to get service pack 1 installed on a machine. I've tried shutting down my security programs, installing it manually, and the fixits from this post: http://www.sevenforums.com/windows-updates-activation/194500-win-7-sp1-fails-800b0100-error-2.html. I'm...
Installation & Setup
Windows 7 Service Pack 1 (SP1) consistently fails to install -80246007
SP1 consistently fails to install. I have tried all the usual suggestions including the System Readiness Tool. The CHECKSUR logs are included below. Can anyone help me correct the corrupted System Store? Thanks in advance. CHECKSUR.LOG ================================= Checking System...
Windows Updates & Activation
Service Pack 1 fails to install (error_file_not_found_0x80070002)
I've never been offered SP1 through windows update for some reason so i decided to download the standalone installer and i went through the following steps: 1. Ran the system update readiness tool - no errors found. 2. Went through following steps before installing - Steps to follow before you...
Windows Updates & Activation
Service pack 1 fails - error 80073712
Hello guys! I am having trouble installing sp1 despite other windows updates having been flawless so far. I tried following instructions found at the Windows site but the System Update Readiness Tool didn't find any errors and repair installation aborts. Sorry to bother you with another "sp1 fail"...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App