Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Pro 64-bit update error code 8007370B

09 Nov 2014   #41
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Hmmm - please run both SFC and CheckSUR, and post the logs together with the C:\windows\windowsupdate.log file ( I really wasn'texpecting any positive results at this stage!)


My System SpecsSystem Spec
.
09 Nov 2014   #42
n2jlc

Windows 7 Professional 64-bit
 
 

Here are the CBS and Windows Update logs all in one folder.
My System SpecsSystem Spec
10 Nov 2014   #43
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

We have progress
CheckSUR ran OK, and fixed a few of the payload file errors - There's still a C Mark error outstanding...
Code:
(f) CSI C Mark Deployment Missing 0x00000000 c!microsoft-w..anguagepack_31bf3856ad364e35_6.1.7600.16385_5df488a7d948b37d amd64_microsoft-windows-a..orecodecs.resources_31bf3856ad364e35_6.1.7600.16385_en-us_a0117050dc6b1274
I'll try and sort that one out today.

SFC found the following errors (and finished successfully)
Code:
 Line 4375: 2014-11-09 15:04:37, Info                  CSI    00000348 [SR] Repairing 5 components
 Line 4376: 2014-11-09 15:04:37, Info                  CSI    00000349 [SR] Beginning Verify and Repair transaction
 Line 4381: 2014-11-09 15:04:37, Info                  CSI    0000034c [SR] Cannot verify component files for Microsoft-Windows-ALG.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)
 Line 4384: 2014-11-09 15:04:37, Info                  CSI    0000034e [SR] Cannot repair member file [l:16{8}]"apps.inf" of Microsoft-Windows-shell32, Version = 6.1.7601.18517, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
 Line 4387: 2014-11-09 15:04:37, Info                  CSI    00000350 [SR] Cannot repair member file [l:20{10}]"WsmRes.dll" of Microsoft-Windows-Web-Services-for-Management-Core, Version = 6.1.7601.17514, pA = PROCESSOR_ARCHITECTURE_IA32_ON_WIN64 (10), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
 Line 4392: 2014-11-09 15:04:37, Info                  CSI    00000353 [SR] Cannot verify component files for Microsoft-Windows-Security-Credential-Manager-Command-Line-User-Interface.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)
 Line 4395: 2014-11-09 15:04:37, Info                  CSI    00000355 [SR] Cannot repair member file [l:32{16}]"AuthFWSnapin.dll" of Networking-MPSSVC-Admin, Version = 6.1.7601.17514, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
I'll put up a fix protocol for that later.
My System SpecsSystem Spec
.

10 Nov 2014   #44
n2jlc

Windows 7 Professional 64-bit
 
 

YEA! I'm off to work. Will check as soon as I return this evening before I go off to study. I re-certify my CCNA on Thursday. Thanks again.
My System SpecsSystem Spec
10 Nov 2014   #45
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Found a couple more bitflips that we need to address before we start replacing files...


I've uploaded a file - n2caf.zip - to my OneDrive at Noel's OneDrive

Please download and save it to your desktop.

Right-click on the file and select Extract All, andsave to the default destination (which should be a folder on the desktop)



Create a new System Restore point



Open an Elevated Command Prompt, and run the followingcommands.



Code:
IF EXIST C:\Windows\System32\config\COMPONENTS.OLD1 DEL C:\Windows\System32\config\COMPONENTS.OLD1
REN C:\Windows\System32\config\COMPONENTS COMPONENTS.OLD1
COPY "%userprofile%\desktop\n2caf\COMPONENTS" C:\Windows\System32\config
  
.


If you get an error with either command, STOP THERE -do not reboot! - post for instructions.



Assuming both commands go OK, reboot, and run anotherCheckSUR scan - post the new CheckSUR.log file.
My System SpecsSystem Spec
10 Nov 2014   #46
n2jlc

Windows 7 Professional 64-bit
 
 

Alright, here are today's CBS logs.
My System SpecsSystem Spec
11 Nov 2014   #47
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Code:
Checking Component Store
(f) CSI Payload File Missing 0x00000000 mscorlib.dll amd64_mscorlib_b77a5c561934e089_6.1.7601.18299_none_546d3d32697be903 
(w) CSI S256H Incorrect 0x00000000 S256H amd64_microsoft-windows-alg.resources_31bf3856ad364e35_6.1.7600.16385_en-us_b09e0ee225f9b48e Invalid Length: 31
(w) CSI S256H Incorrect 0x00000000 S256H x86_microsoft-windows-s..interface.resources_31bf3856ad364e35_6.1.7600.16385_en-us_66462316273e5577 Invalid Length: 31
(f) CSI Payload File Missing 0x00000000 webengine.dll x86_netfx-web_engine_dll_b03f5f7f11d50a3a_6.1.7601.22515_none_f42de1c60e368b6c 
(f) CSI Missing C Mark 0x00000000 c!microsoft-w..anguagepack_31bf3856ad364e35_6.1.7601.17514_60259c6fd6373717 amd64_microsoft-windows-a..orecodecs.resources_31bf3856ad364e35_6.1.7600.16385_en-us_a0117050dc6b1274 Missing c!
(fix) CSI Missing C Mark CSI Registry Item Repaired c!microsoft-w..anguagepack_31bf3856ad364e35_6.1.7601.17514_60259c6fd6373717 successfully added to amd64_microsoft-windows-a..orecodecs.resources_31bf3856ad364e35_6.1.7600.16385_en-us_a0117050dc6b1274
(f) CSI C Mark Deployment Missing 0x00000000 c!microsoft-w..anguagepack_31bf3856ad364e35_6.1.7600.16385_5df488a7d948b37d amd64_microsoft-windows-a..orecodecs.resources_31bf3856ad364e35_6.1.7600.16385_en-us_a0117050dc6b1274
... Now that's interesting!
The two SHA256 errors found here are actually ones that I repaired in yesterday's upload - I'll have to think about what this implies.

I'll post again after work.
My System SpecsSystem Spec
11 Nov 2014   #48
n2jlc

Windows 7 Professional 64-bit
 
 

OK on the why the 2 SHA256 errors didn't stay fixed. Also, for your information, when I shut down the PC last night, it did two updates: The .NET 3.5.1 (KB2937610) that it did not do on Sunday and some other kind of generic Win 7 update (KB2970228).
My System SpecsSystem Spec
11 Nov 2014   #49
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

OK -it was my fault

I've uploaded a file - n2caf.zip - to my OneDrive at Noel's OneDrive

Please download and save it to your desktop.

Right-click on the file and select Extract All, andsave to the default destination (which should be a folder on the desktop)

Create a new System Restore point

Open an Elevated Command Prompt, and run the following commands.

Code:
IF EXIST C:\Windows\System32\config\COMPONENTS.OLD1 DEL C:\Windows\System32\config\COMPONENTS.OLD1 
REN C:\Windows\System32\config\COMPONENTS COMPONENTS.OLD1 
COPY "%userprofile%\desktop\n2caf\COMPONENTS" C:\Windows\System32\config 
  .
If you get an error with either command, STOP THERE -do not reboot! - post for instructions.

Assuming both commands go OK, reboot, and run anotherCheckSUR scan - post the new CheckSUR.log file.
My System SpecsSystem Spec
11 Nov 2014   #50
n2jlc

Windows 7 Professional 64-bit
 
 

OK here are the CBS logs from today.
My System SpecsSystem Spec
Reply

 Windows 7 Pro 64-bit update error code 8007370B




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Code 8007370B Windows Update Error
Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0 Cached Online Validation Code: 0x0 Windows Product Key: *****-*****-X7M9F-TJR49-D6BXJ Windows Product Key Hash: SyIL2E+mQRbOtJSSoOSzyBRx4qI= Windows Product ID:...
Windows Updates & Activation
Win 7 SP1 Ultimate x64 Windows Update Fails, error code 8007370B
For 2 weeks now, I have been completely unable to get Windows Update to run properly on my Windows 7 SP1 Ultimate x64 computer. I have no idea what I did to cause this and I've done some limited troubleshooting to no avail. I would really appreciate any assistance you could offer. Per the...
Windows Updates & Activation
WinDows Update Error Code 8007370B
Hi so whilst trying to do windows 7 updates i keep getting error code this error code:8007370B sfc /snannow also with errors anyone know how this can be resolved? :shock:
Windows Updates & Activation
Windows 7 Professional 64bit Update Error Code 8007370B
I've been having a problem updating my windows 7 professional 64bit for a while (Code 8007370B). I have tried to use microsoft fix it, the SURT, the SFC Scan all to no help. Reading the other posts, I believe it is a "bitflop" that Tom982 mentioned. Anyways, here are the files requested in the...
Windows Updates & Activation
Windows Update Error Code 8007370B (Win 7 Professional 64bit)
Hi Guys. I have been experiencing this issue for some time. At first I ignored it but I would really like to get it resolved. My issue is pretty much identical to the issue found here: ...
Windows Updates & Activation
Windows Update stopped working Code 8007370B
Hi Guys, I'm new to the forum but from what I can gather, you guys know how to resolve Windows Update errors. Each time I run Windows Update I get error code 8007370B. I've tried running SURT but that fails straight away with the error on the screen shot attached. Please help!
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App