Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Warning - KB3004394 corrupts system files

12 Dec 2014   #31
Phone Man

Windows 8.1 Pro w/Media Center 64bit, Windows 7 HP 64bit
 
 

Quote   Quote: Originally Posted by whs View Post
Thanks Jim. That's good to know.

Yesterday someone was chasing that 4777 and could not find it on his updates although he saw it was on his system.
MS is always late with the KB articles. Always a day or two behind the release of the update.

The KB3004394 article was also updated and that is where I found the link to 4777 article.

Ms don't make it easy, you have to poke around and hope you hit something useful.

Jim


My System SpecsSystem Spec
.
12 Dec 2014   #32
melen001

Wins 7 x64 SP1 Home Premium
 
 

Quote   Quote: Originally Posted by whs View Post
Thanks Jim. That's good to know.

Yesterday someone was chasing that 4777 and could not find it on his updates although he saw it was on his system.

Hi...
Thanks for the info on the FIX for KB3004394 but it's not installed on my machine. I've been searching my machine and the blotched update is not installed on my machine. Ran the Windows Update feature on my PC and no updates or FIXes are available. I wonder why when I updated last Tuesday this update was not installed?. Also checked Hidden Updates and not there so I'll just leave my machine alone. I haven't had any issues what so ever so I'll just wait to see what happens.
My System SpecsSystem Spec
12 Dec 2014   #33
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Just leave it alone. Someone else also reported that it did not install on his machine. No need to fix something that is not there.
My System SpecsSystem Spec
.

13 Dec 2014   #34
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 

I didn't have any activation errors or features such as Magnifier not working... but whenever I (re)booted, it took ten full minutes for my boot drive to stop thrashing and for every single desktop icon, shortcut and thumbnail to be redrawn instead of showing a plain white box!
Running the update patch solved the issues. Good thing I make Macrium images every week.
My System SpecsSystem Spec
13 Dec 2014   #35
melen001

Wins 7 x64 SP1 Home Premium
 
 

Quote   Quote: Originally Posted by whs View Post
Just leave it alone. Someone else also reported that it did not install on his machine. No need to fix something that is not there.

hi...
Just what i was thinking. If it's not broken then why fix it. Exactly what i thought, I'll just leave my machine as-is and wait to hear from MS. I'm sure they will explain why some of us didn't get this blotched up-date. All is good on my machine but I'm still curious on why it was not installed. Thanks for the info....
My System SpecsSystem Spec
13 Dec 2014   #36
melen001

Wins 7 x64 SP1 Home Premium
 
 

Quote   Quote: Originally Posted by OvenMaster View Post
I didn't have any activation errors or features such as Magnifier not working... but whenever I (re)booted, it took ten full minutes for my boot drive to stop thrashing and for every single desktop icon, shortcut and thumbnail to be redrawn instead of showing a plain white box!
Running the update patch solved the issues. Good thing I make Macrium images every week.
Hi...
I see that you ran into a few glitches on your machine. Many had problems and some had serious issues so lucky for you that the FIX resolved that matter. I also use Macrium and it's an excellent back-up and frequently recommend it to my friends. I also do weekly backups and luckily have yet to use it so i guess I've been kind of lucky. Have a great day.....
My System SpecsSystem Spec
13 Dec 2014   #37
Wordsworth

Windows 7 Ultimate 64 bit
 
 

Initially I installed KB3004394 and had no discernable problems with it installed. Per Microsoft's recommendation I uninstalled it yesterday and also, before uninstalling, saw the supposed fix for it (4777) in WU but did not install it as I was going to wait on that. Today, even after using Check for updates, 4777 no longer appears in WU which makes sense. I guess I'm good and perhaps a new update will appear that will solve the problems KB3004394 was intended to resolve.
My System SpecsSystem Spec
13 Dec 2014   #38
melen001

Wins 7 x64 SP1 Home Premium
 
 

Quote   Quote: Originally Posted by Wordsworth View Post
Initially I installed KB3004394 and had no discernable problems with it installed. Per Microsoft's recommendation I uninstalled it yesterday and also, before uninstalling, saw the supposed fix for it (4777) in WU but did not install it as I was going to wait on that. Today, even after using Check for updates, 4777 no longer appears in WU which makes sense. I guess I'm good and perhaps a new update will appear that will solve the problems KB3004394 was intended to resolve.

Hi...

I just received update KB3011970 and apparently has nothing to do with KB3004394. It states that it's a Microsoft Silverlight update. Unless KB3004394 was originally an intended Silverlight update it seems it's just a new update.
My System SpecsSystem Spec
13 Dec 2014   #39
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The Silverlight Update is another one that MS pulled on Wednesday - apparently before it caused too many problems.
My System SpecsSystem Spec
13 Dec 2014   #40
melen001

Wins 7 x64 SP1 Home Premium
 
 

Quote   Quote: Originally Posted by NoelDP View Post
The Silverlight Update is another one that MS pulled on Wednesday - apparently before it caused too many problems.
That's news to me. I didn't know that. Seems like Microsoft is on a roller coaster ride these days. This is the first time I've seen such mistakes on MS part. Luckily i haven't seen any glitches on my machine. Do you know where can i get info on the Silverlight blotched update? I would appreciate it.
My System SpecsSystem Spec
Reply

 Warning - KB3004394 corrupts system files




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows suddenly not genuine (KB3004394 ??)
After installing a bunch of updates (among which the infamous KB3004394) early this week, I started getting the 'windows not genuine' message (my copy is 100% legal). I run the KB3024777 update which is supposed to fix things, but I'm still getting the 'windows not genuine' message. Any ideas? ...
Windows Updates & Activation
After KB3004394, no IE, no MS updates
I installed the updates from 12/9 including KB3004394 and immediately lost Internet Explorer along with any subsequent MS updates. To make matters worse, some of my administrator ability has apparently been lost and I can view installed updates but not remove any of them. A system restore to an...
Windows Updates & Activation
Can't find/uninstall KB3004394; Update History says it's installed
I'm yet another possible casualty of the dreaded KB3004394 update. However, in spite of my Installed History Log saying my computer had downloaded and installed it, I can't find it in my Installed Updates window, like so: http://i71.photobucket.com/albums/i124/Matilda_rose/screenshot79.jpg ...
Windows Updates & Activation
KB3004394 breaks Windows genuine (error code 0x8004fe21)?
Tonight I received a message to the effect I now have counterfeit Windows. This was after taking a bunch of Windows updates last night. The error code is 0x8004fe21 The MGADiag dump is pasted below. I also pasted a list of the updates that were installed last night. Per this thread, there...
Windows Updates & Activation
dual boot system (XP & Win 7-64) 7 reboot corrupts disk
Help! I have a dual boot system (XP & Win 7-64) with the Win 7 installed 2nd. I set it up to migrate away from XP. When I reboot the system from Win 7 it restarts and then immediately upon log-on I get a series of errors that the disk is corrupt (most applications trying to load & error 55 in...
General Discussion
Deleting corrupt files corrupts more files?
Laptop: Acer Aspire 5552 OS: Windows 7 Home Premium AV: Avast! Antivirus Pro I have an 2TB external hard drive (Toshiba) where I keep my music, movies, etc. About two months ago, I had an issue where the drive became inaccessible due to the data cable disconnecting during file transfers. The...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:06.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App