Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Tried to install Service Pack 1, now I'm getting various errors

16 Dec 2014   #1
rskfx

Windows 7 Ultimate x32
 
 
Tried to install Service Pack 1, now I'm getting various errors

I have tried removing the update but it doesn't show up under uninstall updates yet under installed updates it shows that today at 1:51am it was installed, there was also an update in there that wouldn't give me the option to remove it but it disappeared when I cleared the updater cache.. I've tried doing a system restore at various points and it always tells me that it failed and could not change system files or settings. And I've even tried going to Windows Update to install files that maybe I need for this to work but I get the 80072efe error every single time that I try. I ended up trying various things like the Windows Update tool and MS Fix It and neither worked. The Windows Update tool told me that the error is a problem that occurred while installing an update. I tried downloading the standalone SP1 for Windows 7 x32 and it gave me a 0x80080005 error and that same error is now popping up when I try to do the install from Windows Update. I have Windows 7 Ultimate.


My System SpecsSystem Spec
.
16 Dec 2014   #2
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Hello rskfx,

Can you go through the steps and post the required information from the link below?

Windows Update Posting Instructions
My System SpecsSystem Spec
16 Dec 2014   #3
rskfx

Windows 7 Ultimate x32
 
 

Step 1 installed the hot fix and didn't show any error until I ran the updater which gave me the error code 80080005.

Step 2 tells me for the sfc /scannow option "Windows Resource Protection could not start the repair service." And doing a system restore ends up just telling me that nothing can be changed.

Step 3 the only error code I am getting now is the 80080005 error, although Windows Update Diagnostic tells me "Problems installing recent updates."

Step 4 I added the CBS document to this post.

EDIT: I ran the update diagnostic test again and got two errors. I get the "Problems installing recent updates" and now "Windows Update error 0x80080005(2014-12-16-T-03_12_18A)" and the detailed gives me the information that I attached with the CBS file.
My System SpecsSystem Spec
.

16 Dec 2014   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

PLEASE follow the instructions that Cator posted - we need ALL the data requested to be able to properly diagnose and repair the error

Here's what appears to be the critical error from the posted data - from your further attempt to install SP1...
Code:
2014-12-15 23:02:18, Info                  CBS    Failed to load Core DLL from path: C:\Windows\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049\cbscore.dll [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND]
2014-12-15 23:02:18, Info                  CBS    Failed to initialize CBS Core. [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND]
...but it's no use fixin that if there are still a lot of other errors that need fixing.
My System SpecsSystem Spec
16 Dec 2014   #5
rskfx

Windows 7 Ultimate x32
 
 

Quote   Quote: Originally Posted by NoelDP View Post
PLEASE follow the instructions that Cator posted - we need ALL the data requested to be able to properly diagnose and repair the error

Here's what appears to be the critical error from the posted data - from your further attempt to install SP1...
Code:
2014-12-15 23:02:18, Info                  CBS    Failed to load Core DLL from path: C:\Windows\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049\cbscore.dll [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND]
2014-12-15 23:02:18, Info                  CBS    Failed to initialize CBS Core. [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND]
...but it's no use fixin that if there are still a lot of other errors that need fixing.
I'm not sure what I'm supposed to post. The first thing just told me that it installed the hot fix. And the sfc /scannnow doesn't work for me. I tried over and over but it keeps telling me that "Windows Resource Protection could not start the repair service." I get Error 126 when I try to start the Windows Modules Installer. Also, the only error code I'm receiving is the 80080005 when I click to search for updates and when I run the Windows Update Diagnostic.
My System SpecsSystem Spec
16 Dec 2014   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You are supposed to post the WHOLE CBS folder - not just the CBS.log file. Please read the link Gator posted again.
My System SpecsSystem Spec
16 Dec 2014   #7
rskfx

Windows 7 Ultimate x32
 
 

Quote   Quote: Originally Posted by NoelDP View Post
You are supposed to post the WHOLE CBS folder - not just the CBS.log file. Please read the link Gator posted again.
I added the whole folder this time. Hopefully that can tell you because I really need to fix this fast. A job I'm trying to get depends on it.
My System SpecsSystem Spec
16 Dec 2014   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You still haven't included the older CBSPersist files - these are important as they contain currently your SFC results.
The CheckSUR results show the following problems...
Code:
(f) CSI Payload File Missing 0x00000000 dpx.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 poqexec.exe x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 cmiadapter.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 fastprox.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 helpcins.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 CbsCore.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 apircl.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 CntrtextInstaller.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 smiengine.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 drvstore.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 PkgMgr.exe x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wdscore.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 smipi.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 cmiv2.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wcp.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wrpint.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wbemcore.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wbemcomn.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 wmicmiplugin.dll x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049 
(f) CSI Payload File Missing 0x00000000 ntoskrnl.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.16792_none_6bf8ee9215816c61 
(f) CSI Payload File Missing 0x00000000 ntkrnlpa.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.16792_none_6bf8ee9215816c61 
(f) CSI Payload File Missing 0x00000000 ntoskrnl.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.21701_none_6ec9394b2b7d606e 
(f) CSI Payload File Missing 0x00000000 ntkrnlpa.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.21701_none_6ec9394b2b7d606e 
(f) CSI Payload File Missing 0x00000000 ntoskrnl.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.17592_none_6ddf4b9812a7d84d 
(f) CSI Payload File Missing 0x00000000 ntkrnlpa.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.17592_none_6ddf4b9812a7d84d 
(f) CSI Payload File Missing 0x00000000 ntoskrnl.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20941_none_6cb79c952e776446 
(f) CSI Payload File Missing 0x00000000 ntkrnlpa.exe x86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20941_none_6cb79c952e776446
The SFC scan may show more - or less.
My System SpecsSystem Spec
16 Dec 2014   #9
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Never mind - with luck this will repair things enough to get the SFC working properly...


I've uploaded a file - rfxaa.zip - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\rfxaa
hit the enter key - if you get a 'Not Found' error try
DIR D:\rfxaa
or
DIR E:\rfxaa



The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...



XCOPY <drive>:\rfxaa <drive>:\windows\winsxs /y /i /s /v /h



(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )



run the command (it should take almost no time) and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
My System SpecsSystem Spec
16 Dec 2014   #10
rskfx

Windows 7 Ultimate x32
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Never mind - with luck this will repair things enough to get the SFC working properly...


I've uploaded a file - rfxaa.zip - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\rfxaa
hit the enter key - if you get a 'Not Found' error try
DIR D:\rfxaa
or
DIR E:\rfxaa



The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...



XCOPY <drive>:\rfxaa <drive>:\windows\winsxs /y /i /s /v /h



(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )



run the command (it should take almost no time) and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
It finds the file but xcopy says "Access denied. Unable to create directory - C:\Windows\winsxs 0 files copied.
My System SpecsSystem Spec
Reply

 Tried to install Service Pack 1, now I'm getting various errors




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Service Pack 1 won't install
I have tried to install SP1 on my laptop every time Windows update lists it to download, it fails. Other updates install as expected. Curiously, I have Windows 7 on a desktop system and it installed just fine. Is there a way to get this update in an ISO file and install it manually? Thank...
Windows Updates & Activation
Factory Windows 7 Service pack 1 but service pack shows in updates?
Just bought new never used factory fresh PC Acer AXC-605-UR29 Windows 7 Service Pack 1 manufacrtured this year, I checked for latest updates and sure enough Service Pack 1 shows up in updates Windows 7 Service Pack 1 for x64-based Systems (KB976932) Download size: 9.1 MB
Windows Updates & Activation
Can't (re)install Service Pack 1
I'm havin' a bit of trouble installing Service Pack 1. Either that or Windows Update wants to make an excuse and stop the installation halfway and then spit out a random error code. Failed - Error Code 8024200D Would downloading the MSU file help resolve what's halting the update process?
Windows Updates & Activation
Service Pack 1 won't install
I am working on a PC with Windows 7 Ultimate. The owner has told me that a friend upgraded her from Vista to 7. There is an OEM activation key listed under system configuration. How do I know it is genuine? The reason I ask is because SP1 dowloads from Microsoft site but fails to install:...
Windows Updates & Activation
Service Pack 1 won't install.....
Every time I go to run the windows upgrade program and I begin installing it on my laptop I get to a point it comes up with a screen warning that my laptop is low on power, even thought its at full power and plugged into the ac, and won't let me go on any further. Does anyone out there have...
Windows Updates & Activation
Service Pack 1 won't install
I have tried several times to get it to install on one of my W7 machines. First I tried getting it from Microsoft Update. When that didn't work, I downloaded the ISO file and burned a DVD. That installation worked fine on my secondary computer running an AMD processor. But this one, an Intel...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:05.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App