Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Service Pack 1 error 80070005 (Access Denied)

30 May 2015   #1
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 
Service Pack 1 error 80070005 (Access Denied)

Hi all,

I've been trying to install the Service Pack 1 for Windows 7 Pro 64 bit. I am able to install it, but after I restart my computer, Windows attempts to configure the Service Pack and then fails causing it the system to revert. Once the desktop appears, I see a window that says the configuration failed with error code 80070005. I am still able to get to my desktop and operate as normal, but no Service Pack is installed.

I've tried some of the main troubleshooting options: Used the System Update Readiness Tool (SURT), ran a sfc /scannow (no problems), removed temporary internet files, ran Microsoft Hotfix, disabled antivirus and firewalls during installation and configuration.

Here are some notes that may help with diagnostics:

I have 25.6 Gigs available on C:\Windows drive. Partitioned drive.

I recently changed everything (CPU, Mobo, VGU, Mem) on this PC (although looking at the history, I've never had service pack 1 installed).

Attachments:

Attached are the shortened CB Log (I think it captures the errors that occurred during configuration) and a screenshot of my Windows Update history.

Thanks in advance for any help!




Attached Thumbnails
Service Pack 1 error 80070005 (Access Denied)-update-errors.png  
Attached Files
File Type: txt 5-29 CB Log Shortened.txt (437.3 KB, 1 views)
My System SpecsSystem Spec
.
31 May 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The uploaded CBS data is only the rollback after the reboot - and contains no data about the install phase.

Please upload the latest TWO CBSPersist cab files, and the C:\Windows\windowsupdate.log file - all zipped!
My System SpecsSystem Spec
31 May 2015   #3
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 

Quote   Quote: Originally Posted by NoelDP View Post
The uploaded CBS data is only the rollback after the reboot - and contains no data about the install phase.

Please upload the latest TWO CBSPersist cab files, and the C:\Windows\windowsupdate.log file - all zipped!
Here they are:

I think this is what you are looking for?


Attached Files
File Type: log WindowsUpdate.log (1.87 MB, 1 views)
My System SpecsSystem Spec
.

31 May 2015   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

This appears to be the root error in the WindowsUpdate log...
Code:
2015-05-29 07:16:30:797  952 3c0 Misc  Microsoft signed: Yes
2015-05-29 07:16:30:797  952 3c0 PT +++++++++++  PT: Synchronizing server updates  +++++++++++
2015-05-29 07:16:30:797  952 3c0 PT   + ServiceId = {9482F4B4-E343-43B6-B170-9A65BC822C77}, Server URL = https://www.update.microsoft.com/v6/...ce/client.asmx
2015-05-29 07:16:31:795  952 3c0 Agent WARNING: Failed to evaluate Installed rule, updateId = {2A1234D0-3E2D-4D9E-AA5E-3430A20EDC11}.100, hr = 80242013
2015-05-29 07:16:32:107  952 3c0 Misc Validating signature for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab:
2015-05-29 07:16:32:107  952 3c0 Misc  Microsoft signed: Yes
2015-05-29 07:16:32:123  952 3c0 Misc Validating signature for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab:
2015-05-29 07:16:32:123  952 3c0 Misc  Microsoft signed: Yes
Here's a string of errors during the rollback phase, that may be part of the problem (from the most recent Persist file)...
Code:
 Line 163451: 2015-05-29 14:54:58, Error                 CSI    00000012 (F) Logged @2015/5/29:21:54:58.743 : [ml:148{74},l:146{73}]"FirewallConfigInstaller:AddRemoveFirewallConfig() installation type is 4."
 Line 163453: 2015-05-29 14:54:58, Error                 CSI    00000013 (F) Logged @2015/5/29:21:54:58.743 : [ml:132{66},l:130{65}]"FirewallConfigInstaller:AddRemoveFirewallConfig() SERVICING is 1."
 Line 163455: 2015-05-29 14:54:58, Error                 CSI    00000014 (F) Logged @2015/5/29:21:54:58.743 : [ml:660{330},l:658{329}]"FirewallConfigInstaller:AddRemoveFirewallConfig() installing <firewallRule xmlns="urn:schemas-microsoft-com:asm.v3" Action="Allow" Active="FALSE" Binary="System" Desc="@FirewallAPI.dll,-28756" Dir="In" LPort="3389" Name="@FirewallAPI.dll,-28753" Protocol="6" group="@FirewallAPI.dll,-28752" internalName="RemoteDesktop-In-TCP" />"
 Line 163457: 2015-05-29 14:54:58, Error                 CSI    00000015 (F) Logged @2015/5/29:21:54:58.743 : [ml:142{71},l:140{70}]"FirewallConfigInstaller:AddRemoveFirewallConfig() Installing a rule..."
 Line 163459: 2015-05-29 14:54:58, Error                 CSI    00000016 (F) Logged @2015/5/29:21:54:58.743 : [ml:228{114},l:226{113}]"FirewallConfigInstaller::AddFirewallRule DEFAULTS adding rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 7)"
 Line 163461: 2015-05-29 14:54:58, Error                 CSI    00000017 (F) Logged @2015/5/29:21:54:58.743 : [ml:242{121},l:240{120}]"FirewallConfigInstaller::AddFirewallRule POLICY adding rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 2147483647)"
 Line 163463: 2015-05-29 14:54:58, Error                 CSI    00000018 (F) Logged @2015/5/29:21:54:58.743 : [ml:152{76},l:150{75}]"FirewallConfigInstaller::AddFirewallRule Active - Inactive Profiles (0 - 0)"
 Line 163465: 2015-05-29 14:54:58, Error                 CSI    00000019 (F) Logged @2015/5/29:21:54:58.743 : [ml:152{76},l:150{75}]"FirewallConfigInstaller::AddFirewallRule Active - Inactive Profiles (0 - 7)"
 Line 163467: 2015-05-29 14:54:58, Error                 CSI    0000001a (F) Logged @2015/5/29:21:54:58.743 : [ml:228{114},l:226{113}]"FirewallConfigInstaller::AddFirewallRule adding INACTIVE rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 7)"
 Line 163469: 2015-05-29 14:54:58, Error                 CSI    0000001b (F) Logged @2015/5/29:21:54:58.774 : [ml:214{107},l:212{106}]"FirewallConfigInstaller::AddFirewallRule - CFirewall::AddRule/SetRule failed: 0x80070005 (Status: 0x10000)"
 Line 163471: 2015-05-29 14:54:58, Error                 CSI    0000001c (F) Logged @2015/5/29:21:54:58.774 : [ml:178{89},l:176{88}]"FirewallConfigInstaller:AddRemoveFirewallConfig() AddFirewallRule() failed. (0x80070005)"
Looking back at the install pahse, we get the same set of errors, followed by...
Code:
2015-05-29 14:45:00, Error                 CSI    0000001d@2015/5/29:21:45:00.392 (F) CMIADAPTER: Inner Error Message from AI HRESULT = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED)
 [
[19]"Access is denied.
"
]
[gle=0x80004005]
2015-05-29 14:45:00, Error                 CSI    0000001e@2015/5/29:21:45:00.392 (F) CMIADAPTER: AI failed. HRESULT = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED)
 Element:
 [268]"<firewallRule xmlns="urn:schemas-microsoft-com:asm.v3" Action="Allow" Active="FALSE" Binary="System" Desc="@FirewallAPI.dll,-28756" Dir="In" LPort="3389" Name="@FirewallAPI.dll,-28753" Protocol="6" group="@FirewallAPI.dll,-28752" internalName="RemoteDesktop-In-TCP" />"
[gle=0x80004005]
2015-05-29 14:45:00, Error                 CSI    00000838@2015/5/29:21:45:00.392 (F) d:\win7sp1_gdr\base\wcp\cmiadapter\installers.cpp(352): Error HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::ResolveAndInvokeInstaller expression: hr
[gle=0x80004005]
2015-05-29 14:45:00, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Percent progress: 96.
2015-05-29 14:45:07, Error                 CSI    0000001f@2015/5/29:21:45:07.740 (F) CMIADAPTER: Exiting with HRESULT code = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED).
[gle=0x80004005]
2015-05-29 14:45:07, Error                 CSI    00000839@2015/5/29:21:45:07.740 (F) d:\win7sp1_gdr\base\wcp\cmiadapter\installers.cpp(123): Error HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::Install expression: hr
[gle=0x80004005]
What AV is currently installed? What other security software has ever been installed?
My System SpecsSystem Spec
31 May 2015   #5
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 

Quote   Quote: Originally Posted by NoelDP View Post
This appears to be the root error in the WindowsUpdate log...
Code:
2015-05-29 07:16:30:797  952 3c0 Misc  Microsoft signed: Yes
2015-05-29 07:16:30:797  952 3c0 PT +++++++++++  PT: Synchronizing server updates  +++++++++++
2015-05-29 07:16:30:797  952 3c0 PT   + ServiceId = {9482F4B4-E343-43B6-B170-9A65BC822C77}, Server URL = https://www.update.microsoft.com/v6/...ce/client.asmx
2015-05-29 07:16:31:795  952 3c0 Agent WARNING: Failed to evaluate Installed rule, updateId = {2A1234D0-3E2D-4D9E-AA5E-3430A20EDC11}.100, hr = 80242013
2015-05-29 07:16:32:107  952 3c0 Misc Validating signature for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab:
2015-05-29 07:16:32:107  952 3c0 Misc  Microsoft signed: Yes
2015-05-29 07:16:32:123  952 3c0 Misc Validating signature for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab:
2015-05-29 07:16:32:123  952 3c0 Misc  Microsoft signed: Yes
Here's a string of errors during the rollback phase, that may be part of the problem (from the most recent Persist file)...
Code:
 Line 163451: 2015-05-29 14:54:58, Error                 CSI    00000012 (F) Logged @2015/5/29:21:54:58.743 : [ml:148{74},l:146{73}]"FirewallConfigInstaller:AddRemoveFirewallConfig() installation type is 4."
 Line 163453: 2015-05-29 14:54:58, Error                 CSI    00000013 (F) Logged @2015/5/29:21:54:58.743 : [ml:132{66},l:130{65}]"FirewallConfigInstaller:AddRemoveFirewallConfig() SERVICING is 1."
 Line 163455: 2015-05-29 14:54:58, Error                 CSI    00000014 (F) Logged @2015/5/29:21:54:58.743 : [ml:660{330},l:658{329}]"FirewallConfigInstaller:AddRemoveFirewallConfig() installing <firewallRule xmlns="urn:schemas-microsoft-com:asm.v3" Action="Allow" Active="FALSE" Binary="System" Desc="@FirewallAPI.dll,-28756" Dir="In" LPort="3389" Name="@FirewallAPI.dll,-28753" Protocol="6" group="@FirewallAPI.dll,-28752" internalName="RemoteDesktop-In-TCP" />"
 Line 163457: 2015-05-29 14:54:58, Error                 CSI    00000015 (F) Logged @2015/5/29:21:54:58.743 : [ml:142{71},l:140{70}]"FirewallConfigInstaller:AddRemoveFirewallConfig() Installing a rule..."
 Line 163459: 2015-05-29 14:54:58, Error                 CSI    00000016 (F) Logged @2015/5/29:21:54:58.743 : [ml:228{114},l:226{113}]"FirewallConfigInstaller::AddFirewallRule DEFAULTS adding rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 7)"
 Line 163461: 2015-05-29 14:54:58, Error                 CSI    00000017 (F) Logged @2015/5/29:21:54:58.743 : [ml:242{121},l:240{120}]"FirewallConfigInstaller::AddFirewallRule POLICY adding rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 2147483647)"
 Line 163463: 2015-05-29 14:54:58, Error                 CSI    00000018 (F) Logged @2015/5/29:21:54:58.743 : [ml:152{76},l:150{75}]"FirewallConfigInstaller::AddFirewallRule Active - Inactive Profiles (0 - 0)"
 Line 163465: 2015-05-29 14:54:58, Error                 CSI    00000019 (F) Logged @2015/5/29:21:54:58.743 : [ml:152{76},l:150{75}]"FirewallConfigInstaller::AddFirewallRule Active - Inactive Profiles (0 - 7)"
 Line 163467: 2015-05-29 14:54:58, Error                 CSI    0000001a (F) Logged @2015/5/29:21:54:58.743 : [ml:228{114},l:226{113}]"FirewallConfigInstaller::AddFirewallRule adding INACTIVE rule (RemoteDesktop-In-TCP | @FirewallAPI.dll,-28753, 7)"
 Line 163469: 2015-05-29 14:54:58, Error                 CSI    0000001b (F) Logged @2015/5/29:21:54:58.774 : [ml:214{107},l:212{106}]"FirewallConfigInstaller::AddFirewallRule - CFirewall::AddRule/SetRule failed: 0x80070005 (Status: 0x10000)"
 Line 163471: 2015-05-29 14:54:58, Error                 CSI    0000001c (F) Logged @2015/5/29:21:54:58.774 : [ml:178{89},l:176{88}]"FirewallConfigInstaller:AddRemoveFirewallConfig() AddFirewallRule() failed. (0x80070005)"
Looking back at the install pahse, we get the same set of errors, followed by...
Code:
2015-05-29 14:45:00, Error                 CSI    0000001d@2015/5/29:21:45:00.392 (F) CMIADAPTER: Inner Error Message from AI HRESULT = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED)
 [
[19]"Access is denied.
"
]
[gle=0x80004005]
2015-05-29 14:45:00, Error                 CSI    0000001e@2015/5/29:21:45:00.392 (F) CMIADAPTER: AI failed. HRESULT = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED)
 Element:
 [268]"<firewallRule xmlns="urn:schemas-microsoft-com:asm.v3" Action="Allow" Active="FALSE" Binary="System" Desc="@FirewallAPI.dll,-28756" Dir="In" LPort="3389" Name="@FirewallAPI.dll,-28753" Protocol="6" group="@FirewallAPI.dll,-28752" internalName="RemoteDesktop-In-TCP" />"
[gle=0x80004005]
2015-05-29 14:45:00, Error                 CSI    00000838@2015/5/29:21:45:00.392 (F) d:\win7sp1_gdr\base\wcp\cmiadapter\installers.cpp(352): Error HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::ResolveAndInvokeInstaller expression: hr
[gle=0x80004005]
2015-05-29 14:45:00, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Percent progress: 96.
2015-05-29 14:45:07, Error                 CSI    0000001f@2015/5/29:21:45:07.740 (F) CMIADAPTER: Exiting with HRESULT code = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED).
[gle=0x80004005]
2015-05-29 14:45:07, Error                 CSI    00000839@2015/5/29:21:45:07.740 (F) d:\win7sp1_gdr\base\wcp\cmiadapter\installers.cpp(123): Error HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::Install expression: hr
[gle=0x80004005]
What AV is currently installed? What other security software has ever been installed?
I currently have Norton Security Suite through my cable TV/Internet provider and I have had McAfee in the past. I've also had to run Malwarebytes to remove some malware in the past.
My System SpecsSystem Spec
31 May 2015   #6
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 

I tried some more troubleshooting since the last reply. I disabled all the Windows firewalls, tried to re-install SP1 and it failed to configure. Then I tried uninstalling my AV (Norton), same error again. Here are the most recent CBS and Windows Update files. I've also included a screenshot showing my firewall status (right after failure) and the error message that appears.


Attached Thumbnails
Service Pack 1 error 80070005 (Access Denied)-firewall-status-after-norton-uninstall.png  
Attached Images
Service Pack 1 error 80070005 (Access Denied)-restart-error-screen.png 
Attached Files
File Type: rar WindowsUpdate as of 5-31.rar (166.2 KB, 2 views)
My System SpecsSystem Spec
01 Jun 2015   #7
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You probably need to run the McAfee cleanup tool - and certainly (if Norton is uninstalled now) need to run the Norton cleanup tool...

Download the McAfee removal tool from:

http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe

Click Save, and save the file to a folder on your computer.
Navigate to the folder where you saved the file.
right-click on MCPR.exe and select 'Run as Administrator' to run the removal tool.

when complete, reboot.

Download the Norton Removal Tool from here https://www-secure.symantec.com/norton-support/jsp/help-solutions.jsp?lg=english&ct=united+states&docid=20080710133834EN&product=home&version=1&pvid=f-home

Close all other programs, then run the tool. When it's complete, reboot the machine whether it asks for it or not.

After the reboot, open an Elevated Command Prompt, and run the following command

NETSH WINSOCK RESET

You'll be advised to reboot - do so.
then post another MGADiag report.
My System SpecsSystem Spec
01 Jun 2015   #8
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 

I used the Mcafee and Norton removal tools, disabled Windows firewalls and attempted to install the Service Pack again and the same error window appeared after failing to configure and reverting changes. Here is the MGADiag before the attempted install along with the most recent Windows update and CBS logs.

I really do not want to do this, but I'm wondering if I need to do a complete re-install of Windows.


Attached Files
File Type: rar WindowsUpdate 6-1.rar (115.6 KB, 4 views)
File Type: txt mgadiag.txt (4.7 KB, 4 views)
My System SpecsSystem Spec
05 Jun 2015   #9
ncalcs99

Microsoft Windows 7 Professional 64-bit 7600 Multiprocessor Free
 
 

Anyone have any advice on this issue? I still have not found any solutions.
My System SpecsSystem Spec
06 Jun 2015   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Sorry about that - it got past me!
This seems to bethe critical problem from the windowsupdate log...
Code:
2015-05-29 07:16:30:797  952 3c0 PT   + ServiceId = {9482F4B4-E343-43B6-B170-9A65BC822C77}, Server URL = https://www.update.microsoft.com/v6/ClientWebService/client.asmx
2015-05-29 07:16:31:795  952 3c0 Agent WARNING: Failed to evaluate Installed rule, updateId = {2A1234D0-3E2D-4D9E-AA5E-3430A20EDC11}.100, hr = 80242013
Have you tried running the SP1 install from the standalone package?
http://www.microsoft.com/en-in/download/details.aspx?id=5842
My System SpecsSystem Spec
Reply

 Service Pack 1 error 80070005 (Access Denied)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Factory Windows 7 Service pack 1 but service pack shows in updates?
Just bought new never used factory fresh PC Acer AXC-605-UR29 Windows 7 Service Pack 1 manufacrtured this year, I checked for latest updates and sure enough Service Pack 1 shows up in updates Windows 7 Service Pack 1 for x64-based Systems (KB976932) Download size: 9.1 MB
Windows Updates & Activation
Windows Firewall service will not start, Error Code 5: Access Denied
Hey guys, I am running Windows 7 Home Premium 64bit. I can not start Windows Firewall, Diagnostic Policy Service, Diagnostic Service Host, or Diagnostic System Host. When I try and start them manually in services.msc, it gives me Error Code 5: Access denied. Both BFE and Windows Firewall...
System Security
The Group Policy Client Service failed the logon, Access is denied.
A computer was handed to me to fix. Well it's a Windows 7 laptop. I'm not actually by it right now so I can not tell you the manufacturer at the moment; but I'll try to explain everything I can. I usually am very good with this stuff but the thing is, I've only came across an error like once...
General Discussion
Windows Search Service/Indexing - Access Denied?
Hello, I have been trying to enable the search feature on my windows 7 64-bit machine but when I attempt to do so, or use indexing, nothing seems to happen. When I try to enable windows search in services I get "Windows could not start the Windows Search service on Local Computer - error 5...
General Discussion
access denied to a service
Hi i want to kill a service, it's the Eset security service, I have eset antivirus loongtime ago but this services doesn't want to be killed, i have tried to susped, disable it through the services.msc tool but it says "access denied", I have tried to run it as administrator but it didn't help.
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App