Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to install SP1 windows 7 home premium 64bit. error 800B0100

07 Jun 2015   #1
ultimaa

Windows 7 Home Premium 64bit
 
 
Unable to install SP1 windows 7 home premium 64bit. error 800B0100

Hello, I am having an issue getting windows 7 service pack 1 to install (windows6.1-KB976932-X64.exe).
I get error code TRUST_E_NOSIGNATURE(0x800b0100). These are troubleshooting steps i have already attempted. I had antivirus and firewall disabled during this whole process.

1.First i attempted to use the microsoft fixit tool located here Troubleshoot problems with installing updates - Windows Help
2.Ran a Sfc scannow test on command promt (no errors found)
3.Ran a diskchk on the harddrive which my windows OS was located on (no errors)
4.Ran System Update readiness tool which completed (log is attached)
5.Added Windows6.1KB947821-v34-x64.msu to my %Windir%\Temp\CheckSUR \servicing\packages\ directory. Reran System update readiness tool (same missing manifests, mum, and cat file errors in log).

So basically the next step from what I read is to do a install repair or to manually copy in the missing manifest, mum and cat files. I would prefer to do that latter but i don't have another 64bit machine to get the files from. I dont know where i would attain these files.




Attached Files
File Type: log CheckSUR.log (5.7 KB, 3 views)
My System SpecsSystem Spec
.
08 Jun 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the CheckSUR summary
Code:
Summary:
Seconds executed: 3009
 Found 16 errors
  CSI Manifest All Zeros Total count: 10
  CBS MUM Corrupt Total count: 3
  CBS Catalog Corrupt Total count: 3
Unavailable repair files:
 winsxs\manifests\amd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7600.20789_none_366f2ebb2946b708.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver-v1_31bf3856ad364e35_6.1.7600.20789_none_3679fea7293e9b17.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver-common_31bf3856ad364e35_6.1.7600.20789_none_6058c38042f219f9.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver-v1_31bf3856ad364e35_6.1.7600.16664_none_36010042101544b8.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.20789_none_55777e451da680d3.manifest
 winsxs\manifests\wow64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.20789_none_5fcc2897520742ce.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.16664_none_54fe7fe0047d2a74.manifest
 winsxs\manifests\wow64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.16664_none_5f532a3238ddec6f.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7600.16664_none_35f63056101d60a9.manifest
 winsxs\manifests\amd64_microsoft-windows-smbserver-common_31bf3856ad364e35_6.1.7600.16664_none_5fdfc51b29c8c39a.manifest
 servicing\packages\Package_1_for_KB2345886~31bf3856ad364e35~amd64~~6.1.1.2.mum
 servicing\packages\Package_1_for_KB2345886~31bf3856ad364e35~amd64~~6.1.1.2.mum
 servicing\packages\Package_for_KB2345886_RTM~31bf3856ad364e35~amd64~~6.1.1.2.mum
 servicing\packages\Package_for_KB2345886_RTM~31bf3856ad364e35~amd64~~6.1.1.2.mum
 servicing\packages\Package_for_KB2345886~31bf3856ad364e35~amd64~~6.1.1.2.mum
 servicing\packages\Package_for_KB2345886~31bf3856ad364e35~amd64~~6.1.1.2.mum
I'll post a fix protocol later.
My System SpecsSystem Spec
08 Jun 2015   #3
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I've uploaded a file - ulaaa.zip - to my OneDrive at Noel's OneDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder ulaaa in the same place.
Open this folder - there should be two folders inside it (Manifests, and Packages)

Copy the content of the Packages folder to the folder
C:\Windows\Temp\CheckSur\Servicing\Packages

And the content of the manifests folder (.manifest files) into this folder:

C:\Windows\Temp\CheckSur\Winsxs\Manifests

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.
My System SpecsSystem Spec
.

08 Jun 2015   #4
ultimaa

Windows 7 Home Premium 64bit
 
 
Update

Ok i copyed in the folders to the places here are my new logs


Attached Files
File Type: log CheckSUR.log (6.8 KB, 4 views)
File Type: log CheckSUR.persist.log (29.8 KB, 1 views)
My System SpecsSystem Spec
08 Jun 2015   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Odd - it fixed the Packages, but not the Manifests?

Did you copy the files to the correct place?
My System SpecsSystem Spec
08 Jun 2015   #6
ultimaa

Windows 7 Home Premium 64bit
 
 

I believe so it was where in directory you told me here is screenshot of where i put them


Attached Thumbnails
Unable to install SP1 windows 7 home premium 64bit. error 800B0100-untitled.png  
My System SpecsSystem Spec
08 Jun 2015   #7
ultimaa

Windows 7 Home Premium 64bit
 
 

Actually on second glance i put the packages in wrong spot had an extra packages folder after trying to fix it by following this guys advice Using CheckSUR and update packages to fix corruption - The Windows Servicing Guy - Site Home - TechNet Blogs rerunning SUR will post new logs when done
My System SpecsSystem Spec
08 Jun 2015   #8
ultimaa

Windows 7 Home Premium 64bit
 
 

Ok here is latest logs from last repair


Attached Files
File Type: log CheckSUR.log (1.4 KB, 2 views)
File Type: log CheckSUR.persist.log (33.0 KB, 2 views)
My System SpecsSystem Spec
08 Jun 2015   #9
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I think that looks OK now - you appear to have uploaded the logs before the scan completed.

Try a Check for Updates, and see what happens.
My System SpecsSystem Spec
08 Jun 2015   #10
ultimaa

Windows 7 Home Premium 64bit
 
 

Alright it worked perfectly, thank you so much for taking time to help me resolve this issue! Rep++
My System SpecsSystem Spec
Reply

 Unable to install SP1 windows 7 home premium 64bit. error 800B0100




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Win 7 Home Premium 64bit Unable to run windows update SP1
AS I said in the title, I am having problems installing windows updates. I have reformatted 3 times and get the same errors at the same spot. I ran SURT and then tried to update, but it still didn't work. Here are the files I believe you need to help me. Thank you.
Windows Updates & Activation
Unable to boot Windows 7 Home Premium 64bit dv6 using recovery disk
Hello, I have a HP dv6 that I force shutdown. Upon reboot, it asks me to do a Windows diagnostic and if I select that option, all I see is a blue screen (not the blue screen of death) and nothing else happens. No progress bar, nothing...a DOS window did appear and disappear in a flash at...
General Discussion
Install Media - Windows Home Premium 64Bit
My laptop didn't come with the recovery disc. I have a blank HD with no recovery partition. Are there any options to freely obtain the install media? I have the license sticker on my laptop. Thank You!
Installation & Setup
Windows 7 home premium x64 update error 800b0100 for sp1
Keep geting error the error code 800b0100 when I try to update window 7 home premium x64 for service pack 1 when i try to update with the file KB976932 have used surt still no sucess. Hope you can help thanks a bunch. Vicky
Windows Updates & Activation
Can't install Windows 7 Home Premium 64Bit?
Basically I'm ready to explode. As you know, I'm running Ultimate. I recently decided to upgrade to a 64 bit OS. I purchased a 250 gb harddrive for it. (dualboot 32 bit and 64 bit win7) but my ISO file won't boot. I've tried everything. Yes, my PC is 64bit capable. Please help me. P.S I don't...
Installation & Setup
Error 800B0100 for KB2425227 (Windows 7 Home Premium x64)
Hi. I am receiving errors when trying to install update KB2425227. The error is 800B0100. I have tried resetting Windows Update, running sfc and system readiness tool. No luck. Manual install does not work either. Attached are the System Readiness Tool log and sfc log. Thanks in advance!
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App