Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SP1 failing to install, 0X80073712

21 Aug 2015   #1
manuel2

Windows 7 Professional x64
 
 
SP1 failing to install, 0X80073712

Hi,
I'm trying to update this laptop running Win7 with no SP1. Since i got a limited traffic ISP plan i downloaded SP1 (windows6.1-KB976932-X86.exe) and im trying to install in like that, though it fails when updating through windows update (i cant be 100% sure but I think with the same error code).
The error it presents at the end in the Details is ERROR_SXS_COMPONENT_STORE_CORRUPT(0X80073712).
Downloaded and ran SURT (Windows6.1-KB947821-v34-x86.msu), it just completed, retried to install SP1 and got the same error.
Ran sfc /scannow and got this
Code:
...
Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log
...
My CBS.zip is in the atachments.


My System SpecsSystem Spec
.
21 Aug 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the CheckSUR error list...
Code:
Summary:
Seconds executed: 1401
 Found 2 errors
  CSI Manifest All Zeros Total count: 2

Unavailable repair files:
	winsxs\manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.20935_en-us_4fdd65da8f1fc992.manifest
	winsxs\manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.16789_en-us_66afb31075744e72.manifest
I'll post a fix protocol later for that
The SFC errors only relate to these missing files, so hopefully that'll be fixed when we repair them as well.
My System SpecsSystem Spec
22 Aug 2015   #3
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I've uploaded a file - ml2aa.zip - to my OneDrive at Noel's OneDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder ml2aa in the same place.
Open this folder - there should be two folders inside it (Manifests, and Packages)

Copy the content of the manifests folder (.manifest files) into this folder:

C:\Windows\Temp\CheckSur\Winsxs\Manifests

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.
My System SpecsSystem Spec
.

22 Aug 2015   #4
manuel2

Windows 7 Professional x64
 
 

You are a vacation saver Noel. Have some small work to finish so have to install VS2013 on the laptop (and SP1 before that) or quit vacation and head home. Added the manifests, ran SURT, checked the log, those two problems were reported as fixed. Installed SP1 with no problem after that. Attached the logs anyway since you asked. Thanks alot for your time!


Attached Files
File Type: zip CheckSURlogs.zip (1.2 KB, 0 views)
My System SpecsSystem Spec
22 Aug 2015   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Thank the powers that be for that!
Sorry it took so many iterations to get it right
Good luck!
My System SpecsSystem Spec
Reply

 SP1 failing to install, 0X80073712




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
SP1 Update repeatedly failing, error 0x80073712
Good afternoon! From what I've seen in a Whole Lot of Googling, this forum seems to have the most targeted, successful support for the kind of issue I'm seeing. I've been running Win7 Home Premium for a few years, and every single Windows Update has run successfully (with a snag now and then)...
Windows Updates & Activation
Cannot install MS Access DB engine 2010 - Error 0x80073712
Can someone help me? I tried to install Microsoft Access database engine 2010 (file ver. 14.0.6119.5) but I got error message: "Error 1935. An error occured during the installation of assembly component {9DA4DC8A-9731-3F0E-8BD5-FC17CA6848AD}. HRESUL: 0x80073712" I tried to install this DB...
Microsoft Office
2008 R2 SP1 failing to install
Hi Folks, long time lurker, first time help requester... got a Windows 2008 R2 box that is refusing to take SP1, and appears to be missing 4 repair files, that I can't find on any other server in the environment... I believe the files should be on Windows 7 as well - can someone help me...
Windows Updates & Activation
Failing to update Win 7 with SP1 and to install IE9
Hello, I installed several new updates but Service pack 1 for Win 7 keeps failing giving me the error message 0x80070541. I am using Win 7 Home Premium 32 Hebrew version, updated from Vista 7 Home Premium 32 Hebrew version I have tried twice, it gets to around 98-100% downloaded and then...
Windows Updates & Activation
Failing Install (unlike the others
Originally had Vista on the machine working fine. Purchased Win 7 Ultimate retail disks. First attempt was to do an upgrade from Vista 64bit to Win 7 64 bit. Vista read the disk fine it went through it's normal activity, choose Upgrade and than it said it was ready to reboot. Reboot >...
Installation & Setup
KB970789 Install keeps failing
Hi there...windows upgrade is trying to install the KB970789 hotfix, it downloads it but once it starts to install it, i get a window saying installation failed. Says "errors found: Code 800B0100" Any ideas what's up?
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App