Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Update Error 80073701

26 Aug 2015   #1
hunter2

Windows 7 Home Premium x64
 
 
Windows Update Error 80073701

So I've had this error for a while and I've tried close to everything.

1. I can't recover from my manufacturer's recovery disk because I've lost it (whoops)
2. I can't perform an in place upgrade because it's OEM and I can't get an ISO from Microsoft

So I hope someone can help me with this issue. Here's the details:

- The code is 80073701 (ERROR_SXS_ASSEMBLY_MISSING)
- System Update Readiness Tool says there's no errors.
- Running sfc /scannow is more helpful, but I'm not sure what updates to remove or what files to replace.
- These might be the problem areas:
WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256.Aux
WUClient-SelfUpdate-Aux-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320
WUClient-SelfUpdate-Core-CoreComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256.Core
WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320

Here's the CBS.log, if you need any more info: CBS.log


My System SpecsSystem Spec
.
27 Aug 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Please follow the Windows Update Posting Instructions and post the requested data

If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)

Please also post the C:\Windows\windowsudpate.log file
My System SpecsSystem Spec
27 Aug 2015   #3
hunter2

Windows 7 Home Premium x64
 
 
Additional Files

Whoops, here you go:
Files.zip

I just reran sfc /scannow and posted the files above (along with WindowsUpdate.log).
My System SpecsSystem Spec
.

28 Aug 2015   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the summary of the SFC scan...
Code:
	Line 21269: 2015-08-27 16:03:57, Info                  CSI    000005ff [SR] Repairing 1 components
	Line 21270: 2015-08-27 16:03:57, Info                  CSI    00000600 [SR] Beginning Verify and Repair transaction
	Line 21273: 2015-08-27 16:03:57, Info                  CSI    00000602 [SR] Cannot repair member file [l:22{11}]"PINTLGB.IMD" of Microsoft-Windows-IME-Simplified-Chinese-Core, Version = 6.1.7601.17514, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
I'll post a fix protocol for that later.

Here's what you appear to have found in the CBS log...
Code:
2015-08-26 23:46:57, Info                  CBS    Exec: Resolving Package: WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ru-RU~7.6.7600.320, Update: Aux-64and32, PinDeployment: amd64_microsoft-windows-w..oyment-languagepack_31bf3856ad364e35_7.6.7600.320_ru-ru_c844a75b10d6b521
2015-08-26 23:46:57, Info                  CSI    0000002a Performing 1 operations; 1 are not lock/unlock and follow:
  AddCat (14): flags: 0 catfile: @0x26fe058
2015-08-26 23:46:57, Info                  CSI    0000002b Performing 1 operations; 1 are not lock/unlock and follow:
  Stage (1): flags: 8 app: [Microsoft-Windows-WindowsUpdateClient-Aux.Deployment-LanguagePack, Version = 7.6.7600.320, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"ru-RU", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) comp: (null) man: @0x26fe328
2015-08-26 23:46:57, Info                  CBS    Exec: Resolving Package: WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256, Update: Aux
2015-08-26 23:46:57, Info                  CBS    Exec: Resolving Package: WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256, Update: Aux, PinDeployment: amd64_microsoft-windows-w..oyment-languagepack_31bf3856ad364e35_7.6.7600.256_ar-sa_ea82b2e8fad05210
2015-08-26 23:46:57, Error                 CSI    0000002c@2015/8/26:21:46:57.856 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
[gle=0x80004005]
2015-08-26 23:46:58, Error                 CSI    0000002d (F) STATUS_SXS_ASSEMBLY_MISSING #21196# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2015-08-26 23:46:58, Error                 CSI    0000002e (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #21081# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-WindowsUpdateClient-Aux.Deployment-LanguagePack, Version = 7.6.7600.256, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"ar-SA", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [77]"WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256.Aux", rah = [2]"32", manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2015-08-26 23:46:58, Info                  CBS    Failed to pin deployment while resolving Update: Aux from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2015-08-26 23:46:58, Info                  CBS    Failed to resolve item[0] in Package: WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256, Update: Aux [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2015-08-26 23:46:58, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2015-08-26 23:46:58, Error                 CBS    Failed to resolve execution package: WUClient-SelfUpdate-Aux-AuxComp~31bf3856ad364e35~amd64~ar-SA~7.6.7600.256 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
I think I'll be able to fix this at the same time - I'm just surprised that CheckSUR didn't pick it up.
My System SpecsSystem Spec
06 Sep 2015   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I think you may have other deeper problems... From the logs, it looks like you may have more than one MUI Language Pack installed - which breaks the Licensing terms for Home Premium, and can only be achieved by use of a hack (which carries its own dangers, including the system perhaps being declared non-genuine.

I need to see a full copy of the report produced by the MGADiag tool
(download and save to desktop - http://go.microsoft.com/fwlink/?linkid=52012 )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.x
- in your own thread, please

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
How to tell - Hardware
My System SpecsSystem Spec
10 Sep 2015   #6
hunter2

Windows 7 Home Premium x64
 
 

Wow, thanks for spotting that! I just recently got a random "Not Genuine" text thing at the bottom right of my desktop (which did fix itself with a reboot). The sticker says "Windows 7 Home Prem OA". Once again, thanks a lot for your help.

Here are the results of the tool:

Code:
Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-*****-*****-9YQTR (I blocked the last two out as well because I'm posting it to the web)
Windows Product Key Hash: PVjSC5x6njvqunmbCY3lOD7rYDo=
Windows Product ID: 00359-OEM-8992687-00007
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {17799284-2075-4488-ABAB-0203D0609698}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.140303-2144
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{17799284-2075-4488-ABAB-0203D0609698}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-9YQTR</PKey><PID>00359-OEM-8992687-00007</PID><PIDType>2</PIDType><SID>S-1-5-21-367287247-1499848727-2799565984</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc.</Manufacturer><Model>N53SN</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>N53SN.209</Version><SMBIOSVersion major="2" minor="6"/><Date>20120110000000.000000+000</Date></BIOS><HWID>01C93E07018400FE</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Romance Standard Time(GMT+01:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: d2c04e90-c3dd-4260-b0f3-f845f5d27d64
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00178-926-800007-02-1033-7600.0000-2092009
Installation ID: 095356527130381594338623734014937494969976027694676946
Processor Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88338
Machine Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88339
Use License URL: http://go.microsoft.com/fwlink/?LinkID=88341
Product Key Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88340
Partial Product Key: 9YQTR
License Status: Licensed
Remaining Windows rearm count: 0
Trusted time: 10/09/2015 16:37:31

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 8:21:2015 23:59
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: MAAAAAEAAQABAAIAAAABAAAAAwABAAEAHKJQU0xvGjhEytpERCMEPyyoBsQHii5z

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information: 
  ACPI Table Name	OEMID Value	OEMTableID Value
  APIC			_ASUS_		Notebook
  FACP			_ASUS_		Notebook
  DBGP			_ASUS_		Notebook
  HPET			_ASUS_		Notebook
  MCFG			_ASUS_		Notebook
  ECDT			_ASUS_		Notebook
  SLIC			_ASUS_		Notebook
  SSDT			PmRef		Cpu0Ist
  SSDT			PmRef		Cpu0Ist
  ASF!			INTEL 		 HCG
My System SpecsSystem Spec
10 Sep 2015   #7
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Nope - that doesn't show the characteristics of a multi-language hack having been used - so I'll post the fixes I was going to as soo as I get time to create them!

Back soon I hope.
My System SpecsSystem Spec
11 Sep 2015   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the fix for the file error, at least - I'm having problems understanding the exact cause of the component missing one, so we'll have to deal with that separately.

I've uploaded a file - hr2aa.zip - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\hr2aa
hit the enter key - if you get a 'Not Found' error try
DIR D:\hr2aa
or
DIR E:\hr2aa



The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...



XCOPY <drive>:\hr2aa <drive>:\windows\winsxs /y /i /s /v /h



(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )



run the command (it should take almost no time) and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
My System SpecsSystem Spec
Reply

 Windows Update Error 80073701




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Home Premium Fails to Update error 80073701
Since July 16 failed the Windows update. Every day Windows attempts to install updates every day it fails. Error code is 80073701. CBS.zip is too large, therefore, via this link: https://www.sendspace.com/file/wewb9x I have added a copy of the update history. It's in Dutch: Mislukt...
Windows Updates & Activation
Windows Update error 80073701 since October
When I run Windows Update I am requested to install new Windows Update software. I press "Install now" and after a while I get an error message: "Windows couldn't search for new updates. An error occurred while checking for new updates for your computer. Error(s) found: Code 80073701". I...
Windows Updates & Activation
Windows 7 Update error 80073701
Hi everyone, I've ran into this error for the last couple months while trying to install these Windows 7 updates: KB2973201 KB3002885 KB2993651 In the meantime, I've been able to install a number of other serious and optional updates. I've tried a number of things so far. Running the...
Windows Updates & Activation
Windows Update Error Code 80073701
I'm unable to install the following updates: KB2984972 KB2992611 KB3003743 KB3011780 Windows Update keeps giving Error Code 80073701. I'm using Windows 7 Home Premium 64-Bit.
Windows Updates & Activation
Windows 7 Fails to Update error 80073701
Hi, I'm trying to fix a laptop at work that is failing to run windows update. The laptop is running Windows 7 Professional x64 with SP1 The error I receive is: Code 80073701 Windows Update encountered an unknown error.
Windows Updates & Activation
Win7 Ultimate Update Failed to Win7 Sp1 Error Code 80073701
Hello I'm Having Problem Updating My Windows 7 Ultimate into Windows 7 Ultimate SP1 I Tried Using System Update Readiness Tool for Windows 7 (KB947821) But an Error Pops Up Please HELPP!!:cry:
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App