Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 update error 80246008 - since 08/13/2015

15 Sep 2015   #11
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

NoeIDP,

Thanks for replying, I do appreciate it !!!

** Do you want me to keep using the save Title? Or, would it be better to change it for each reply I am posting?


I downloaded the FRST and checked ALL of the check boxes and ran a FULL scan.

Attached are the logs ( not zipped ) from the run.

?? One thing I am curious..
- do you think a "fix" is just on horizon ??
* OR *
- should I look at removing the HDD from the laptop, install it in an external case, copy off ALL of the files to a different HDD, re-install back in the laptop, perform a full system rebuild (from the Toshiba System Recovery DVDs), take back out, put back into the external case, copy the files back over the "rebuilt" HDD?

If I were to do this, what I am most curious about is:
- if everything is "cataloged / logged" under the C:\desktop\user folder should it have everything I would need after the rebuild (LESS the installed programs)???

Make sense?!




Attached Files
File Type: txt FRST-Addition.txt (42.6 KB, 1 views)
File Type: txt FRST-Main-Log.txt (114.2 KB, 4 views)
File Type: txt FRST-Shortcut.txt (84.7 KB, 1 views)
My System SpecsSystem Spec
.
15 Sep 2015   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I ask for a simple FSS log - and get a full-blown FRST log?

PLEASE follow the instructions given - they are there for a reason.
My System SpecsSystem Spec
16 Sep 2015   #13
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

NoeIDP,


I am so very sorry. I got confused on what to download & run and I see what I did wrong. I downloaded and ran the Farbar Recovery Scan Tool (somehow I got confused on what to download).

I have downloaded the FSS tool, will run and attach the results to this message.


Attached Files
File Type: txt FSS-091615.txt (2.9 KB, 1 views)
My System SpecsSystem Spec
.

16 Sep 2015   #14
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

No problem
For some reason the BITS service has been set to Demand start -
Code:
Windows Update:
============
BITS Service is not running. Checking service configuration:
The start type of BITS service is set to Demand. The default start type is Auto.
The ImagePath of BITS service is OK.
The ServiceDll of BITS service is OK.
Please open an Elevated COmmand Prompt, and run the following command...

SC config BITS start= delayed-auto

(note the spaces!)

then close the window and reboot.

This almost certainly won't cure the problem, but at least we'll then have the settings where we need them to have any hope of a solution.

Once rebooted, post the C:\Windows\windowsupdate.log file, and a new set of Event logs.
My System SpecsSystem Spec
16 Sep 2015   #15
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

NoeIDP,

c:\windows\system32>SC config BITS start= delayed-auto
[SC] ChangeServiceConfig SUCCESS

c:\windows\system32>

** Rebooted

** I checked the BITS service and it is currently set to: "blank status" / Automatic (Delayed Start)

** Uploaded: c:\windows\WindowsUpdate.log

** Uploaded: Applications.zip, System.zip

============================

1) post the C:\Windows\windowsupdate.log

open administration and get the event logs:

2) Control Panel >> All Control Panel Items >> Administrative Tools >> Event Viewer

+ Windows Logs >> Application <LC>
Action >> Save All Events As...

+ Windows Logs >> System <LC>
Action >> Save All Events As...

then zip both, and upload them.


Attached Files
File Type: zip Applications.zip (2.09 MB, 0 views)
File Type: zip System.zip (1.73 MB, 1 views)
File Type: zip WindowsUpdate.zip (129.9 KB, 1 views)
My System SpecsSystem Spec
17 Sep 2015   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You have Comodo installed as AV - and it's not loading properly.
Please uninstall it - at least temporarily - and replace it with MSE.

You appear also to have at least residues from Kaspersky and AVG installed - you need to run their removal programs to get rid of the dregs...

http://www.avg.com/us-en/utilities
Service articles
reboot after each- then...
After the reboot, open an Elevated Command Prompt, and run the following command

NETSH WINSOCK RESET

You'll be advised to reboot - do so.

post a new set of event logs, and windowsupdate.log
My System SpecsSystem Spec
17 Sep 2015   #17
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

** MSE was installed a few threads ago.

1) Ran AVG 64-bit uninstaller 2015
- no modules were installed ???
- "specified service" does not exist as an installed service (dozen's of these messages)
>>> [SC] OpenService FAILED 1060:
>>> More help is available by typing "NET HELPMSG 2185"
>>> c:\windows\system32\config\systemprofile\appdata\local\avg2013 - not found
>>> c:\programdata\avg security toolbar - not found
>>> WARN 'AVGDIR' in empty (program/data folder is empty and computer was restarted) ???
>>> No idea if this worked or did anything at all...

2) REBOOT laptop

3) Ran AVG 64-bit uninstaller 2015
- not sure what version I may have installed back then
- pretty much the SAME messages as the 64-bit uninstaller

4) REBOOT laptop

5) Unzipped / Run KAV Ininstaller ( from link provided )
- Tried AV 2009 ( no idea what version I may have had )...
- REBOOTED / laptop was much slower to boot
- Tried AV 2010 ( did I have this version ??)
- REBOOTED / laptop still a little slow to boot
- Tried AV / Internet Security 2011 ( no idea what I had installed )
- REBOOTED / laptop a little faster to boot
- Tried AV / Internet Security 2012 ( no idea what I had installed )
- REBOOTED / laptop a little slower to boot
- Tried AV / Internet Security 2013 ( no idea what I had installed )
- REBOOTED / laptop a little faster to boot
- Tried AV / Internet Security 2014 ( no idea what I had installed )
- REBOOTED / laptop a little faster to boot

5) Ran Comodo Uninstaller Tool ( from link provided )
- Chose Comodo Internet Security
>>> [SC] OpenService FAILED 1060:
>>> The process: "cmdagent.exe", "cfp.exe" NOT FOUND
>>> Several more "[SC] OpenService FAILED 1060:" messages
>>> Failed to delete several files in c:\users\Scott\AppData\Local\temp\*.log (type)
>>> REGINI: CreateKey (\Registry\Machine\System\CurrentControlSet\Enum\Root\LEGACY_CMDAGENT) relative to handle (000000000) FAILED - damn script took off and I could not see anymore.
>>> Then saw a toolbar pop-up "The Windows Security Center service can't be started [CLOSE]"
>>> Then saw the damn pop-up for me to "Reserve my copy of Windows 10" ( I ALWAYS close this window )
- REBOOTED / laptop a lot faster to boot

6) Ran Comodo Uninstaller Tool ( from link provided )
- Chose Uninstall Comodo Geekbuddy / LivePCSupport ( it used to be an AUTOMATIC install w/all Comodo tools )
>>> Ran too quickly to see IF it found / removed anything
- REBOOTED / laptop a little slower to boot

7) Open command prompt as Administrator ( elevated ?? )
- c:\windows\system32\NETSH WINSOCK RESET
>>> Successfully reset the Winsock Catalog
>>> You must restart your computer in order to complete the reset.
- REBOOTED / laptop about the same as last for booting

8) Start >> Control Panel >> Administrative Tools
- Services
>>> BITS: status: (blank) / startup Type: Automatic (delayed)
- Event Viewer
>>> Windows Logs >> Application (saved to file)
>>> Windows Logs >> System (saved to file)
>>> I also found an Application log for Comodo IS from 04/12/2015 (Applications & Services Logs)????
>>> WindowsUpdates log (saved to file)


Attached Files
File Type: zip Application.zip (2.10 MB, 0 views)
File Type: zip Comodo Internet Security.zip (3.7 KB, 1 views)
File Type: zip System.zip (1.87 MB, 1 views)
File Type: zip WindowsUpdate.zip (144.0 KB, 1 views)
My System SpecsSystem Spec
18 Sep 2015   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Comodo is still hanging on in there
Open Device Manager
Click on View > Show hidden Devices
With luck, you'll find an entry for the Comodo (something or other) that's been tagged with either a yellow triangle or a red cross over its icon.
Right-click on it, and select Uninstall. Accept the warnings/messages and once complete, reboot again.
Go back into Device Manager, and check that the entry is still gone, then try Windows Update again, and post the new windowsupdate.log file
My System SpecsSystem Spec
19 Sep 2015   #19
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

1) Opened Device Manager

2) Showed Hidden Devices
>>> NO devices have a yellow "/\" or a red "+" on them

>>> Showing Hidden Devices only brings into the tree the "Non-Plug and Play Drivers"

>>> None of these "devices" have a yellow "/\" or a red "+" on them

>>> NOTHING stood out or described as being associated with Comodo...


Did any of the "Non-Plug & Play Devices" stand out to you?
>>> I see these that seem odd to me:

***> avgtp; Device Instance Path: "ROOT\Legacy_AVGTP\0000"; Class icon path: "%SystemRoot%\System32\setupapi.dll,-19;
Driver Files: "\??\C:\windows\system32\drivers\avgtpx64.sys"; Device is STARTED; Startup type is SYSTEM

***> hagel technologies DU Meter traffic accounting driver; Device is STOPPED; Startup type is DEMAND; Class icon path: "same as avgtp";

***> MFE_RR; "same basic info as above"

***> SASDIFSV; Driver Files: "\??\c:\Program Files\SUPERAntiSpyware\SASDIFSV.SYS"; Device is STARTED; Startup type is SYSTEM;
( the FREE version is installed on the laptop - but NOT setup for the 30-day trial )

***> SASKUTIL; Driver Files: "\??\c:\Program Files\SUPERAntiSpyware\SASKUTIL64.SYS"; Device is STARTED; Startup type is SYSTEM;

***> Security Driver; Driver Files: "c:\windows\system32\drivers\secdrv.sys"; Provider: "Macrovision Corporation, Macrovision Europe (c) 2006 Macrovision Corporation"; Device is STARTED; Startup type is AUTOMATIC; Device Description "Security Driver";

***> TDEIO; Device is STOPPED; Startup type is DEMAND;

3) To see devices "Non Present Devices in Device Manager", I did the following:
- Control Panel >> Systems Page >> Clicked Advanced Settings (on the left)
- Clicked "Environment Variables"
- Clicked "New" in the lower System Variables Section
- Entered devmgr_show_nonpresent_devices for the Variable Name
- Entered 1 for the Variable Value
- Clicked "OK"
- Returned to Device Manager >> Show Hidden Devices
* now see ALL kinds of devices greyed out, including:

- "Disk Drives"
Disk Drive, Disk Drive, Generic Flash Disk USB Device, Generic - Multi-Card USB Device, HDT72252 0DLAT80 USB Device,
Hitachi HDS721010CLA332 USB Device, hp v165r USB Device, LG VN530 USB Device, LG VN530 USB Device, SD Card,
TOSHIBA MK6475GSX ATA Device (the one before is darkened I guess showing active), TOSHIBA MK6475GSX SATA Device,
USB 2.0 USB Flash Drive USB Device, USB 2.0 USB Flash Drive USB Device, USB Device.

- "DVD/CD-Rom Drives"
There are several greayed out, only "TSSTcorp CDDVDW SN-208AB ATA Device" is darkened

- "Floppy Disk Drive"
Just one item "MITSUMI USB FDD 070MUSB Device"

- "Human Interface Devices"
ALL of these are greyed out as "USB Input Device"

- "IDE ATA/ATAPI Devices"
Greyed out "AMD SATA Controller, ATA Channel 0, ATA Channel 1"; there are several darkened with the same names

- "Keyboards"
Greyed out "HID Keyboard Device"; Darkened "Standard PS/2 Keyboard"

- "Network Adapters"
Greyed out "RAS Async Adapter, Remote NDIS based Internet Sharing Device"

- "Non-plug and Play Devices"
There are DOZENS in here, including:
"COMODO Internet Security Eradication Driver",
"COMODO Internet Security Firewall Driver",
"COMODO Internet Security Helper Driver",
"COMODO Internet Security Sandbox Driver",
ALL are reporting the following status "Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer."
>>> I have UNINSTALLED all 4 of these devices.

>>> REBOOTED /
Laptop booted fairly quick
* NO DICE, BITS still NOT started!!!!!!

>>> Will return to Device Manager as I also saw some other greyed items for Avast! and AVG, Symantec, Zone Alarm Firewall Driver, PCToolsProtectInjDev lingering around ( just LOTS of weirdly named ones too )..

"Avast! HardwareID",
"Avast! Reverter",
"Avast! VM Monitor",
* DELETED / REBOOTED / Laptop Booted faster
* BITS showed STARTING & Automatic (Delayed) - Pressed F5 (refresh) Status is BLANK!!!

>>> Will return to Device Manager and DELETE the AVG items

"avg??",
"avgtp",
"avkmgr",
* DELETED / REBOOTED / Laptop booted about the same.
* BITS showed STATUS - BLANK & Automatic (Delayed)

>>> Will return to Device Manager and DELETE Symantec, Zone Alarm Firewall & PCToolsProjectInjDev
"PCToolsProjectIngDev",
"Symantec Eraser Control driver",
"Symantec Iron Driver",
"Symantec Network Security WFP Driver",
"Zone ALarm Firewall Driver"
* DELETED / REBOOTED / Laptop booted about the same
* BITS showed STATUS: BLANK & Automatic (Delayed)
* Still cannot start manually

>>> Will return to Device Manager and DELETE ALL devices with a code 45 - "Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer."
"LG CDMA USB Modem", First install date: 08/18/15 ( around the time when updates stopped working )
"8GB Thumb",
"E:\",
"E:\",
"HP v165r",
"MEI-Thumb",
"USB Disk",
* DELETED / REBOOTED / Laptop took a little longer
* BITS showed STATUS: BLANK & Automatic (Delayed) - COM+ and RPC show STARTED / AUTOMATIC

>>> Put together the log(s) requested at this point...


Attached Files
File Type: zip Applications.zip (2.12 MB, 0 views)
File Type: zip System.zip (1.99 MB, 0 views)
File Type: zip WindowsUpdate.zip (167.7 KB, 0 views)
My System SpecsSystem Spec
21 Sep 2015   #20
scottie916

Windows 7 Home Premium 64-bit SP1
 
 
Windows 7 update error 80246008 - since 08/13/2015

NoeIDP,

I was wondering if you have reviewed my "verbose" results from the last iteration for my Toshiba Laptop with Win 7 SP1 that will not update anything...

I hope I did not bombard you with far too much detail.

Still needing your expertise.

-Scott
My System SpecsSystem Spec
Reply

 Windows 7 update error 80246008 - since 08/13/2015




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Update Error 80246008 in Windows 7 - Fix
Windows Update Error 80246008 in Windows 7 - Fix Reasons This error is caused by issues with Background Inteligence Transfer Service or with COM+ Event System Troubleshooting
Tutorials
Can't install Windows 7 SP1 x64, error 80246008
Hello, I'm unable to install Windows 7 SP1 x64 for some reason, I can't figure out why, I tried a lot of things already. Whenever I try installing it (manually or from Windows Update) it just starts going for a while, then gives me a 80246008 error. Tried running SURT, didn't help. Tried...
Windows Updates & Activation
Windows Update error 80246008
My computer for some reason has not been able to do updates for several weeks because I keep getting the above error. When I click on it to get help with this error it tells me I need to change or restart the Background Intelligent Transfer Service (BITS) by opening Administrative Tools, then...
Windows Updates & Activation
Update error 80246008, Restart on Shutdown, dll startup error
This is a family member's laptop. It is a Dell Inspirion N4110 running Win 7 Home Premium x64 They gave it to me complaining that the shutdown button restarts the computer and will not actually shut it down. So I checked its preferences, they were fine. I went into the registry and changed the...
Windows Updates & Activation
Windows Update Error 80246008 and more problems
Hello forum. I'm running Windows 7 Home Premium 64 bit. I checked the update log on our computer, and I was really surprised that every update has failed for months. I tried a manual update, and I got error 80246008. So I went to Administrative tools >>> Services >>>
Windows Updates & Activation
Update error 80246008 with BITS unable to start
Hey all, Windows updates and Microsoft Security Essentials won't update, Windows Update giving the error code 80246008. Looks like cause is the Background Intelligent Transfer Service is unable to start. Error when trying to start the service: Things I've done: 1. Ran sfc /scannow (no...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App