Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Activation and Update errors

19 Sep 2015   #11
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You have a couple of major errors in the CheckSUR...
Code:
(w)	Unable to open Event Log	0x000006B5	Application		OpenEventLog failed: 0x000006B5 - The interface is unknown.
.
(w)	Unable to open Event Log	0x000006B5	System		OpenEventLog failed: 0x000006B5 - The interface is unknown.
.
Please open an Elevated Command Prompt, and run the following commands....


NET START WECSVC
NET START WERSVC
NET START EVENTLOG
SC QUERYEX WERSVC
SC QC WERSVC
SC QUERYEX WECSVC
SC QC WECSVC
SC QUERYEX EVENTLOG
SC QC EVENTLOG


post the results...


Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.


My System SpecsSystem Spec
.
19 Sep 2015   #12
rmk9785e

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Thank you for detailed instructions. At first, this command gave an error.

C:\>NET START EVENTLOG
The Windows Event Log service is starting.
The Windows Event Log service could not be started.

A system error has occurred.
System error 5 has occurred.
Access is denied.

In order to correct this, I searched Microsoft sites and applied this fix. I then ran the commands again and received these results. What should I do next?

Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\>NET START WECSVC
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

C:\>NET START WERSVC
The Windows Error Reporting Service service is starting.
The Windows Error Reporting Service service was started successfully.

C:\>NET START EVENTLOG
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

C:\>SC QUERYEX WERSVC

SERVICE_NAME: WERSVC
        TYPE               : 20  WIN32_SHARE_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 6324
        FLAGS              :

C:\>SC QC WERSVC
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: WERSVC
        TYPE               : 20  WIN32_SHARE_PROCESS
        START_TYPE         : 3   DEMAND_START
        ERROR_CONTROL      : 0   IGNORE
        BINARY_PATH_NAME   : C:\Windows\System32\svchost.exe -k WerSvcGroup
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : Windows Error Reporting Service
        DEPENDENCIES       :
        SERVICE_START_NAME : localSystem

C:\>SC QUERYEX WECSVC

SERVICE_NAME: WECSVC
        TYPE               : 20  WIN32_SHARE_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 1332
        FLAGS              :

C:\>SC QC WECSVC
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: WECSVC
        TYPE               : 20  WIN32_SHARE_PROCESS
        START_TYPE         : 3   DEMAND_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : C:\Windows\system32\svchost.exe -k NetworkService
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : Windows Event Collector
        DEPENDENCIES       : HTTP
                           : Eventlog
        SERVICE_START_NAME : NT AUTHORITY\NetworkService

C:\>SC QUERYEX EVENTLOG

SERVICE_NAME: EVENTLOG
        TYPE               : 20  WIN32_SHARE_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 352
        FLAGS              :

C:\>SC QC EVENTLOG
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: EVENTLOG
        TYPE               : 20  WIN32_SHARE_PROCESS
        START_TYPE         : 2   AUTO_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : C:\Windows\System32\svchost.exe -k LocalServiceNetw
orkRestricted
        LOAD_ORDER_GROUP   : Event Log
        TAG                : 0
        DISPLAY_NAME       : Windows Event Log
        DEPENDENCIES       :
        SERVICE_START_NAME : NT AUTHORITY\LocalService
My System SpecsSystem Spec
19 Sep 2015   #13
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Ah - I'm not certain about the permissions here... even if it seems to have fixed the problem for now, they may still be wrong. Did you use a Windows 7 machine to create the permissions file?

Please upload the file and also run the following commands and post the results...

ICACLS C:\Windows\System32\winevt
ICACLS C:\Windows\System32\winevt\Logs\System.evtx
My System SpecsSystem Spec
.

19 Sep 2015   #14
rmk9785e

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I didn't create a permissions file from another Windows 7 machine but rather manually changed permissions of the folder on this machine following directions in that KB. Which file should I upload?
The results of these two commands are here:

Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\ICACLS C:\Windows\System32\winevt
C:\Windows\System32\winevt NT SERVICE\TrustedInstaller:(I)(F)
                           NT SERVICE\TrustedInstaller:(I)(CI)(IO)(F)
                           NT AUTHORITY\SYSTEM:(I)(F)
                           NT AUTHORITY\SYSTEM:(I)(OI)(CI)(IO)(F)
                           BUILTIN\Administrators:(I)(F)
                           BUILTIN\Administrators:(I)(OI)(CI)(IO)(F)
                           BUILTIN\Users:(I)(RX)
                           BUILTIN\Users:(I)(OI)(CI)(IO)(GR,GE)
                           CREATOR OWNER:(I)(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\ICACLS C:\Windows\System32\winevt\Logs\System.evtx
C:\Windows\System32\winevt\Logs\System.evtx BUILTIN\Administrators:(I)(F)
                                            NT SERVICE\eventlog:(I)(F)
                                            BUILTIN\Users:(I)(F)
                                            NT SERVICE\TrustedInstaller:(I)(F)
                                            NT AUTHORITY\SYSTEM:(I)(F)

Successfully processed 1 files; Failed processing 0 files
My System SpecsSystem Spec
19 Sep 2015   #15
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The permissions are definitely strange - but should work.
The problem as I see it is that the permissions have been opened up way too far - Users aren't supposed to have access to the winevt folder at all unless they are member of the Administrators group at least.
From those results it looks to me like the System32 folder (if not the Windows folder) has the master permissions for the Users - and this is positively dangerous, as it opens the system to every malware on the internet.


Please open an Elevated Command Prompt, and run the following commands...

ICACLS C:\Windows\System32
ICACLS C:\Windows
ICACLS C:\

Post the results.
My System SpecsSystem Spec
19 Sep 2015   #16
rmk9785e

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I'll be glad to change them as appropriate.

Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\WMC_HT>cd\

C:\>ICACLS C:\Windows\System32
C:\Windows\System32 NT SERVICE\TrustedInstaller:(I)(F)
                    NT SERVICE\TrustedInstaller:(I)(CI)(IO)(F)
                    NT AUTHORITY\SYSTEM:(I)(F)
                    NT AUTHORITY\SYSTEM:(I)(OI)(CI)(IO)(F)
                    BUILTIN\Administrators:(I)(F)
                    BUILTIN\Administrators:(I)(OI)(CI)(IO)(F)
                    BUILTIN\Users:(I)(RX)
                    BUILTIN\Users:(I)(OI)(CI)(IO)(GR,GE)
                    CREATOR OWNER:(I)(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\>ICACLS C:\Windows
C:\Windows NT SERVICE\TrustedInstaller:(F)
           NT SERVICE\TrustedInstaller:(CI)(IO)(F)
           NT AUTHORITY\SYSTEM:(M)
           NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
           BUILTIN\Administrators:(M)
           BUILTIN\Administrators:(OI)(CI)(IO)(F)
           BUILTIN\Users:(RX)
           BUILTIN\Users:(OI)(CI)(IO)(GR,GE)
           CREATOR OWNER:(OI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\>ICACLS C:\
C:\ BUILTIN\Administrators:(F)
    BUILTIN\Administrators:(OI)(CI)(IO)(F)
    NT AUTHORITY\SYSTEM:(F)
    NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
    BUILTIN\Users:(OI)(CI)(RX)
    NT AUTHORITY\Authenticated Users:(OI)(CI)(IO)(M)
    NT AUTHORITY\Authenticated Users:(AD)
    Mandatory Label\High Mandatory Level:(OI)(NP)(IO)(NW)

Successfully processed 1 files; Failed processing 0 files

C:\>
My System SpecsSystem Spec
19 Sep 2015   #17
rmk9785e

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I tried installing pending updates a few at a time. One of them failed.

Update for Windows 7 for x64-based Systems (KB3080149)

Installation date: ‎9/‎19/‎2015 3:25 PM

Installation status: Failed

Error details: Code 80070490

Update type: Recommended

Install this update to resolve issues in Windows. For a complete listing of the issues that are included in this update, see the associated Microsoft Knowledge Base article for more information. After you install this item, you may have to restart your computer.

More information:
http://support.microsoft.com/kb/3080149
My System SpecsSystem Spec
20 Sep 2015   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That's an odd one to fail.
Please post the new CBS.log file and windowsupdate.log file.
My System SpecsSystem Spec
20 Sep 2015   #19
rmk9785e

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Noel,
I wish to sincerely thank you for your patience and efforts in trying to revive my corrupted system. I am unable to boot it to upload the current BCD log files. Unfortunately, it is now beyond repair. After the last updates, it again became unstable and would not boot. I tried Windows repair using the original install media but it continued to fail to repair it or restore it to a restore point. Chkdsk shows no errors and memory tests complete without a problem. It's possible that some malware messed it up.
I was using the system primarily as an HTPC to run Windows Media Center. I'll just have to upgrade to Windows 10 and learn to work with MediaPortal as a replacement for WMC.
Thank you again, for your generosity in sharing your expertise. These forums are a great resource.
My System SpecsSystem Spec
21 Sep 2015   #20
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Good luck with it!
My System SpecsSystem Spec
Reply

 Windows Activation and Update errors




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Activation Errors
I was trying to update to Windows 10 from Windows 7 Ultimate SP1, but suddenly Windows 10 was asking me for my product key, saying my Windows 7 Ultimate wasn't genuine. When I try " SLMGR -REARM " in CMD as Administrator this comes up: http://i.imgur.com/nFyMrdy.png Also when I try...
Windows Updates & Activation
Activation: Not Genuine, Windows Update Failing to Install (Errors)
Hello, everybody. I've had a rather rough time, lately, with my computer. For whatever reason, I could not update my computer via Windows Update. I constantly had errors. I could not figure out why nothing was downloading, and I found no solutions to the problem. Fast-Forward to about 5 days ago,...
Windows Updates & Activation
Windows 7 SP1 update failed, causing Windows Update errors
Hi, Running IE 9 and tried to update to IE 11. Said I needed to update my Windows 7, 64 to SP1. found the update and attempted to install. Install failed and message said "restart your computer and try again" tried again and it failed again. Now Windows Update cannot update the PC, error message...
Windows Updates & Activation
Windows Update - Activation Failing
Hi All, I have started getting the following error when trying to run windows update and when I try and activate my Windows. Error 80072EE2 I have been able to run Windows update in the past. Any thoughts???
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App