Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't install SP1, CSI payload files missing

02 Oct 2015   #1
Lemnis8

Windows 7 Home Premium 32bit
 
 
Can't install SP1, CSI payload files missing

First off, this is technically a repost. I am reposting after following the instructions here Windows Update Posting Instructions

I cannot install windows service pack 1. I attached my error code screenshot. I created a CBS.zip but it was too large to attach (more on that below). After troubleshooting windows update, I completed the following steps:

1. System Update Readiness Tool
I downloaded and installed/ran the appropriate SURT for my system and let it complete.

2. SFC Scan
I opened an elevated command prompt and entered the sfc /scannow command. After it completed, it stated 'Windows found no integrity violations'

3. Windows Update Error Codes
After completing the two above steps, I attempted to install SP1 again. The error code I get is 80073712 as seen in the attached screenshot.

4. Log Collection
I copied the CBS folder from C:\Windows\Logs to my desktop then sent it to a compressed zip folder. When I checked the CheckSUR text, it said I had several CSI payload files missing. From other threads, it seems that I need to obtain these files somehow. I'm not sure what steps to take after this.

My compressed zip CBS folder is too big to attach, approximately 15MB and the limit is 8MB. Is there another way I can upload it here that is acceptable? I also cannot for the life of me locate my original disc to do a repair install. Thanks for any help!




Attached Thumbnails
Can't install SP1, CSI payload files missing-errorcode.png  
My System SpecsSystem Spec
.
02 Oct 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

remove the older CBSPersist files from the archive until the compressed size is under the 8MB limit, then upload the file.
My System SpecsSystem Spec
02 Oct 2015   #3
Lemnis8

Windows 7 Home Premium 32bit
 
 

Thank you, I removed the older CBSPersist files from the archive and now the zip folder is less than 8MB, I have attached it here.
My System SpecsSystem Spec
.

02 Oct 2015   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Interesting - the CheckSUR finds only two problems with corrupt/missing files, and SFC finds none, but the SP1 installer finds a number of problems...

Code:
	Line 340753: 2015-10-01 21:37:12, Info                  CSI    000001c4 Hashes for file member \??\C:\Windows\win.ini do not match actual file [l:14{7}]"win.ini" :
	Line 340839: 2015-10-01 21:37:14, Info                  CSI    000001c5 Hashes for file member \??\C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config do not match actual file [l:28{14}]"machine.config" :
	Line 341010: 2015-10-01 21:37:17, Info                  CSI    000001c6 Hashes for file member \??\C:\Windows\fonts\cambria.ttc do not match actual file [l:22{11}]"cambria.ttc" :
	Line 341012: 2015-10-01 21:37:17, Info                  CSI    000001c7 Hashes for file member \??\C:\Windows\fonts\cambriab.ttf do not match actual file [l:24{12}]"cambriab.ttf" :
	Line 341014: 2015-10-01 21:37:17, Info                  CSI    000001c8 Hashes for file member \??\C:\Windows\fonts\cambriai.ttf do not match actual file [l:24{12}]"cambriai.ttf" :
	Line 341016: 2015-10-01 21:37:17, Info                  CSI    000001c9 Hashes for file member \??\C:\Windows\fonts\cambriaz.ttf do not match actual file [l:24{12}]"cambriaz.ttf" :
	Line 341162: 2015-10-01 21:37:19, Info                  CSI    000001ca Hashes for file member \??\C:\Windows\System32\Recovery\ReAgent.xml do not match actual file [l:22{11}]"ReAgent.xml" :
	Line 341182: 2015-10-01 21:37:19, Info                  CSI    000001cb Hashes for file member \??\C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Games\Desktop.ini do not match actual file [l:22{11}]"Desktop.ini" :
	Line 341552: 2015-10-01 21:37:28, Info                  CSI    000001cd Hashes for file member \??\C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Accessories\Tablet PC\Desktop.ini do not match actual file [l:22{11}]"Desktop.ini" :
I have to admit that I'm none too certain what exactly these error messages imply, yet.
I'll have to go into the code deeper and see what I can find.

I'll post a fix protocol for the missing payload files later - gotta get to work now.
Code:
Checking Component Store
(f)	CSI Payload File Missing	0x00000000	csrsrv.dll	x86_microsoft-windows-csrsrv_31bf3856ad364e35_6.1.7601.22280_none_cbc86ec01cf9ddde	
(f)	CSI Payload File Missing	0x00000000	csrsrv.dll	x86_microsoft-windows-csrsrv_31bf3856ad364e35_6.1.7601.18113_none_cb8d824703a0c682	

Summary:
Seconds executed: 804
 Found 2 errors
  CSI Payload File Missing Total count: 2
My System SpecsSystem Spec
02 Oct 2015   #5
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

OK - a little checking shows that the versions of the files found by SP1 are actually from SP1 - so obviously, at some point a partial install has happened, but the rollback didn't properly remove the new files which were already in place.
I'm not sure how to proceed with this, but I'll think about it
My System SpecsSystem Spec
02 Oct 2015   #6
Lemnis8

Windows 7 Home Premium 32bit
 
 

Thanks for your reply, that's interesting. The install does seem to be successful up until the very end and it cannot complete, so that does seem to be possible that it partially installed somehow.
My System SpecsSystem Spec
02 Oct 2015   #7
Lemnis8

Windows 7 Home Premium 32bit
 
 

Hmm should I try to uninstall any of the sp1 that partially installed? Also I'm not sure where to get the missing csi payload files and how to put them back in the right way. I'm trying to avoid messing up my whole computer. Thanks for any suggestions and ideas. Also, a last resort option could be to install a different version of windows, as my friend has their disc. :/
My System SpecsSystem Spec
Reply

 Can't install SP1, CSI payload files missing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Win 7 unable to install SP1, CSI Payload File Missing
Some time ago, Noel had a remarkable record for finding missing files. I wonder if he could do it again. I have inherited this machine from a recently deceased friend. I think it came with Vista, and he installed Win 7 a long time ago. I'd like to keep it, but it needs SP1 to be eligible for...
Windows Updates & Activation
Missing 8 CSI Payload Files, Cant update windows
Hi. title says it all, attempting to install service pack 1 has proved futile and it turnes out im missing some stuff also i am having an extremely hard time adding the CBS.log and CheckSur.log in this post, im going to be posting them in a link to my one drive ...
Windows Updates & Activation
CSI Payload Files Missing - Cannot Install Windows Updates
Hi team, and especially NoelDP. I have eleven CSI payload files missing, and NoelDP, I see you have been able to help a lot of people find these files and re-install them on their system. I have attached a copy of CheckSUR.log, as well as a CBS.log from a SFC scan I ran today. If you could...
Windows Updates & Activation
Windows 7 Updates Failing - CSI payload files missing
I am working on a computer for over a week now. Each time I run Windows updates it appears to complete successfully but upon reboot all changes are reverted. Ultimately I am trying to upgrade to IE 10 or 11 from 8 but would like to fix the Windows update mechanism as well. I have run CheckSur...
Windows Updates & Activation
Issues installing Win 7 SP1, CSI payload files missing
Hi, I'm having trouble installing Win 7 SP1, after running the system update readiness tool I got this output ================================= Checking System Update Readiness. Binary Version 6.1.7601.21645 Package Version 17.0 2012-12-02 11:53
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App