Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Update restart loop

04 Oct 2015   #1
maccaroni

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Windows Update restart loop

Greetings,

I have a problem with Windows Update. The system(windows update)
returns that must be rebooted to install important updates-
of course after a restart situation is the same

A step that i taken :

FIX tool WU
Stop update service -> change the name of the directory -> restart services
Stop update service -> delete the data in catalogs Download and Data ( c: \ windows \ Software Distribution -> restart services
Windows Update Diagnostic Tool - > at the end I get an error : 80070003
Any update fixes from Microsoft
CHKDSK repair and scannow

I am attaching log ( c: \ windows \ logs and c : \ windows \ Software Distribution

Any thoughts?




Attached Files
File Type: txt CheckSUR.persist.txt (9.4 KB, 1 views)
File Type: txt CheckSUR.txt (394 Bytes, 0 views)
File Type: txt ReportingEvents.txt (2.1 KB, 0 views)
My System SpecsSystem Spec
.
04 Oct 2015   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Open an Elevated Command Prompt.

At the prompt, run the following commands.

DEL C:\Windows\System32\config\TxR\*.* /q
DEL C:\Windows\System32\config\TxR\*.* /ah /q
fsutil resource setautoreset true C:\


then wait 10 minutes, and reboot - then try Windows Update
My System SpecsSystem Spec
04 Oct 2015   #3
maccaroni

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Noel, thanks for trying to help me

Quote   Quote: Originally Posted by NoelDP View Post
Open an Elevated Command Prompt.

At the prompt, run the following commands.

DEL C:\Windows\System32\config\TxR\*.* /q
DEL C:\Windows\System32\config\TxR\*.* /ah /q
fsutil resource setautoreset true C:\


then wait 10 minutes, and reboot - then try Windows Update
after typing first 2 lines i am getting 'access denied' to all listed files, isnt something wrong?
My System SpecsSystem Spec
.

04 Oct 2015   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Maybe, maybe not - try running the commands while in Safe Mode, and see if that helps.
My System SpecsSystem Spec
04 Oct 2015   #5
maccaroni

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

In safe mode i have the same situation -> acces denied for all .DLL ;/
My System SpecsSystem Spec
04 Oct 2015   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

OK - try this set of instructions instead...

fsutil resource setautoreset true %systemdrive%\

attrib -r -s -h %SystemRoot%\System32\Config\TxR\*
del %SystemRoot%\System32\Config\TxR\*

attrib -r -s -h %SystemRoot%\System32\SMI\Store\Machine\*
del %SystemRoot%\System32\SMI\Store\Machine\*.tm*
del %SystemRoot%\System32\SMI\Store\Machine\*.blf
del %SystemRoot%\System32\SMI\Store\Machine\*.regtrans-ms
My System SpecsSystem Spec
04 Oct 2015   #7
maccaroni

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by NoelDP View Post
OK - try this set of instructions instead...

fsutil resource setautoreset true %systemdrive%\

attrib -r -s -h %SystemRoot%\System32\Config\TxR\*
del %SystemRoot%\System32\Config\TxR\*

attrib -r -s -h %SystemRoot%\System32\SMI\Store\Machine\*
del %SystemRoot%\System32\SMI\Store\Machine\*.tm*
del %SystemRoot%\System32\SMI\Store\Machine\*.blf
del %SystemRoot%\System32\SMI\Store\Machine\*.regtrans-ms

After typing line 3 i got that files are being used by another process, for files listed below:
.TMContainer0000000000000000000001.regtrans-ms
.TMContainer0000000000000000000002.regtrans-ms
.TMContainer0000000000000000000003.regtrans-ms
.TMContainer0000000000000000000004.regtrans-ms
.TMContainer0000000000000000000005.regtrans-ms


For last 3 line i got that system cannot locate any file


;//
My System SpecsSystem Spec
04 Oct 2015   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I thinks that's as good as it's going to get - please post a new CBS.log and I'll take a look and see if anything has changed
My System SpecsSystem Spec
04 Oct 2015   #9
maccaroni

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Sure
My System SpecsSystem Spec
05 Oct 2015   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Here's the full text of one error sequence...
Code:
2015-10-03 09:01:23, Info                  CSI    00000004 IAdvancedInstallerAwareStore_ResolvePendingTransactions (call 1) (flags = 00000004, progress = NULL, phase = 0, pdwDisposition = @0xc4fc80
2015-10-03 09:01:23, Info                  CSI    00000005 Creating NT transaction (seq 1), objectname [6]"(null)"
2015-10-03 09:01:23, Info                  CSI    00000006 Created NT transaction (seq 1) result 0x00000000, handle @0x1ec
2015-10-03 09:01:23, Error                 CSI    00000007 (F) STATUS_RM_NOT_ACTIVE #155# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey(flg = (AllowAccessDenied), key = {provider=NULL, handle=0}, da = (KEY_SET_VALUE|KEY_WOW64_64KEY), oa = @0xc4ef60->OBJECT_ATTRIBUTES {s:48; rd:NULL; on:[28]"\Registry\Machine\COMPONENTS"; a:(OBJ_CASE_INSENSITIVE)}, disp = Unmapped disposition: 12906240 (0x00c4ef00))[gle=0xd0190005]
2015-10-03 09:01:23, Error                 CSI    00000008@2015/10/3:07:01:23.225 (F) d:\win7sp1_gdr\base\wcp\sil\merged\ntu\ntsystem.cpp(3676): Error STATUS_RM_NOT_ACTIVE originated in function Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey expression: (null)
[gle=0x80004005]
2015-10-03 09:01:23, Info                  CBS    Succesfully flushed NtfsLog.etl
2015-10-03 09:01:23, Info                  CBS    Succesfully added NtfsLog.etl to WER Report
2015-10-03 09:01:23, Error                 CSI    00000009 (F) STATUS_RM_NOT_ACTIVE #154# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey(flg = 0, key = {provider=NULL, handle=0}, da = (KEY_SET_VALUE|KEY_WOW64_64KEY), oa = @0xc4ef60->OBJECT_ATTRIBUTES {s:48; rd:NULL; on:[28]"\Registry\Machine\COMPONENTS"; a:(OBJ_CASE_INSENSITIVE)}, disp = Unmapped disposition: 12906712 (0x00c4f0d8))[gle=0xd0190005]
2015-10-03 09:01:23, Error                 CSI    0000000a@2015/10/3:07:01:23.624 (F) d:\win7sp1_gdr\base\wcp\sil\merged\ntu\ntsystem.cpp(3676): Error STATUS_RM_NOT_ACTIVE originated in function Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey expression: (null)
[gle=0x80004005]
2015-10-03 09:01:23, Info                  CBS    Succesfully flushed NtfsLog.etl
2015-10-03 09:01:23, Info                  CBS    Succesfully added NtfsLog.etl to WER Report
2015-10-03 09:01:23, Error                 CSI    0000000b (F) STATUS_RM_NOT_ACTIVE #153# from Windows::Rtl::SystemImplementation::CSystemIsolationLayer_IRtlSystemIsolationLayerTearoff::OpenRegistryKey(flags = (OpenForBackupIntent), da = (KEY_SET_VALUE), kn = [ml:58{29},l:56{28}]"\Registry\Machine\COMPONENTS", key = NULL, disp = (null))[gle=0xd0190005]
2015-10-03 09:01:23, Info                  CSI    0000000c Warning: Failed to delete pending transaction content. Error code: STATUS_RM_NOT_ACTIVE

2015-10-03 09:01:23, Info                  CBS    NonStart: Success, startup processing not required as expected.
- that repeats at every boot.

Open an Elevated Command Prompt, and run the following commands


Code:
REG LOAD HKLM\COMPONENTS C:\Windows\System32\config\COMPONENTS
REG DELETE HKLM\COMPONENTS /V PendingRequired
*
.
then reboot, and try Windows Update again.
My System SpecsSystem Spec
Reply

 Windows Update restart loop




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 infinite reboot loop on RESTART only
Ok so I have Windows 7 PC and ever since it was purchased, whenever your Restart, it just do an infinite reboot loop. This only happens when RESTARTING and not when SHUTTING DOWN. I need fix on this as my Windows 10 Upgrade is ready and the upgrade just doesn't complete because during the...
General Discussion
Windows Update error, stuck on restart loop.
Greetings Seven Forums crew, I am having an issue with the Windows 7 Update Service. After installing the latest Microsoft Updates (November 2013), I am now stuck in a "restart your computer to finish installing important updates" message. No matter how many times I restart & check for updates,...
Windows Updates & Activation
Windows 7 Ultimate 64 bit restart in loop
Hi, I have a problem with win 7 that restart in loop. First problem become when I not know how but in BIOS changed settings from RAID1 to IDE Controler. Win become to restart, I return settings to RAID1 but have the same problem. I try to make with instalation CD: - system recovery - cmd...
BSOD Help and Support
Windows in a restart loop
I didn't know where to post my problem. It's not exactly a BSOD problem. So, I have this notebook Sony Vaio NW250AF since 2010. It never had any problem before. Four months ago, I installed Ubuntu with wubi (windows ubuntu installer) and everything went well, until couple weeks ago. Suddenly, my...
BSOD Help and Support
Windows restart loop while booting. Safe mode crashes.
Hi, I am here once again as my computer has decided to die again. The problem is that when I boot my PC it will go black and restart after getting to the windows logo boot part. If I try Safe mode it will get to SYSTEM32\DRIVERS\DISK.SYS and then just bluescreens and restarts again. Before...
General Discussion
One initial Install Restart, Windows gets stuck in a restart loop
Hi All, I have read many, many other threads that address infinite reboot loops, but none of the solutions have resolved my issue. I am hoping the community might be able to help me identify this problem. I have just recently replaced my CPU and MB with the items listed below. After...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App