Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows update not working after install

14 Oct 2015   #1
hazel123

Windows 7 64 bit, Windows 7 32 bit and Xubuntu
 
 
Windows update not working after install

I have reinstalled Windows 7 after upgrading to Windows 10 and it not being compatible. Windows update doesn't seem to be working. Have reinstalled 2 or 3 times, from recovery discs and system image and the same problem. I tried one thing recommended somewhere, to update Windows defender. This triggered Windows update to update itself.

I have an installed system with my programs and antivirus on now, but no windows updates (it already has Service pack 1).

So just left it running for a number of hours. I have now had a pop up window saying 'Windows is ready to install some updates, click here' but there are no updates - it is still 'checking for updates'.

Earlier I tried all kinds of fixes - updating Windows update to the latest agent, running Fixit - nothing seemed to make any difference. Anyone got any suggestions please? I'm beginning to wonder if having had Windows 10 activated is somehow stopping me from updating/running Windows 7. Product key is activated and it was a genuine purchase from Microsoft Anytime Upgrade. The Windows update problem has been the same on Windows Starter as well as Home Premium - before I reactivated the Anytime upgrade again.

After the first reinstall I thought I'd try updating Windows starter first, before re-doing the upgrade to Home Premium but couldn't get Windows update working then either so it doesn't seem to make a difference.

I have virus checked hard drive and usb's and sd cards with malwarebytes and all fine, done a disk check and all fine.

32 bit Windows 7 on Atom N2600 processor

Also did Scannow and the other things listed on the Windows Update tutorial. Apologies for not attaching a zip file, not sure how.

Anyway - I gave up for the night, turned it off and it came up saying it was installing 121 updates. Which is ok except I don't know which ones they are! And don't want IE11 installing. Windows Update was still 'checking' before I turned off.


My System SpecsSystem Spec
.
15 Oct 2015   #2
hazel123

Windows 7 64 bit, Windows 7 32 bit and Xubuntu
 
 

Well I am ready to chuck this machine out of the window. Not only did Windows update start installing updates without asking me, as set, and without showing which ones were going to be downloaded, but as expected it bluescreened when it tried to install Internet Explorer 11 - on configuring updates (which is why I never install that on this machine). Went into safe mode and restarted. Then it wouldn't let me change Windows updates settings to 'check for updates but let me decide'.

Just ran fixit again and it has fixed a few things. Internet Explorer is not working at all, unsurprisingly. Does anyone have a link for downloading Internet Explorer 10 - it doesn't seem to be available any more. It currently has non functioning 9 on it.

There are no error messages in Windows update. Fixit said it fixed registration error (did this earlier as well). Have done the CBS Log zip file but not sure how to post it on here - do I just attach it? Probably not - it seems to be over the limit suggested for paint at 13.5mb.
My System SpecsSystem Spec
16 Oct 2015   #3
hazel123

Windows 7 64 bit, Windows 7 32 bit and Xubuntu
 
 

Marked as solved as started new posted with updated info and attachments.
My System SpecsSystem Spec
.

Reply

 Windows update not working after install




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Unable to install Windows Update: Update Kernel-mode driver framework
I am unable to update the Kernel-mode driver framework ver 1.11 for windows 7 for x64-based systems (KB2685811). I get error: 80073712 Also, I am getting BSOD/stop errors in normal mode that say anything from: -memory_management 0x0000000001a, - "A device driver attempting to corrupt the...
Windows Updates & Activation
Windows Update is not working/Update Readiness Tool won't install
Win 7 64 Windows Update not working (post migration), nor is Windows Update Readiness tool installing. I have renamed catroot and stopped services, nothing working. I just migrated HD to a hybrid solid state (Seagate Momentus). I had this problem both with Acronis 2009 and Acronis 2013, and...
Windows Updates & Activation
Can't install updates using windows update or standalone update
I haven't been able to install any updates since jan 11 of this year. I have been on the road for a few weeks and I tried to figure out the problem once I got back. When a update is being installed it will stall we will say at 95%. I have looked in the log files and this is what I find. From...
Windows Updates & Activation
Boot config not working, tried clean install, can't install windows 7
My spouses pc all of a sudden wouldn't boot, not into safe mode or anything (vista), and so we were going to upgrade anyways to windows 7, so i bought the upgrade windows 7 and attempted to do a clean install and reformatted the c: drive which has 250gb, and each time i start the install it bogs...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App