Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows not genuine after sfc /scannow following missing dnsapi.dll

30 Oct 2015   #31
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Good - that is an improvement.

Now open an Elevated Command Prompt, and run the following commands:

NETSH WINSOCK RESET
NETSH WINHTTP RESET

then reboot, and see how things go now.


My System SpecsSystem Spec
.
30 Oct 2015   #32
realtekwin7

 
 

Quote   Quote: Originally Posted by NoelDP View Post
Good - that is an improvement.

Now open an Elevated Command Prompt, and run the following commands:

NETSH WINSOCK RESET
NETSH WINHTTP RESET

then reboot, and see how things go now.
sup noel, can you help me out too? i might have some validation errors too
My System SpecsSystem Spec
30 Oct 2015   #33
jobucks

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Results following resets

1. I ran both commands and restarted the laptop after each command.

2. Improvements
  • I can ping a website
  • I have Blue Stacks to proxy Whats app and it communicated happily over the internet
  • IE and Chrome will open but... see below
3.
  • Skype still cannot download dnsapi.dll
  • Firefox crashes on start up - I did completely uninstall including removing the appdata and reinstall 41.0.2. It sill crashs
  • Opera wont start at all - so I deleted it ( I have 3 other browsers there)
  • IE starts but cannot load Google
  • Chrome starts but says the setting are corrupted and in response to Google - the screen shot attached.
Thanks a lot - things seems to edging forwards and bring a big smile to my face . .


Attached Images
Windows not genuine after sfc /scannow following missing dnsapi.dll-chrome-failure.png 
My System SpecsSystem Spec
.

30 Oct 2015   #34
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I suspect that there are other permissions problems - I'll have to do some research to find out what may be affected, but in the meantime...

Open an Elevated Command Prompt, and run the following commands:

REG QUERY HKLM\SYSTEM\CurrentControlSet\Services\TrustedInstaller /S
ICACLS C:\Windows
ICACLS C:\Windows\System32
ICACLS C:\Windows\System32\config


post the results, and we'll see if that gives me any clues.
My System SpecsSystem Spec
30 Oct 2015   #35
jobucks

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
For Noel ICACLS reports

Here we go - hope you have a good weeekend.



Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>REG QUERY HKLM\SYSTEM\CurrentControlSet\Services|TrustedInst
aller /S
'TrustedInstaller' is not recognized as an internal or external command,
operable program or batch file.

C:\Windows\system32>

==========
C:\Windows\system32>ICACLS C:\\Windows
C:\\Windows BUILTIN\AdministratorsI)(F)
BUILTIN\AdministratorsI)(OI)(CI)(IO)(F)
NT AUTHORITY\SYSTEMI)(F)
NT AUTHORITY\SYSTEMI)(OI)(CI)(IO)(F)
BUILTIN\UsersI)(OI)(CI)(RX)
NT AUTHORITY\Authenticated UsersI)(M)
NT AUTHORITY\Authenticated UsersI)(OI)(CI)(IO)(M)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>
=====
C:\Windows\system32>ICACLS C:\\Windows\System32
C:\\Windows\System32 BUILTIN\AdministratorsI)(F)
BUILTIN\AdministratorsI)(OI)(CI)(IO)(F)
NT AUTHORITY\SYSTEMI)(F)
NT AUTHORITY\SYSTEMI)(OI)(CI)(IO)(F)
BUILTIN\UsersI)(OI)(CI)(RX)
NT AUTHORITY\Authenticated UsersI)(M)
NT AUTHORITY\Authenticated UsersI)(OI)(CI)(IO)(M)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>
-----


C:\Windows\system32>ICACLS C:\\Windows\System32\config
C:\\Windows\System32\config NT SERVICE\TrustedInstallerCI)(F)
NT AUTHORITY\SYSTEMOI)(CI)(F)
BUILTIN\AdministratorsOI)(CI)(F)
CREATOR OWNEROI)(CI)(IO)(F)

Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>
My System SpecsSystem Spec
01 Nov 2015   #36
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Thepermissions on the folders are completely screwed - even if they aren't actually harmful.
The TrustedInstaller entity is missing from both the Windows and System32 folders - which means that Windows Upadtes have no real chance of installing properly, and your system has much-reduced security.

I recommend a repair install.
My System SpecsSystem Spec
02 Nov 2015   #37
jobucks

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Repair install - noted

Thanks Noel - I don't really know what a repair install is but I will do some reading to catch up.
My System SpecsSystem Spec
02 Nov 2015   #38
mikiii880

Windows 7 Ultimate x64 Windows 8.1 x64
 
 
Fix

Hi. Before you do an install repair, reboot your PC and spam F8 on your keyboard.

Some white text on a black background should appearn, giving you these choices :

Repair Your Computer
Safe Mode
Safe Mode with Networking
Safe Mode with Command Prompt
Enable Boot Logging
Enable low-resolution video (640480)
Last Known Good Configuration (advanced)
Directory Services Restore Mode
Debugging Mode
Disable automatic restart on system failure
Disable Driver Signature Enforcement
Start Windows Normally

Click on the bolded one and wait for it to load. Proceed by selecting your language and introducing your password and then click on "Startup repair.". Wait for it to finish and then restart your computer.

This fixed it for me and it might as well do it for you . Best of luck!
My System SpecsSystem Spec
02 Nov 2015   #39
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

jobucks look no farther, here is a tutorial by Brink for instructions on how to do a Repair Install.

Repair Install
My System SpecsSystem Spec
02 Nov 2015   #40
wben353

Win 7 Home Premium x64/Linux Lite 2.6 x64
 
 

You need to have your Windows Product key, (25 character key)
If it's not on a Microsoft tag on your machine, could be inside battery compartment on laptop. It's store in binary code in the registry. You can use attached vb script to find it.
download attachment and run it (double left-click or right click choose> RUN. popup will display code.
If you want to see the code, right-click and choose EDIT
If you don't have windows installation disc, same version as on computer, you can download the ISO from Microsoft Download Center


Attached Files
File Type: vbs Find Windows Product Key VBS.vbs (621 Bytes, 2 views)
My System SpecsSystem Spec
Reply

 Windows not genuine after sfc /scannow following missing dnsapi.dll




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Cannot connect to Malwarebytes DNSAPI.DLL Missing
So my internet connection randomly went out tonight. I reset my modem/router several times, unplugged chords and made sure everything was plugged in. It showed the internet as connected (I wire my connection with a 40ft cable) however I could not access websites; it immediately gave me a screen...
Network & Sharing
Windows Seven, No Longer genuine (Sfc /Scannow probably caused it).
After sucessfully removing a lot of viruses with malwarebytes and manual cleaning. I trying to fix the lsp by running an /SFC Scannow on the cmd; but when it was finished it said it successfully repaired a lode of files. After a reboot, I find that my Avast, internet, lsp are all still busted...
Windows Updates & Activation
tom982 - sfc /scannow unable to repair missing ATL80.dll file
Hello, I read with interest that tom982 has a way of giving special instructions for repairing corrupt or missing files that sfc /scannow is unable to repair. Maybe others can also help me with this, but I only looked at the following thread mentioning tom982 (so far):...
Performance & Maintenance
Sfc /scannow results - missing file (_isdel.exe)
Hey everyone, I received the follwoing message after running sfc /scannow: Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log So I went ahead and opened...
Performance & Maintenance
Windows saying not genuine after bootmgr is missing problem
My computer stopped booting because it said "Bootmgr is missing". So I thought maybe I could use my Vista DVD to do Startup Repair (my Win 7 DVD is missing). It didn't work for the first time - so I did it again... successful! Bootmgr is missing went away and my computer is working again. I...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App