Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No updates after installing Windows 7 SP1

20 Jan 2016   #1
heardy5

Windows 7 64 bit
 
 
No updates after installing Windows 7 SP1

I have several machines that I am restoring for friends but I'm having a problem with windows 7 updates. I can receive and install updates all the way up to and including SP1 but as soon as SP1 is installed no more updates come down. I have left the update check running for several hours with no success. It just keeps running, I don't get any message to say no updates available. I have tried a couple of Microsoft fix it's without any success either. Is this a problem on Microsoft end or could there be something I'm doing wrong. All laptops are genuine with licence codes and Internet is working fine. If anyone has any ideas or experience with this I would be grateful.


My System SpecsSystem Spec
.
20 Jan 2016   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Every sense W-10 give away started Window 7 updates have been very slow. I mean very very slow.
Members have posted from 8 hours up to over 24 hours after a Clean Install or Repair Install. It just keep searching and searching.
If it's still in the Search stage you can reboot and try updates again. If things go well you might get a Microsoft server that isn't so busy.

Have these system been activated?
My System SpecsSystem Spec
20 Jan 2016   #3
heardy5

Windows 7 64 bit
 
 

Thanks that's useful to know. I had a feeling it could be an issue at microsofts end because it's happening on different machines with different set ups. If I leave it long enough do you think they will eventually find updates?
My System SpecsSystem Spec
.

20 Jan 2016   #4
heardy5

Windows 7 64 bit
 
 

Also, it only seems to happen after SP1 is installed
My System SpecsSystem Spec
20 Jan 2016   #5
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Sooner or later you will get them if the system is left on hooked to the internet.

Why are you not installing Windows 7 with SP-1 included in the install media?

I have no idea where one can buy a Microsoft DVD for Windows 7 without SP- included.
My System SpecsSystem Spec
20 Jan 2016   #6
heardy5

Windows 7 64 bit
 
 

I'll keep it running then and see if it is successful. I had an old DVD without SP1 on it, can't remember where it is even from. Only used it to see if my SP1 DVD was causing the problem. Can anyone explain why this happens only after SP1 is installed. As I said, updates come down no problem before that?
My System SpecsSystem Spec
20 Jan 2016   #7
UsernameIssues

W7 Pro SP1 64bit
 
 

Manually download and install KB3112343. That should drastically shorten the time that it takes to get a list of updates.
My System SpecsSystem Spec
20 Jan 2016   #8
legacy7955

win 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by heardy5 View Post
Also, it only seems to happen after SP1 is installed
I noticed this as well, you are definitely not the only one experiencing this symptom.
ALL update PRIOR to installing SP1 work as normal as soon as you update to SP1 and the
new update client package (!!!!I think this is the culprit???) getting updates takes forever or you don't get them at all.

I posted in a different that strangely I noticed on several occasions that while attempting to download updates post SP1 and client update, that it appears that MS servers shut off during some of the updates, it's almost like they are refusing updates...can't be but it seems like it.
My System SpecsSystem Spec
27 Jan 2016   #9
heardy5

Windows 7 64 bit
 
 

Finally got Windows to find updates by leaving it running for at least 24 hours and they eventually came down. Turned off sleep too. Just wanted to add that for anyone else who may experience this problem. Just got to be patient. Now updates are working fine.
My System SpecsSystem Spec
27 Jan 2016   #10
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Yep patient is necessary. Just like my post #2 stated.
We had one poor member that it took 48 hours.
My System SpecsSystem Spec
Reply

 No updates after installing Windows 7 SP1




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 not installing updates
I am having issues with installing updates on Windows 7 x64. The start menu always has "Shut down and install updates", I click to install and sometimes the system says installing and then just hangs and sometimes it says it has installed the 2 updates. However when I turn the machine back on the...
Windows Updates & Activation
Installing Windows Updates
I like doing my updates in groups, what I don't like, is after every group update I have to restart the machine. Is there a way or setting to pause the restart until I'm finished, and I decide I want to restart? What about the balloon pop-up at the taskbar, is there a way to stop it from...
Windows Updates & Activation
Windows Updates Not Installing : Error Unknown (Sits on Installing)
Hi, To give you some back story, I built my computer the end of August 2012. Ran Smoothly. I decided to get a 60 gig SSD to be the partition that stored Windows. I didnt have much stored on the Main HD so I deleted my original 2TB HD and tried installing on the SSD... found that the SSD was bad...
Windows Updates & Activation
Windows 7 Updates keeps installing same 8 updates over and over
I did search out this problem...very old posts recommended I start a new thread. For the last 2 weeks every time I shut down automatic install...installs the same 8 updates. I'd appreciate any help in solving this problem. Thanks, Toni
Windows Updates & Activation
Installing Updates and Installing features part of windows setup menu
How do I installing something during the Windows Setup Menu's Installing features and Installing updates? John:D:thumbsup::what:
Installation & Setup
windows updates not installing
Just installed windows 7 and went to windows updates, windows automatically detected my roccat kone mouse and razor keyboard. So downloaded the drivers and some other drivers, all were succesful but when I go to installed updates, say to remove one there are none there. On top of this I...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App