Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WU Always Fails, reverts back

19 Feb 2016   #11
Brento

Windows 7 Professional (32 bit)
 
 

Quote   Quote: Originally Posted by torchwood View Post
Only picked up on it because its showing as not fixed in your screenshot.
Have you installed KB971033 yet.

Roy
I have now. If it was a non-genuine copy, it should have disabled it correct? Since that has not happened, I think I can safely assume my copy is genuine, and that some sequence of events may be related to the problem. You may want to review my comments in this thread, perhaps it is related to one of these things?


My System SpecsSystem Spec
.
19 Feb 2016   #12
Brento

Windows 7 Professional (32 bit)
 
 

After reading this article, I am suspecting my theory that Microsoft has deliberately broken these updates, to make people buy Window 10, is at least partially true:

Microsoft ends support for .Net Framework 4, 4.5 and 4.5.1 - gHacks Tech News

I would say that the problem began shortly after this article was posted. I never updated my .NET to 4.5+.

I have now run NetFxRepairTool.exe, followed by installing 4.6.1 framework on my PC. This will take awhile, so if anyone else has guesses, please give it a shot! Thanks.
My System SpecsSystem Spec
20 Feb 2016   #13
Brento

Windows 7 Professional (32 bit)
 
 

Ok I finally solved this.

As a software engineer, I'm going to state that there is a bug in Microsoft's WU can easily be fix. Very disappointing to see such complacency here.

The incidental culprit appears to have been Visual Studio 2010's shoddy install/uninstall process. While there's nothing Microsoft can do about issues in released software in the field, there's things that can be done to save thousands of man-hours TODAY.

The root problem was a corrupt and lack of .NET configured on my system (caused by the aforemention VS2010). Simply by running the NetFxRepairTool.exe (this repairs built-in .NET libraries too, then installing the comprehensive .NET 4.6.1 library, every update, and Visual Studio 2015 installed successfully.

Now, if I had uninstalled a non-Microsoft product, and it caused the .NET corruption, then Microsoft can claim no liability. But, this is their OWN product. There were legitimate reasons I cleaned up all its associated packages, and it was based on suggestions found in other forums. Besides, regardless of how it got in this state, defense programming could easily have avoided this problem.

The solution, for Microsoft's devs to implement in an emergency fix:

DETECT THE PRESENCE OF .NET MORE ROBUSTLY.

Your Knowledge Base files clearly depend on this being stable. So, in Windows Update (or even when the OS boots), before even scanning for updates, do an integrity check!

I basically found some code on the net that simply looks at the registry settings, to determine .NET compliance, and the utter stupidity of that approach was confounding. DO MORE! Check that the physical files (where does the registry expect them?), and GAC configuration are correct before blindly installing updates and barfing all over the place. Heck, do a checksum and file size check too, while you're at it. This is just stuff off the top of my head.

My guess is Windows Update is done in C++ and relies on core assemblies, so it might be a bit slower to code, but this shouldn't take more than a couple of days. If you try to do this validation using .NET.. well, then I suggest you take a course in basic logic first.

Anyways, until this fix is provided, here's the 2 magic programs I ran:

1. NetFxRepairTool.exe https://support.microsoft.com/en-us/kb/2698555
2. Comprehensive .NET (all versions to date) https://support.microsoft.com/en-us/kb/3102436

This probably applies to anyone who had to uninstall packages from their Programs and Features to remove any large application at some point.

I did have to wait several hours before updates were found, but my god was I surprised that they all succeeded when they did. Even KB3033929 worked, after 12 failures!
My System SpecsSystem Spec
.

21 Feb 2016   #14
wben353

Win 7 Home Premium x64/Linux Lite 2.6 x64
 
 

Awesome, glad to hear your problem is resolved, & that you posted your fix.
Happy Computing!!!
My System SpecsSystem Spec
Reply

 WU Always Fails, reverts back




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows reverts back to default setting
It seems that Windows has a mind of its own. There are two things I change on Windows but in a few days it goes back to the default settings. I do not like any system sound on my computer. It annoys me whenever I click on something I get the "beep". So I go into settings and change it to "NO...
Customization
Theme reverts back on it's own!
Ok this one is driving me nuts. In my themes window under 'my themes' I have my own theme that I use most of the time and somehow a split image of that theme titled 'unsaved theme' but with the screensaver turned OFF. I am not sure how this one got there but no matter how many times I switch...
Themes and Styles
Pagefile reverts back
Im trying to get the best virtual ram usage for my video editing system (WIN7 32BIT 4gB RAM) so I've taken the advice of some and switched the virtual ram over to another drive from that of C (boot) drive. The system recommends 5361mb and 3574mb is currently allocated. I've reset these values twice...
Performance & Maintenance
Windows Updates Fails configuring updates and reverts back
EDIT: Please see my updated information a few posts down. Hello, I'm having issues on a Windows 7 64 bit system. If the updates install, then upon restart it fails configuration and reverts back. Otherwise the the updates will fail and I get the following when using the windows fix it for...
Windows Updates & Activation
External monitor resolution reverts back to 800 x 600
How do I stop the screen resolution from reverting back to 800 x 600 when switching to external monitor? Intel(R) Graphics Media Accelerator Driver for Mobile thinks the optimal resolution is 800 x 600 when it's actually 1024 x 768. How do I make it see 1024 x 768 as the optimal resolution and make...
Graphic Cards
W7 Reverts back to Cloned display mode
Hey all, I dont know how to describe this too well, so bare with me. Everytime a windows popup takes over my screen (like the UAC takeover, or the CTRL+ALT+DEL screen) my displays always revert to Cloned mode after the popup is finished. I've tried the registry edit with changing the TMM...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App