Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Service Pack 1 failing to configure around ~9-11%

28 Feb 2016   #1
Zarkith

Windows 7 Professional x64
 
 
Service Pack 1 failing to configure around ~9-11%

If you've stumbled across this thread by searching for this issue on Google or w/e, what solved it for me was uninstalling the multiple C++ Redistributables that were installed on my system, plus re-installing a problematic usb driver via this article: How To Fix ERROR_NOT_FOUND 0x80070490 During Windows 7 SP1 Installation
Not guaranteed to work for you, but definitely check out that article at least. I certainly wish I had known about it sooner.


This issue has plagued me on and off for years, but it wasn't until recently that I decided to finally get to the root of things and fix the issue once and for all. (Thanks in no small part to Star Citizen and XCOM 2 failing to launch without it)

Normally I try to avoid posting new threads/questions on sites like these when 95% of the time someone else already did and got answered, but that doesn't really cut it in this situation unfortunately. After running the SURT, all errors it found were fixed with the exception of 4 missing .dll's from the a folder under winsxs. From what I've read, I need to get them from a computer running the exact same version of Windows.

No error codes anywhere after restarting or in Windows Update. All other updates are successfully installed.

<Problem has been solved, so I removed the attached logs>


My System SpecsSystem Spec
.
28 Feb 2016   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 
out of date

Hi Zarkith,
For a start can you d/l and run
http://support.microsoft.com/kb/2749655, (for W7 x64)

REBOOT

this may clear your netframework problem as well.
If not d/l and run the MS repair tool
Download Microsoft .NET Framework Repair Tool from Official Microsoft Download Center

Uninstall ALL of your of MSvisual c++ programs, then when you run your games next time it will tell you which you require.

We'll go on from here depending on what your results are

Roy
My System SpecsSystem Spec
28 Feb 2016   #3
Zarkith

Windows 7 Professional x64
 
 

I wasn't aware I had a .NET framework problem, but that first update you linked seems to have cleared up those expired catalog errors in CheckSUR.log

Still missing those 4 .dll's, and SP1 still failed at the same %, but I'd call that progress at the very least.


Could you clarify what you mean by MSvisual c++ programs though?
My System SpecsSystem Spec
.

29 Feb 2016   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Zarkith,
C++
There just programms.
Go Control panel >> programs/features and remove any that are there they will end with a year.

Once we get rid of the errors SP1 should d/l and run, have a read of this first and see if you have the KB's installed.

Roy
My System SpecsSystem Spec
29 Feb 2016   #5
Zarkith

Windows 7 Professional x64
 
 

Ah, you meant the redistributables. Gotcha!

I hadn't anticipated that they would've been related to this, but looking at the programs list I can see why they might be.
Uninstalled all of 'em. I'll run sfc /scannow again and upload the logs if SP1 fails.

"[...] have a read of this first and see if you have the KB's installed"
Have a read of what?
My System SpecsSystem Spec
29 Feb 2016   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 
oops

My System SpecsSystem Spec
29 Feb 2016   #7
Zarkith

Windows 7 Professional x64
 
 

According to Windows Update history, I'm missing the first two, but KB2533552 is installed.

However, when I try installing them, it says they're already installed.
My System SpecsSystem Spec
01 Mar 2016   #8
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Zarkith,

Can you do the following in the order listed please,

download kb971033

From an elevated command mode
run sfc /scannow, could take a while.

Reboot

please run the tool from here and post the results

Windows Genuine and Activation Issue Posting Instructions


did sp1 install?

roy
My System SpecsSystem Spec
01 Mar 2016   #9
Zarkith

Windows 7 Professional x64
 
 

Tried installing KB971033, says it's already installed.

SFC is saying the same thing it has been each time: "Windows Resource Protection found corrupt files but was unable to fix some of them."
Which I can only assume are the four mfc90.dlls that have been missing since the start.

Rebooted and ran MGADiag, here's the results:
Code:
Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-7QJXJ-7XJD2-32WPH
Windows Product Key Hash: Fo8w2uq03vwHo1kVTh8gej1PlIs=
Windows Product ID: 00371-841-2711926-85637
Windows Product ID Type: 5
Windows License Type: Retail
Windows OS version: 6.1.7600.2.00010100.0.0.048
ID: {611CE116-56BF-4A5B-BBE3-9B4AA6432504}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered, 1.9.42.0
Signed By: Microsoft
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7600.win7_gdr.150318-1623
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Users\Zarkith\AppData\Local\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{611CE116-56BF-4A5B-BBE3-9B4AA6432504}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010100.0.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-32WPH</PKey><PID>00371-841-2711926-85637</PID><PIDType>5</PIDType><SID>S-1-5-21-1734206012-1139644240-2510634663</SID><SYSTEM><Manufacturer>Gigabyte Technology Co., Ltd.</Manufacturer><Model>Z97X-UD5H-BK</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>F6</Version><SMBIOSVersion major="2" minor="7"/><Date>20140617000000.000000+000</Date></BIOS><HWID>06BA3607018400F4</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7600.16385

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, RETAIL channel
Activation ID: e838d943-63ed-4a0b-9fb1-47152908acc9
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00170-841-271192-00-1033-7600.0000-3282009
Installation ID: 000872949294374755478315394832363063960690822850480721
Processor Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88338
Machine Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88339
Use License URL: http://go.microsoft.com/fwlink/?LinkID=88341
Product Key Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88340
Partial Product Key: 32WPH
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 3/1/2016 11:37:52 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: PAAAAAIAAgABAAIAAgAEAAAAAgABAAEAHKIUgfyMlZtG1JwtYjXE3vD4je/Cl5R62KWYkBEuFJ4sFsj2

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information: 
  ACPI Table Name	OEMID Value	OEMTableID Value
  APIC			ALASKA		A M I
  FACP			ALASKA		A M I
  HPET			ALASKA		A M I
  MCFG			ALASKA		A M I
  FPDT			ALASKA		A M I
  SSDT			Ther_R		Ther_Rvp
  SSDT			Ther_R		Ther_Rvp
  SSDT			Ther_R		Ther_Rvp
  SSDT			Ther_R		Ther_Rvp
  SSDT			Ther_R		Ther_Rvp
  DMAR			INTEL 		BDW
Tried installing SP1 again, well this is different. Now it's failing in Windows Update with an 800F0A12 error code.
My System SpecsSystem Spec
01 Mar 2016   #10
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 
try this

Hi Zarkith,
things are changing, hopefully for the better.
Even thou that KB is installed the rerun has changed the status of a WAT error as well, 0xc004f012.

Please go to www.microsoft.com/genuine/validate and attempt validation - what happens?
(you will need your full code)

reboot rerun mgadiag the errors on lines 1,4,6 should change

Roy.

Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
My System SpecsSystem Spec
Reply

 Service Pack 1 failing to configure around ~9-11%




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Service Pack 1 fails to configure/install
1. System Update Readiness tool runs to completion. 2. SFC scan detects errors but cannot fix them. 3. The SP1 update (KB976932) has failed (and succeeded once) with several error codes: 1/16/2013 - Code 8024000B - Installation status: Cancelled 9/7/2013 - Installation...
Windows Updates & Activation
Factory Windows 7 Service pack 1 but service pack shows in updates?
Just bought new never used factory fresh PC Acer AXC-605-UR29 Windows 7 Service Pack 1 manufacrtured this year, I checked for latest updates and sure enough Service Pack 1 shows up in updates Windows 7 Service Pack 1 for x64-based Systems (KB976932) Download size: 9.1 MB
Windows Updates & Activation
Service Pack 2?
Does anybody else know if Windows 7 will release a Service Pack 2, or will they continue to have patch Tuesday as a substitute
Windows Updates & Activation
FAILURE TO CONFIGURE WINDOWS 7 SERVICE PACK 1 x-64: Error 0x80070490
This has been an ongoing issue since my first attempt to configure it on 24 June 2011: It always reboots @ 10% during the configuration; restarts @ 7% configuring, then fails completely @ 10%. Error: ERROR_NOT_FOUND(0x80070490) STEP 1: Before attempting any fixes, this was the result after...
Windows Updates & Activation
failure to configure service pack 1
im always trying to install the sevice pack 1 but failure to configure whats the problem?
Windows Updates & Activation
Service pack 1
Hi I installed sp1 for windows 7 pro 32 bit, now everytime windows start I get this popup (service pack 1 is now installed). Cannot find it in msconfig or startup. Any help would be appreciated. Thank You
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App