Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 64 bit : Updates no longer download properly (Svchost.exe)

10 Mar 2016   #1
Question2

win 7 64 bit
 
 
Win 7 64 bit : Updates no longer download properly (Svchost.exe)

Ive noticed that svchost.exe (the process) keeps hanging at 13% CPU usage lately. I restarted now and windows update is correctly giving me a list of updates to install, but they are not downloading properly. It just says downloading 108 updates (0KB total, 0% completed) and just gets stuck there forever, even though i have a valid internet connection (which i am using to make this thread).

Right now svchost.exe is just stuck at 13% cpu usage again and memory usage is stuck at 216,880kb.

Any ideas?


My System SpecsSystem Spec
.
13 Mar 2016   #2
Question2

win 7 64 bit
 
 

I tried running the system update readiness tool. It said it wanted to install a hotfix, and then it hanged when installing the hotfix : Installing Hotfix for Windows (KB947821) (update 1 of 1)...

Running sfc /scannow just gave me errors in the CBS log which is included in the rar file : https://www.**************/?wefbvgtamfvkvu1

No error codes that i can see, it just hangs.

Edit : Well the forum wont allow me to paste the mediafire download link and when i try to upload the .rar here, it just gives me a 404 error...any ideas? You can just replace the * with mediafire . com and it should work...
My System SpecsSystem Spec
14 Mar 2016   #3
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Follow the instructions in the sticky, it will tell you how to post the CBS log.
108 is alot of updates what was the last successfull update and when.

Roy
My System SpecsSystem Spec
.

14 Mar 2016   #4
Question2

win 7 64 bit
 
 

The CBS log is included in the RAR file.

I dont remember what the last update was...probably a few months ago atleast?
My System SpecsSystem Spec
14 Mar 2016   #5
luciomoreira

Windows 7 Home Premium 64bit
 
 

I used AutoPatcher to perform the first update of the system, then Windows Update worked. I installed all critical updates and restarted the computer, then I installed all recommended updates and restarted again. After that WU is normal.
My System SpecsSystem Spec
15 Mar 2016   #6
Question2

win 7 64 bit
 
 

Unfortunately that didnt work for me.

Edit : Okay the system update readiness tool finished installing the hotfix. Restarted, tried to run windows update again, gets stuck at 13% cpu usage and just hangs while "getting setup files"....
My System SpecsSystem Spec
18 Mar 2016   #7
Question2

win 7 64 bit
 
 

Sigh i guess this forum is dead.

Anywqay i eventually managed to get the system update readiness tool to install the hotfix, and then i was able to download and install updates (although it took a very long time and i couldnt see any progress).
My System SpecsSystem Spec
Reply

 Win 7 64 bit : Updates no longer download properly (Svchost.exe)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Update no longer functioning properly
It fails to install updates and claims that updates have never been installed. When I search for updates, I receive 80080005. I attempted to install the latest SURT, twice, but it failed both times. I was considering going onto SFC scan step, but since SURT failed, I thought I should ask first.
Windows Updates & Activation
PC can no longer connect properly to the internet?
My GF told me her computer's firefox wasn't working, so I looked at it and found that Internet Explorer and a few other internet programs also weren't working. It doesn't return any sort of server not found error on the browsers, if I click a link it just seems to do absolutely nothing, it doesn't...
Network & Sharing
Win7 x64 will no longer boot properly after innstalling SP1
Hi my 3 day old Win7 Ultimate innstallation on my 3 day old computer just crashed after trying(or maybe succeding) to innstall Service Pack 1. This is how the screen looks when I try booting. http://s11.postimage.org/eoi2b1vbn/IMAG0029.jpg I have tried all safety moodes, last known good...
Windows Updates & Activation
Windows no longer show my themes properly
I recently reinstalled windows 7 Ultimate 64bit and everything was going just fine untill today that i turned on the pc and saw that my theme didn't look right so i applied another theme and the same thing. here is a screenshot to better show what im saying: ImageShack® - Online Photo and Video...
Themes and Styles
Desktop no longer will go to sleep properly..
i iddnt see the proper forum for this..mods are welcomed to move it..but for some reason my pc wont sleep properly...the monitors shut off the keyboard shut off but the pc itself still runs..i turned it off and turned it on my bios said press f2 to load defaults fro some reason..so i did..and then...
Performance & Maintenance
WMC no longer properly playing movies from library
So I've copied a few of my Blu-Rays to my computer for ease of viewing, and when I originally did that, the movies would play fine when I opened WMC and clicked "Movie Library", then clicked the movie I wanted to play. Now, for some reason, when I hit "Play Now" it goes to a screen that...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App