Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: wuauserv uses over 2GB of RAM, how to solve it?

10 May 2016   #11
noersetiawan

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
This is a little cleaner description
Make sure and go to Uninstall a program and see which Microsoft Net framework you have installed,
4.5.2 is the most consistent to have installed,
https://www.microsoft.com/en-us/down....aspx?id=42642

Switch your windows update setting to Never check for updates temporarily
Restart the machine
You can try and install the newest update client manually leave your update settings at Never check for updates until you install this,
https://support.microsoft.com/en-us/kb/3138612

Then download this to your downloads folder to run it from there,
https://technet.microsoft.com/librar...or=-2147217396

Download the x86 for 32 bit system or x64 for a 64 bit system

Install it and restart when prompted too after it does a stand alone search for updates which shouldn't take too long it took all of 5 seconds "If" the windows update settings are switched to Never check for updates before running it from the downloads folder.

Once it installs and restarts
You can reset your updates setting to whatever you had prior = Default....
Then manually check for updates.
Yes, I did all that precisely by the step you mentioned, but still checking for update never gets finished. Currently I'm trying wsusoffline, hope this works, if it fails too, there are only two option left for me.


My System SpecsSystem Spec
.
10 May 2016   #12
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
See if you can install this,
https://support.microsoft.com/en-us/kb/971033

Just so your update settings is set to never check for updates the stand alone installer should not conflict with the update client already installed.

Check to see if this one is installed
https://support.microsoft.com/en-us/kb/3112343

Use winkey+R
Type in the Run box,
eventvwr
Windows logs on the left column and expanded them and right click and click on clear on the 4 entries below,
Applications
Security
Setup
System
Exit and restart the machine again

Uninstall this update if it ever installed,
Download it again and use Save as and download it to your downloads folder and run it from there without an internet connection
https://support.microsoft.com/en-us/kb/3138612
My System SpecsSystem Spec
10 May 2016   #13
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

The CBS log is showing an error on a IE language pack update.
Did the comp originally come with Indonesian as the base language?, and is the re-install media for the same language.
How many language packs installed?


Roy
My System SpecsSystem Spec
.

11 May 2016   #14
noersetiawan

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
See if you can install this,
https://support.microsoft.com/en-us/kb/971033

Just so your update settings is set to never check for updates the stand alone installer should not conflict with the update client already installed.

Check to see if this one is installed
https://support.microsoft.com/en-us/kb/3112343

Use winkey+R
Type in the Run box,
eventvwr
Windows logs on the left column and expanded them and right click and click on clear on the 4 entries below,
Applications
Security
Setup
System
Exit and restart the machine again

Uninstall this update if it ever installed,
Download it again and use Save as and download it to your downloads folder and run it from there without an internet connection
https://support.microsoft.com/en-us/kb/3138612
Hi,
I can install 971033 successfully, and I don't have 3112343 installed, should I install it? Well I installed it anyway and nothing happened, wuauserv still stuck so I restored using system restore. As for 3138612 I already installed it without internet connection, I think it's the one that solved over 2GB of RAM usage problem (after it was installed RAM usage never exceed 500MB), but the excessive CPU usage isn't solved.

Quote   Quote: Originally Posted by torchwood View Post
The CBS log is showing an error on a IE language pack update.
Did the comp originally come with Indonesian as the base language?, and is the re-install media for the same language.
How many language packs installed?


Roy
Hello,
Ah that's a good information. No, the PC comes with english language, I installed the language pack from here, actually that is the very first thing I did after installation, even before installing driver etc. I only installed Indonesian, is there a connection between LIP and WU to cause trouble?
My System SpecsSystem Spec
11 May 2016   #15
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi Oops
Each new update client replaces a previous one
KB3112343 was released in December 2015
Since then there has been at least 2 others that I can remember
KB3138613 was March's
KB3135445 was February's
Not sure if January had one or not ?
My System SpecsSystem Spec
11 May 2016   #16
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

There are routines within windows update that require the original core language pack to be in place when you update for the "first" time, the language pack install, (as its optional) in this first update run will be one of the final updates of the process if your first update action was to remove the core language, you will encounter problems

Roy
My System SpecsSystem Spec
11 May 2016   #17
noersetiawan

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi Oops
Each new update client replaces a previous one
KB3112343 was released in December 2015
Since then there has been at least 2 others that I can remember
KB3138613 was March's
KB3135445 was February's
Not sure if January had one or not ?
I see.. I have installed all from october 2015-april 2016 fix manually, but CPU problem isn't solved either. Roy's answer below might have some hope, gonna try that.

Quote   Quote: Originally Posted by torchwood View Post
There are routines within windows update that require the original core language pack to be in place when you update for the "first" time, the language pack install, (as its optional) in this first update run will be one of the final updates of the process if your first update action was to remove the core language, you will encounter problems

Roy
I didn't remove the core language, only installed a new one, it's not possible to remove english anyway. So do you suggest I do a reinstall and finished windows update without any language pack? I read somewhere that some update requires reinstall after language pack and it is suggested to install language pack first, that's why I installed LIP at the very beginning, not from windows update but from an mlc file.
My System SpecsSystem Spec
11 May 2016   #18
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by noersetiawan View Post
~~~
Quote   Quote: Originally Posted by torchwood View Post
What language packs are you running please.

Roy
It's Indonesian, does language pack has something to do with Windows Update?
I've seen this note on the updates to the Windows Update Clients (WUC):
Quote:
Important If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update.

Quote   Quote: Originally Posted by ThrashZone View Post
Hi Oops
Each new update client replaces a previous one
KB3112343 was released in December 2015
Since then there has been at least 2 others that I can remember
KB3138613 was March's
KB3135445 was February's
Not sure if January had one or not ?
Correct - no update to the WUC in January.
The March update is KB3138612
(https://support.microsoft.com/en-us/kb/3138612)


:::goes back to lurking:::
My System SpecsSystem Spec
11 May 2016   #19
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Ha thanks for the typo correction UNI

Yea the "If you add a language pack after installing this update" is a common note on many updates that it need to be reinstalled.
My System SpecsSystem Spec
11 May 2016   #20
noersetiawan

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Quote   Quote: Originally Posted by noersetiawan View Post
~~~
Quote   Quote: Originally Posted by torchwood View Post
What language packs are you running please.

Roy
It's Indonesian, does language pack has something to do with Windows Update?
I've seen this note on the updates to the Windows Update Clients (WUC):
Quote:
Important If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update.
Exactly! That's why I installed LIP first before anything else (and to not see the default language anymore of course), but it apparently suspected of making Windows Update broken? Will try reinstall without LIP installed.
My System SpecsSystem Spec
Reply

 wuauserv uses over 2GB of RAM, how to solve it?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BITS, WUAUSERV, WINDEFEND not working, missing from the Services List
Hi, I've a windows 7 Home Basic 64-bit Service Pack 1 in my PC. I noticed one day that I haven't been getting Windows Updates since a long time. After doing all research, I've found that the BITS, wuauserv and windefend services are not working. They're not even listed in the Services list....
Windows Updates & Activation
wuauserv cpu and memory high no error
Hello sevenforums I have an update issue I can not resolve. I have always manually updated. 12/12/15 I did a partial update and when I went to do the remaining update I got a high cpu and memory during checking for updates. No error just keeps searching. Not trying to upgrade to WX. I did all...
Windows Updates & Activation
Problem with wuauserv
Hello Forum While investigating why my PC is slow, I opened Task Manager and saw CPU 100 % and memory about 80 %, it was the " wuauserv" service, so I stopped it (I know this prevents updating windows) and CPU went down to normal up to 26 % and programs loaded and acted faster. After a while,...
Performance & Maintenance
wuauserv causing svchost memory usage to explode
To be honest, I started out investigating the wrong thing. This all started because I would have errors in Chrome. The Aww, Snap or It's Dead Jim errors, etc. Or Chrome would just crash and I would relaunch and restore. I did normal Chrome things like check the shockwave and flash files, disable...
General Discussion
wuauserv service using CPU without updating
UPDATE: One of the links I put in my document to your site gave me this link for some reason. http://www.sevenforums.com/windows-updates-activation/264840-windows-update-posting-instructions.html I guess it's because I'm logged in here now. I shall follow it for now to see if it has some super...
Windows Updates & Activation
Wuauserv and BITS missing - re-install without OS reboot?
Hey everyone! So.. I've got a machine on one of my networks that was victim to a nasty virus a few months back. I cleaned it and verified that it was healthy again and sent it on it's way. Yesterday, our IP was blacklisted for spam suddenly. After checking the logs from the mail service and...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App