Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: windows 7 SP1 installed!!


19 Jul 2010   #1

Windows 7 Ultimate SP1 x64
 
 
windows 7 SP1 installed!!

here is the proof:
Name:  sp1.PNG
Views: 30
Size:  63.3 KB
Attachment 86321
Name:  bottom.PNG
Views: 514
Size:  8.7 KB
Name:  paint.PNG
Views: 39
Size:  47.2 KB

note:
I recomend downloading the iso, the windows update method did not work
It will ask you to uninstall uncompatible language pack, for example: Romanian
It will take about 45 minutes to 1 hour to uninstall.

If you found this helpfull in any way please add to my rep.




My System SpecsSystem Spec
.

19 Jul 2010   #2

Windows 7 Ultimate X64 SP1
 
 

thats the Sp1 Beta I think you'll find... there is a big thread about it here:Windows 7 SP1 Public Beta Released
My System SpecsSystem Spec
20 Jul 2010   #3

Windows 7 Ultimate (Build 7600)
 
 

i got it yesterday too but it took 3 hours using windows update
My System SpecsSystem Spec
.


Reply

 windows 7 SP1 installed!!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:13 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33