Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: windows 7 SP1 installed!!

19 Jul 2010   #1
ionbasa

Windows 7 Ultimate SP1 x64
 
 
windows 7 SP1 installed!!

here is the proof:
Name:  sp1.PNG
Views: 30
Size:  63.3 KB
Attachment 86321
Name:  bottom.PNG
Views: 514
Size:  8.7 KB
Name:  paint.PNG
Views: 39
Size:  47.2 KB

note:
I recomend downloading the iso, the windows update method did not work
It will ask you to uninstall uncompatible language pack, for example: Romanian
It will take about 45 minutes to 1 hour to uninstall.

If you found this helpfull in any way please add to my rep.




My System SpecsSystem Spec
19 Jul 2010   #2
severedsolo

Windows 7 Ultimate X64 SP1
 
 

thats the Sp1 Beta I think you'll find... there is a big thread about it here:Windows 7 SP1 Public Beta Released
My System SpecsSystem Spec
20 Jul 2010   #3
The Master

Windows 7 Ultimate (Build 7600)
 
 

i got it yesterday too but it took 3 hours using windows update
My System SpecsSystem Spec
Reply

 windows 7 SP1 installed!!




Thread Tools





Similar help and support threads
Thread Forum
Win 7 SP1 Installed, Previously Installed Updates Reappear
I recently installed Windows 7 Service Pack 1 for my Windows 7 Home Premium 32-bit edition. As the installation finished the computer restarted and I did not give it another thought. Later on I returned to the Windows Update screen to see if there were any recent updates available for my PC. To my...
Windows Updates & Activation
installed HD 2600 pro card, installed AMS driver, but no ccc software?
I was wondering if this would help? http://www.sevenforums.com/graphic-cards/195195-fix-catalyst-control-center-ccc-will-not-open-install.html I see no evidence that the AMD driver installed at all. Right click desktop does not show ccc, and ccc is not in the lower right panel. Windows...
Graphic Cards
9gb Ram installed. 7 Gb shown as installed, 6.1gb available. Windows 8
Hello, Haven't needed help from you guys in a while. I'm even using windows 8 now. Your advice was so good the last time.. I'm back. Ok so I have a brand new kingston 4gb ram chip installed on my ecs p-45-t black series board. It replaced a 1gb chip. My other chips all say 1.8v this new one...
Performance & Maintenance
List of updates required to be installed before SP1 is installed?
Hello, Is there a list of hotfixes that are required to be installed prior to installing SP1? I am trying to slipstream SP1 into an installation DVD for Windows 7. It works fine, however, after I installed my newly created DVD, I found an update that said "You must install this patch before...
Windows Updates & Activation
How do I get my newly installed Hard Drive (1TB) with Win 7 installed
to boot up. Here's my issue I have a HP Desk top w/ a standard 320 GB hard Drive. I bought a new Hard drive (1 TB Western Digital) so that I could move everything to the new one and use the old one as storage. I had trouble even formatting the new drive but eventually got it and successfully...
Backup and Restore
neo basic 2165 - 4gb installed but only shows 3gb installed
hey guys got an issue her thats been like a stubbed toe - just cant let go of it - im using a dual core neo basic 2165 - i just recently upgraded my ram to 4gb 2x - 2gb -ddr2 800 but it just shows 2.75 usable - and only 3gb installed - ive tried every thing so far- still same result-...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App