Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Service Pack 1 won't install

25 Feb 2011   #11

Windows 7 Home Premium
I Downloaded this Fix From Microsoft - It Worked

My 1st try to install SP1 failed as well. I followed the link on the update page to the Microsoft site and they offered this as a solution. It worked perfectly for me.

System Update Readiness Tool for Windows 7 (KB947821) [February 2011]

You may need to install this first to successfully install SP1

Download Confirmation


My System SpecsSystem Spec

25 Feb 2011   #12

Windows 7 Home Premium X64

Did the repair install and then immediately installed Service Pack 1 and it all worked fine. Seems that .net was causing the problem because the repair install balked on it for a few minutes and gave me a warning not to restart the computer until the install was done. When the warning screen went away, it rebooted and all is well now. Thanks to all who offered help.
My System SpecsSystem Spec
25 Feb 2011   #13
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

Good to see you got it running and thanks for the update.
My System SpecsSystem Spec

27 Mar 2011   #14

Windows 7 Pro
Here's what fixed it for me

For those who have Kaspersky Internet Security installed, I had to UNINSTALL it in order to successully install the SP1. (NOT just disable it.) I had tried just about everything else by the way.

Good luck.
My System SpecsSystem Spec
13 Apr 2011   #15

Windows 7 Ultimate x64
Win7 SP1 Issue

Lastnight I started installing SP1 on my Win7 Ultimate x64 Machine with Windows Update and the download on it would slow down and sit at like 19% for a couple hours so i would cancle it but it would still download in the background cuz of the way I have my updates set up... once it finished I would try and install it but it would end up failing... so I did some research and downloaded the Service Readyness Tool and tried installing it multiple times and each time it would freeze at a certian percentage and sit there for a while... i decided b4 going to bed to just let it go maybe it would finish eventually that was at 2am est... i woke up at 5am and saw it had so i quickly downloaded SP1 standalone install from and started it... come 7am it had rebooted and started the "configuring your service pack" phase and come 11am it was still sitting at 10% now at 12pm it moved up to 14% and waited for a bit but then finally kicked me back to windows and gave me a error code 0x800705b4 meaning it timed out I havn't the feightest as to "why" it was having such problems...
My System SpecsSystem Spec
13 Apr 2011   #16
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Welcome kithin ... follow this article to make a 'clean' boot, then try installing SP1 again. You may have a 3rd party program that is affecting the installation.
How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
My System SpecsSystem Spec
14 Apr 2011   #17

Windows 7 Ultimate x64
RE: Win7 SP1 Issue

I tried again last night to install SP1 on my Win7 machine even did as suggested by "clean booting"... but I had some non constants happen between last night and the night before last... the night before last the SP did try and install and configure w/o issue except the 5hours it took on the configuring screen b4 it canceled it self and gave me the time out error code... last night the standalone SP installer did not want to install because of the lack of sufficient space on my primary hard drive... it demanded 8 gigs of free space (sadly I am running a 36gig WD Raptor hard drive and Win7 takes up 20.4 gigs for the windows folder alone not including all the other major stuff like video/sound/mouse drivers and other utilities located in the program files folders) so in short did not have the space to use the standalone installer... I then tried to use the Windows Update again and it sat for 40min at 0.0kb and 0% complete before it jumped to being at 99% complete it then ran and installed and asked to reboot.... upon reboot it went into the configuring your service pack screen again and spent another 4ish hours there before kicking it self out again and giving me the same Time out Error Code... this point i'm about to just give up on sp1....
My System SpecsSystem Spec

 Service Pack 1 won't install

Thread Tools

Similar help and support threads for2: Service Pack 1 won't install
Thread Forum
Windows 7 Service Pack 1-Just will not install..tried Windows Updates & Activation
Can't (re)install Service Pack 1 Windows Updates & Activation
Service Pack 1 won't install Windows Updates & Activation
Solved Windows 7 service pack 1 will not install Windows Updates & Activation
Solved Service Pack 1 won't install Windows Updates & Activation
Can't install Service Pack 1 Windows Updates & Activation
Service Pack 1 won't install..... Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:46 AM.
Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App