Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows backup doesn't work?

11 Mar 2011   #1
total confusion

Windows 7 Pro
Windows backup doesn't work?

I just tried running a backup on my Windows 7 Pro and got "backup application could not start due to internal error: Class not registered (0x80040154)"
I put a snip of it in (attachment) Why would that happen if I'm trying to set it up?

Attached Thumbnails
Windows backup doesn't work?-backup.jpg  
My System SpecsSystem Spec
02 Apr 2011   #2
total confusion

Windows 7 Pro

Still looking for some help on this one. I really wanted to get that fixed before installing SP1. I thought installing the SP might fix what ailed it but it didn't.

I contacted support but they didn't get back to me, they sent me a request number but when I ran the diagnostic it said it couldn't send it.
My System SpecsSystem Spec
02 Apr 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

You can easily avoid Windows Backup and use free alternatives that are less confusing, less frustrating, and more flexible.

But you might have a particular reason to use Windows only?
My System SpecsSystem Spec

02 Apr 2011   #4

64-bit Windows 10 Pro

Hello TC,

I agree that using a free backup program like Paragon Backup & Recovery 2011 (Advanced) Free instead is a good alternative.

If you really wanted to try and fix it, then....

You might see if running a sfc /scannow command may be able fix this for you.

If not, then as a test, create a new Administrator account and see if it works while logged in this new account instead.

If not, then you could try doing a system restore using a restore point dated before you started getting this error (if known or best guess)
My System SpecsSystem Spec
02 Apr 2011   #5

Windows 7x64 Home Premium SP1

This type of error can indicate a registry error. Problems with backup imaging may be a symptom not a cause.
Others may have a suggestion.
My System SpecsSystem Spec
03 Apr 2011   #6
total confusion

Windows 7 Pro

Sorry I didn't get back to this. My weekend is totally out of hand.
I've run both SFC and the disk check, neither show any problem. I have also used Macrium reflect (the full paid version) and the free Acronis for western digital. I can't get either one to verify an image. I did try EASEUS Todo and it said I have a good image, I don't know if I can trust that. After a crash is no time to find out the software your using isn't trustworthy. That's why I was trying to use the one that came with my Windows 7 Pro. I thought there might be a compatibility problem somewhere.
I should also mention I had this same problem when I was running Vista on a different hard drive, same machine.
I've run stress test on processor and it passed. I've also checked both the internal hard drive and the external drive both pass (both are also new).

I tend to agree with mjf. Somewhere I have a file that isn't passing the checksum. That explains why they don't pass verification (meaning I have a good image). That doesn't explain why I get this " App can't start due to Internal error". What would be the internal error? Nothing is showing up in the event log and in my "services", the shadow copy is set to automatic and shows as running.
My System SpecsSystem Spec

 Windows backup doesn't work?

Thread Tools

Similar help and support threads
Thread Forum
Backup in Win 7 Pro doesn't work, again?
After reinstall (repair install) the backup on my Win 7 Pro doesn't work. For some reason it's not recognizing the external drive. I looked in th KB and found an update, download it and tried to install. It came back that my system doesn't need it. My event log is already filing up with errors...
Backup and Restore
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Backup and Restore Doesn't Work
Problem: Windows Backup and Restore does not work. When the link is clicked, nothing happens. Background: At one point Acronis True Image Home was installed. The uninstaller left behind an entry in key HKEY_CLASSES_ROOT\CLSID\{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD} that continues to point to...
Backup and Restore
Control Panel Backup & Restore link doesn't work
How can I get the Windows 7 Control Panel Backup & Restore link to work? When I click on it it does nothing
Backup and Restore
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:50.
Twitter Facebook Google+