Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't get Windows Backup to work

26 Sep 2011   #1

Windows 7 Ultimate Home x64
Can't get Windows Backup to work

I have my Win 7 PC set to back up to an external HD and have yet to get a successful backup. The Action Center gives me the message:

Windows Backup failed while trying to read from the shadow copy on one of the volumes being backed up.

When I look in the event viewer, I find the following error:

The backup operation that started at [date] has failed with following error code '2147942405' (General access denied error).

I've searched for that error code but haven't found any useful info. I've confirmed that both the Volume Shadow Copy and SPP Notification services are running. I suspect file permissions may be involved. The files I'm backing up are on both the original C: drive and another internal drive I added. Does anyone have any ideas what the problem might be, or things I should check?

My System SpecsSystem Spec
27 Sep 2011   #2

Microsoft Community Contributor Award Recipient


My System SpecsSystem Spec
27 Sep 2011   #3

Windows 7 Ultimate

Windows backup is extremely primitive and touchy, and therefore unreliable.

I'd suggest using "Vice-Versa Pro" or something similar (a backup with shadow copy - "DriveImage XML" is another). VV-pro is great for incremental backups and has an excellent display of the files to be copied.
My System SpecsSystem Spec

27 Sep 2011   #4

Windows 7 Ultimate x86

I agree with flemur: Windows Backup is touchy to a point where I question its use. Who guarantees, that even if the Backup went through without a hitch, that the restore process in times of needs goes through as well.
Because of that uncertainty I don't even bother and use a 3rd party solution which comes highly recommended by many users of this board. just give it a try:

Macrium Reflect FREE Edition - Information and download

My System SpecsSystem Spec
27 Sep 2011   #5

Windows 7 Ultimate SP1 64-Bit

SledgeDG is right, Macrium does have a good reputation from WSF users.
My System SpecsSystem Spec
27 Sep 2011   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Try this:
Restart the "Block Level Backup Engine Service" service [net stop wbengine &
net start wbengine] make sure this service starts and it is running before
you commence backup
My System SpecsSystem Spec

 Can't get Windows Backup to work

Thread Tools

Similar help and support threads
Thread Forum
Backup Does Not Work Sometimes
When I place a new disk in for backup, it works. When I want to backup again, sometimes it works and sometimes does not. Then a message appears asking me to put the right disk in. Why can I not use the same disk again? I thought backup only adds the new files and updates the old files if they were...
Backup and Restore
Cannot get backup to work. Help.
I try to backup again to my external HD (20GHz) but not enough space so it fails. I buy another HD (200GHz) but backup cannot find the location where my backup are being saved! I try to change settings but always get ' the backup could not start due to an internal error. No such interface...
Backup and Restore
Backup does not work
I'm getting the error 'The backup application could not start due to an internal error. The specified service does not exist as an installed service (0x80070424).' I've tried the backup service on both manual and auot, and the RPC service is running. I'm using Windows 7 Ultimate...
Backup and Restore
Windows backup doesn't work?
I just tried running a backup on my Windows 7 Pro and got "backup application could not start due to internal error: Class not registered (0x80040154)" I put a snip of it in (attachment) Why would that happen if I'm trying to set it up?
Backup and Restore
Windows 7 backup doesnt work
i installed windows 7, and everything seemed to work fine. installed a bunch of programs, they also all seem to work. but then i decided to do some backups; i created the rescue cd using windows, and then cloned the hard drive also using windows 7. but then i noticed the backup program, and...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App