Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Backup can't find non existing directory?

23 Feb 2012   #1

windows 7
Backup can't find non existing directory?

This is so weird. I created an image backup for drive C and F.
After completion of the backup I got the following explanation in the error log.
Backup encountered a problem while backing up file F:\Prior 2010\Orig Music. ErrorThe system cannot find the path specified. (0x80070003))

That directory does not exist anymore. How can the backup look for a non existing directory? How do I get rid of this for the next backup?

My System SpecsSystem Spec
23 Feb 2012   #2

64-bit Windows 10 Pro

Hello MiaAccess,

Whenever you click on the Back up now button, it creates an incremental backup of what was included when you first setup the backup. Since that file's path was included when you setup the backup, that would be why you are getting that error log message since it had been deleted and cannot be found to back it up now.

You will just need to click on the Change settings link in "Backup and Restore" to change what is included in the backup, and make sure that the deleted file's path is no longer included. Using step 4 in the tutorial below can help show you more details on this. :)

Backup User and System Files

Hope this helps,
My System SpecsSystem Spec
06 Dec 2013   #3

Windows 7 Ultimate x64

I know this thread is old, but this problem is the closest I have been able to find on the site, and extremely similar to what I am experiencing...

PS: Hi, I'm Dravial, been watching you all for a while. Damn Brilliant, nice to meet your acquaintance.

So now then, I have been using Backup and Restore for a while, no problems. I was using it on my internal hdd, 2 TB, which I partitioned into four equal parts. On two of these parts, E: 'Media' and F: 'Storage', I made shared folders on the network/homegroup. I was keeping my backup on F: along with a number of other files, and it became almost full. Then along came the miracle of Black Friday and a $99 3 TB external drive. After fighting with it and getting it formatted properly to even allow backup and restore to work properly on it, I finally set up a shared folder so all my computers on my network would be able to back up to it, each in their own folder within the shared folder. At the same time, I took some of the shared items on E: and moved them to the new external hdd where they seemed better suited and accessible. Then I deleted everything on E:, or at least I tried...
I could not delete two folders here, even after reboot - stated "S1-587256-5342543-543543243" (I made the numbers up, as I do not remember EXACTLY, but that is what it 'resembled') was using it, and I needed admin permission to delete it, Right. OK, except... I AM ADMIN. So yeah, buggers to the lot of ya, I formatted the drive. I had everything I needed off of it, so I deleted it. Then when I try to run backup and restore, it completes, but with error 0x80070003 - Says it can not find two of the folders within the shared folder that used to be on E: - and believe me I looked at method 4 stated above, and already tried to do it three times now with the same results. And frankly, I do not have that hdd checked, or see a path to the files it is after anywhere in what is selected to be backed up...
I finally went and added the folders it so desperately wants back to E:, and now it backed up fine, even though they are empty. So I thought, Right, the're empty, you don't care if I delete them now. LOL@U. Oh yeah it does, I once again can not delete them. Seriously? Any thoughts as to why it wants them so bad? If I was not such a stickler for things to be right, I would leave them, but I hate having useless things cluttering up anything...
If I left anything out, just ask. My thanks in advance for any insights.

EDIT: Is it possible to just wipe Backup and Restore, and 'start over'? (Short of re-installing windows, I am not drinking the required amount of bourbon for that tonight!)
My System SpecsSystem Spec

06 Dec 2013   #4

64-bit Windows 10 Pro

Hello Dravial, and welcome to Seven Forums.

In that case, you might consider to completely reset Windows Backup to default, then set up Windows Backup again to see if that may sort it for you.

Hope this helps, :)
My System SpecsSystem Spec
07 Dec 2013   #5

Windows 7 Ultimate x64

Brilliant - but I did alter a few things, or rather, the order. I looked over your steps to remove backup, and instead of going through some nonsense of deleting a schedule after the fact, I first opened backup and restore and removed any scheduling and saved. Then I ran your registry key and rebooted, hoping to clear anything out of memory. I then went to my folders and was able to successfully delete them without formatting, although I could not delete the parent folder with the other two inside, it gave me the same error; I had to go in the delete the child folders first, which it completed fine, then go back and delete the parent folder afterwards fine. Who knows... Anyway, then I started backup and restore, FOR THE FIRST TIME!, It did show as the first time, and Iwaited for 10 minutes or so, the green bar was almost to the end and...

Then it turned RED. I received the same errors... What gives? This is maddening...
Backup encountered a problem while backing up file E:\Shared Media\MUSIC. ErrorThe system cannot find the path specified. (0x80070003))
Backup encountered a problem while backing up file E:\Shared Media\Customize. ErrorThe system cannot find the path specified. (0x80070003))

Edit: Should I have deleted the event log or something? There must be something telling it to look there... I'm not making this computer any more sandwiches! >_<
My System SpecsSystem Spec
07 Dec 2013   #6

64-bit Windows 10 Pro

When you set up Windows Backup after resetting it, did you make sure that that folder location was not included to be backed up?
My System SpecsSystem Spec
07 Dec 2013   #7

Windows 7 Ultimate x64

I selected let windows choose. Also remember, I stated before, I had no check mark in E: at all under "Computer", and I did/do not see it listed under Data Files/Libraries/Additional Locations... so where would it be?

Hrm... I have an idea. Be afraid. I had added one of those folders to the 'library' or what have you under Video Libraries... I just went and removed it, maybe this will help... now where might the other one be? ...

EDIT: Well dur, in the MUSIC folder, right? Amazing how many things their are to screw up if you are given enough time. I got those two deleted from the libraries (where they made note of there non-existence, and would also explain why the system wanted to keep control of them). SO I think they were being included by an association aspect, the library was included ,and it was in the library as a point to find material for the library... even if non-existent. I have it backing up again now. I bet it works. I'm having a bourbon either way. I'll have another one now, because it did work. Thanks for walking me through this! You're so damn brilliant! :P

Seriously though, thanks!

**Now you can message me and explain how to make my computer turn on when another computer on my network wants to back up to that same external hdd, and my computer the hdd is attached too is in hybrid sleep mode! **
My System SpecsSystem Spec
07 Dec 2013   #8

64-bit Windows 10 Pro

If the deleted folder is still included in library that is selected to be included in the backup, then that's most likely it. Removed the folder from the library should sort it.

Library - Remove a Included Folder

That network issue would be a good one for a new thread.
My System SpecsSystem Spec

 Backup can't find non existing directory?

Thread Tools

Similar help and support threads
Thread Forum
Backup directory using dos.
Hi, I have tried. Various methods to fix my laptop and its not happening. All the tools to fix it are more than i can afford so will be doing a clean install. My question is, can anyone tell me how to back up the users folder to a USB, i have checked computer hope and everything i find is to back...
General Discussion
New SSD installed and working can't find existing HDD
Got nasty virus on HDD and wanted to install a SSD anyway so installed it (SSD) and now need to get data off of HDD but it is not recognized, how do I get it back so I can get data of of it before reformatting. I unplugged power to HDD prior to installing SSD and plugged it back in and get nothing.
Installation & Setup
Windows 7 Backup is backing up a non existing backup!
I have the little flag "backup in progress" icon and my hard drives are being accessed constantly. This has been going on for four days. When I double click on the icon I get taken to the action centre where I am told that I do not have a backup set. There is no schedule for a backup either. If I...
Backup and Restore
How to create system 'knowledge' of an existing backup?
I have an existing full system backup from months ago. The current Win7 system has no current 'knowledge-does not offer to use the backup image' of that backup. Obviously, there are no sys. files telling Win7 how/what to do with it. Win7 lost 'knowledge' of this backup due to a 'Restore...
Backup and Restore
new to find program directory in XP Mode
(thread title should read "need" not "new" I installed XP mode in my Windows 7 Professional 64 bit laptop to be able to run my older programs. I successfully installed CompuServe (my mission critical software) in XP mode, but I need to find the program directory because that's where the data...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:16.
Twitter Facebook Google+