Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need big help with backup error 0x81000038

23 Apr 2012   #1

Need big help with backup error 0x81000038

I am getting this error now on backups, where I did not used to have this problem. My Toshiba Portege is several months old Backups were running fine. However, recently, I have installed and uninstalled various utilties, and can no longer backup.

The error code is 0x81000038.

Microsoft has a KB article for this "0x81000038" error message when you back up files in Windows 7

So begins, the trip down the rabbit hole.

Know first, that this is an upgraded system, now running Windows 7 Pro. All the upates are applied, There are no viruses, as MSE watches over the system constantly.

The KB article says:
This problem occurs because the following registry key value is missing:
HKEY_USERS\<User ID>\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\AppData
So, I go to the registry and find that there are no user IDs that match anything I expect to see (like my windows login). (See the attachment.)

So, I decide to add the key(s) listed in the KB article. But I cnanot edit that part of the registry, permission denied. Nor can I add myself to the permisisoons list for the KEY_USERS key.


Attached Images
Need big help with backup error 0x81000038-hkey_users.jpg 
My System SpecsSystem Spec
23 Apr 2012   #2

MS Windows 7 Ultimate SP1 64-bit

go to a command prompt, that is,
WIN | type cmd.exe | ENTER
then enter following:
wmic sysaccount get Domain,LocalAccount,Name,SID,Status /format:table > %userprofile%\desktop\SystemAccounts.txt

this will put a file, systemaccounts.txt on your desktop.

My System SpecsSystem Spec
23 Apr 2012   #3

MS Windows 7 Ultimate SP1 64-bit

go to a command prompt and run:
wmic useraccount list full /format:table > %userprofile%\desktop\UserAccountsFull.txt

which will put a file called useraccountsfull.txt onto your desktop.

Now you should be able to spot the account of interest to you.
My System SpecsSystem Spec

23 Apr 2012   #4


Karl, Thank you.

Following your instructions helped me both find the account and also to understand that Microsoft was referring to the SID not the Name. So, other readers should understand that the KB article might have been clearer if it had said:

HKEY_USERS\<User SID>\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\AppData

However, backups still failed. Following the instructions in the KB article to turn off the AppData in the Windows selections and turn it on in the "let me choose" section did not work. I tried turning off all default selections and turned on "let me choose" my entire system disk ( C: ). Still errrored.

Then I remembered something I encountered in another Microsoft problem.
So, I used file explorer to change the %userprofile%\AppData folder to visible instead of hidden (that folder only).
Repeating the backup, it worked!

As implied by the KB article, the root cause only applied to the account running the backup, not for each user on the system. So, I only had to unhide mine. I hope our thread helps someone else with this problem.

Final answer: change %userprofile%\AppData to visible (not hidden).
My System SpecsSystem Spec
23 Apr 2012   #5

MS Windows 7 Ultimate SP1 64-bit

Thanks for getting back to us with how you solved the problem.

Glad to be of assistance.

Changing some of the Win 7 default configuration can sure turn around and bite us in strange ways.
My System SpecsSystem Spec
23 Apr 2012   #6


Yes indeed. The hard part is knowing what changed. Installed application? Windows upgrade? Who knows? Nobody can effectively assure that all working functions (like backup was) continue to work after making a system change.

Thus, we need to be able to solve problems from whatever the current working state is.

As in this case, I didn't run backups enough to know whether any of a dozen software changes might have caused the problem, whether the registry (which I didn't end up changing, just came to better undertand) was modified by the upgrade or a software install, but something changed.

Sometimes it's a grey line between fix and work-around. At least I feel a good correlation between the reported KB root cause of "not finding" AppData and the "fix" of making the AppData directory visible.

In any case, it worked and I can get on to new things, with backups running again. Thanks again for the help!
My System SpecsSystem Spec

 Need big help with backup error 0x81000038

Thread Tools

Similar help and support threads
Thread Forum
Keep getting this error on backup
I seem to always get this error when I do my backups, any input on this would be great Backup encountered a problem while backing up file D:\Image C 64bit\. Error:(The system cannot find the file specified. (0x80070002))
Backup and Restore
Getting error when trying to run Paragon Backup
I've been having issues lately running Paragon Backup to make a copy of my C: drive Here is a pic of what is happening, anyone have any ideas?
Backup and Restore
Getting an error when trying to run Paragon Backup, please help.
I was trying to run Paragon backup the other day to back up my OS like I've done many times with it before. Now all of a sudden I'm getting this error message: Any help is greatly appreciated. Thanks.
Backup Image Error / Cannot Create Shadow Copy / VSS error
I am trying to create scheduled backups for my computer on an external drive (H:\) and am having a bunch of trouble. I had one successful attempt but did not have "create image of C:\" checked. I chose to check it and attempt again. No success. I unchecked the image and now cannot create any...
Backup and Restore
Backup error
Let me begin by saying hi to everyone. My computer specs that I typed in last night was changed today. I previously had windows ultamate 64bit but it is changed to 32bit. I was doing my first backup after installation and had this error. "The system cannot find the file specified. (0x80070002))"...
Backup and Restore
Backup error
Whenever I try to run windows backup, it fails. I'm trying to backup files and a disk image from C: drive to an external HD. The errors it gives are listed below. Any clue why it's doing this and how it can be fixed? Thanks! Log Name: Application Source: Windows Backup Date: ...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App