Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System Image Not Found on External USB HDD with Image as Root Folder

26 Jul 2012   #1

Windows 7 Ultimate 64bit
System Image Not Found on External USB HDD with Image as Root Folder

I have read about 50 threads in regard to the topic. I'm just looking for clarity here. I have a homebuilt system that got a virus Alureon.gen!k. Before researching it I let windows fix it. Computer won't open any applications now.
Decided to go to my Image to save time (NOT!). The image is on a USB external HDD currently attached directly to the computer. I can't get it to find the bleepin' Image!

The HDD was attached to an NAS over the network where it saved my windows images and backup files from the NAS. The drive's structure looks like this:

E: R6 Backup
Office Server
Office WindowsImageBackup MediaID.bin Data Drive Backup Files

Inside the Office folder are three items: Office, WindowsImageBackup, and a MediaID.bin. The Office folder has file backups. The WindowsImageBackup contains the expected image folders and files.

I understand from the threads that the WindowsImageBackup needs to be in the root of E: so I have done this two ways, neither of whiched worked. First I simply renamed the Root Office folder, and then I undid the rename and moved the WindowsImageBackup out of the Office folder and into the root of E:.

Windows sees the drive. Within the recovery you have the option under advanced to load drivers. I was doing this trying to use eSata to no avail so I switched to USB where you can clearly see the drive and all its contents. No matter, windows still won't recognize the image.

Is there anything I am missing here or is there a fault with Windows that is killing me? I will be using another tool Acronis or whatever in the future but as of right now it seems I am doing everything as I should. I guess I'm looking for conformation before a complete reinstall.

Thanks for whatever I get, unless it's someone telling me to use search for the answer which I did already for the better part of 1.5 days.

My System SpecsSystem Spec
26 Jul 2012   #2

Windows 7 Ultimate 64bit

I installed Acronis after seeing someone's post about converting the Windows Image file to an Acronis and just booting from that, but it is telling me it won't work and possibly the windows file is corrupted. Has anyone seen this or been able to fix a so called corrupted .img file?
My System SpecsSystem Spec
28 Jul 2012   #3
Victor S

Windows 7 Ultimate x64

Sorry you're not getting help here, and I don't have an answer.
The Win 7 imaging utility has been a problem for many, and you're not the first to encounter this problem.
All I can say is look into other imaging software for your future imaging.
Many here use free Macrium. I use Ghost 15.
I'm hoping somebody here with Win 7 imaging utily experience will jump in, but I can't recall seeing a solution to this. Hope I'm wrong about that.
My System SpecsSystem Spec

28 Jul 2012   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit Service Pack 1

Not sure whether this will help or not since Windows Imaging is a bit picky, but try moving the MediaID.bin into the root as well.
My System SpecsSystem Spec
28 Jul 2012   #5
Victor S

Windows 7 Ultimate x64

My System SpecsSystem Spec
28 Jul 2012   #6

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

You may be able to mount the vhd and image the mounted vhd with any imaging app.

I told whs about it along time ago.

He explains on that thread he tried it with disk mgmt and Macrium.

If you have any difficulty with that - let me know.
My System SpecsSystem Spec
28 Jul 2012   #7

Windows 7 x64

Can I ask why you put the NAS hard drive directly on your system? Did you try recovering the image from the network first?

On my NAS, the drive is formatted as ext3, which doesn't work well with Windows. Maybe you just have an external drive connected to the NAS, and not in it.

But if the drive is a USB 3.0 device, the 3.0 ports may not work in the recovery environment.

Try leaving the drive off during the boot into the Recovery environment. After it searches for an image, turn on the drive and let it search again.

If you want to check the backup image, you can mount it by using Disk Management and the Action option to Attach VHD. Make sure you have the partition with the Windows Backup Image selected, but look for the .vhd file in one of the folders.
My System SpecsSystem Spec
28 Jul 2012   #8
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

My System SpecsSystem Spec
28 Jul 2012   #9

Windows 7 Ultimate 64bit

Hi guys and thanks for the responses.
The NAS was not connected directly it was networked via ethernet on the router. My back up drive was connected to the NAS via usb.
Coincedentally my power supply on the NAS broke so I can't network to the back up drive. So, I connected the back up drive direct to the pc in question. It is connected via 2.0 and the drive can be seen in the advanced tab when working restore.
I will try moving the MediaBin file too.
I'm wondering if: IF the drive was connected to the NAS, perhaps it can only be recovered through the network? No way to tell until I get my replacement power supply from Iomega I guess.
I've never attempted to mount an image. Is this done and then recovered from there, or does the mounted image become your C drive?
Thanks agian
My System SpecsSystem Spec
28 Jul 2012   #10

Windows 7 x64

I ran a test the other day where I moved a backup image from the NAS to my system and one from my system back to the NAS. Both images were still recoverable, so I don't think just moving it makes much difference. It does matter for a drive connected to your system, that the folder be on the root directory.

If you decide to use the networked NAS again, loading a driver for your Network Adapter using the Advanced button, is not hard to do.

I looks like now we need to determine if the Windows backup image is bad, or your drive is bad. I don't suppose you have a second internal hard drive you could copy the image to? Mounting the image using the VHD option would just see if you could read it. Someone else may know if you can do more.

You might test by renaming the current backup folder and making a new backup, assuming it would work. You certainly want to keep the system after a re-image using that, but you could test the external drive that way.

Have you ever used a image created on the external to restore your system?

I am not sure if I missed it, but how are you getting into the Windows Recovery Environment? If you aren't using an Install DVD to boot, something on your system may be involved.
My System SpecsSystem Spec

 System Image Not Found on External USB HDD with Image as Root Folder

Thread Tools

Similar help and support threads
Thread Forum
System Image Backup Questions and Cannot be found
Ok, I have read and read and cannot find the answer. I have a system image that was saved to a maxtor one touch ext HD via USB. This was created using W7 image making system. I am trying to copy the image to my new HDD (internal) 1TB. The problem is when I go to recovery>advanced...
Backup and Restore
System image problems - image not found
I am looking at a system for a friend that has got W7 Home Premium installed. However, he made a system image of his Windows 7 Ultimate system (using Backup and Restore) as he has all his work applications on it (some of the software he uses won't work with W8 or W10.) I booted the system...
Backup and Restore
Can I use a partition of an external HDD for a system image?
I want to create a clean system image after I fresh install Win7 in my Sony Vaio laptop. But I hear that external drives should be formatted with NTFS if they are to be used for this purpose. I only have one Sony HDD (1TB) & it has lots of stuff already which I cannot delete or move somewhere else....
Backup and Restore
Saving system image to external HD
In Backup one can choose to create a System Image and choose "On a hard disk". However, Backup does not see my attached external HD.
General Discussion
System restore image not working/cannot be found?
So way back when I installed windows on my SSD I made a system image restore doohickey, using the "Create A System Image" tool, once I had applied all the necessary settings, installed drivers, etc. Now, windows is experiencing problems and I wish to restore to this back up. How on earth do I do...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:25.
Twitter Facebook Google+