Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Restore Fail. Boot at infinite loop. Memtest.exe missing/corrupt.

01 Sep 2012   #1

Windows 7 x64, trying to get from Home to Ultimate
Restore Fail. Boot at infinite loop. Memtest.exe missing/corrupt.

I am running Windows 7 Home x64.
I've tried to restore my ASUS laptop (i think the model name was k53e or something similar) to factory settings, but I couldn't do so (????) because while other people told me to press f9 at bootup, when I pressed f9, I only got the choice of either booting up as "Windows 7" or starting the "Windows Memory Diagnostics" (or something like that).
Thus I got iso file of Windows 7 Ultimate x64, and since I didn't have large enough of a CDrom to burn it on CD, i used my 4gig USB drive to "burn" it on there using a Microsoft software.
I booted up the Windows 7 install page successfully after pressing "esc" button on bootup and I think I somewhat installed Windows 7 on my laptop to some extent (I went passed that point where it asked me to put the name of the laptop and if i wanted a password to protect this laptop).
However, after the windows 7 installation was "complete", the laptop restarted by itself, and then..well.. infinite loop started.
the infinite loop takes this process
(turn on computer) ASUS logo pops up -> "Windows is loading files" -> windows logo&"Starting Windows" -> a background photo (ASUS on the background, never downloaded this before, probably means that the windows 7 installation has occurred) and an oversized mouse pointer (probs the resolution is not set)... and then the computer restarts.

this is what i have tried

1. Installed Windows 7 again using my USB via pressing "esc." Same thing happened. Nothing changed in the end.

2. Pressed F9 at bootup. Gives me the choice of "Windows 7" and "Memory Diagnose". Went to Memory Diagnose. says that it can't run Memory Diagnose because boot\Memtest.exe is missing or corrupt.

3. Pressed F8 at bootup. Gives me various choices regarding "Safe Mode". Ran the computer in Safe mode. nothing's different as just turning the computer on. Infinite loop again.

4. went back to my USB via pressing "esc." Clicked "Repair your computer."
4.1"Use recovery tools...." and clicked next. Says that the version of system recovery options is not compatible with the version of Windows i'm trying to repair. Seems like my old Windows 7 Home x64 is lurking somewhere to cause this problem?
4.2"Restore your computer using a system image that you created earlier" and clicked next (pfft, I knew that I had no system image). Error pops up "Windows cannot find a system image on this computer." Clicked Cancel. Clicked cancel to "Select a system image backup." Voila! a new windows pop up. "System Recovery Options."
4.2.1 clicked "Startup Repair." Tried this twice. Nothing changed.
4.2.2 clicked "system restore." wants me to restart the computer and specify which windows i'm tyring to restore? uhh... skip.
4.2.3 clicked "system image recover." oh, we tried this already. no image.
4.2.4 Windows Memory Diagnostic. Restarts computer. back to infinite loop.
4.2.5 Command prompt. followed directions from this: Startup Repair Infinite Loop Recovery
apparently all my files in RegBack (including SAM, DEFAULT, etc.) are 0 bytes. So I stopped following the tutorial as it told me to.

Although I doubt that my Windows 7 Ultimate x64 file is corrupted and thus is leading me to this miserable situation, I'm currently looking for a Windows 7 Home x64 so that I can restore to the windows i have been using (which might cause me less trouble). But I don't think that's the cause of the problem anyways.

It makes me really sad that my laptop doesnt have (or I fail to find..) an inherent restore-back-to-factory-settings tool. So I need help.. please! What should I do now?

My System SpecsSystem Spec
01 Sep 2012   #2

Windows 7 x64, trying to get from Home to Ultimate

I installed win7 x64 Home. Now it is working fine. Not sure what happened with the Ultimate. I'll try upgrading this to ultimate, but for now this is fixed!
My System SpecsSystem Spec

 Restore Fail. Boot at infinite loop. Memtest.exe missing/corrupt.

Thread Tools

Similar help and support threads
Thread Forum
BSOD On Shutdown Causing Infinite Boot Loop
Hi Everyone, I am new here so forgive me if I am going about this the wrong way. I am usually able to solve problems one way or another but I am at a dead end and I don't know what to do at this point. I have had this problem sporadically since I have built my computer but recently it has become a...
BSOD Help and Support
Another infinite boot loop
Hi I had a virus, downloaded some subpar anti virus (Yet Another Cleaner) and it deleted the virus... along with some Windows registry or something important along those lines. My computer is now stuck in an infinite boot loop. Undoed a System Restore to a point before the anti virus killed my...
General Discussion
Startup Repair Infinite Loop, Cannot Find Hard Disk, Registry Corrupt?
So I tried using the Startup Repair Infinite Loop Recovery ( and It did not work for me. I tried the Startup Repair and It said "Hard Disk could not be found" On another instance, It said "Registry is...
Backup and Restore
AHCI Infinite Boot Loop
I have installed a Samsung 840 Pro 120Gb SSD into my ZT System machine and am trying to get around a clean install. The drive runs but I cannot get AHCI to work when I turn it on in the AMI BIOS. I have made the registry tweaks, three but I cannot remember which three at this time as I am at work...
General Discussion
Windows 7 Infinite Updates (not boot loop)
First off, I'd like to apologize for not knowing exactly how to go about describing my issue, although I promise to do the best I can. I guess my first problem was forgetting to write down the day this issue started happening, because that would have helped me narrow down the problem, I'm sure....
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:12.
Twitter Facebook