Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to restore from a .bkf file

16 Oct 2009   #11

Windows 7

Ultraplanet, You are a genius! Works like a champ, and there are no hoops to jump through.

Many, many thanks!


My System SpecsSystem Spec
16 Oct 2009   #12

Windows 7

Thanks Zoner - it was an interesting problem.
My System SpecsSystem Spec
26 Oct 2009   #13

Windows 7 Beta
Worked Great!

Thanks a heap!
My System SpecsSystem Spec

26 Oct 2009   #14

W8 Pro, W7 Ultimate, XP Pro x64, Vista x64, Ubuntu

Quote   Quote: Originally Posted by ultraplanet View Post
The link to the program I provided above should do exactly what you are looking for. Provide a way to use Windows 7 to restore files from a backup made using XP's backup utility.

After trying this out it doesn't work but the ntbackup utility itself will run under w7.

Copy 3 files from XP (c:\windows\system32) to a new folder on the Windows 7 machine (not the system32 folder though because w7 has its own version of vssapi.dll):


Run ntbackup.exe from the folder you created on the windows 7 machine.

Click on do not show this message again when warned that removable storage service is not running.

Click on OK

NTBackup starts up and runs just like on XP.
Great information! I was looking for something like this.

Did you have problems with the Windows NT Backup - Restore Utility in your link because there was no place to turn on "Removable Storage Management" in W7? Or some other problem?

I had a compatability problem/error with using the three files you list, though. I'm running x64 W7 and the ntbackup.exe is 32-bit. I was close but no cigar.

Rep for ya' though. Thanks.
My System SpecsSystem Spec
12 Nov 2010   #15

Windows 7 64 bit

I need help restoring my BKF file in windows 7. I have the same problem as Zoner, but I don't think I am as tech savy as he is. I was running Windows 2000 professional and I made a backup file before I upgraded, a .bkf file, on an external hard drive. I was upgrading to Windows 7 but I had to upgrade to Vista first. After installing Windows 7 I tried to restore my backup file and it would not do it. What do I do now? I no longer have a copy of Windows 2000 and even if I did, I do not know how to create a virtual partition or how to "dual boot".
It appears that there are plenty of windows users in the same boat. If the purpose of making a backup is to be able to recover one's files why does Microsoft change backup file formats without warning?

Any suggestions that do not require me to go back to school and get an IT degree would be appreciated.
My System SpecsSystem Spec

 Unable to restore from a .bkf file

Thread Tools

Similar help and support threads
Thread Forum
System Restore Error, Unable to Create Restore Points
Hello everyone, not sure why but I get an error every time I open the System Restore. I rarely have to use a restore point as I regularly maintain my computer and check for viruses and malware, but I would like to have the option just in case. When I open System Properties, and click the System...
Backup and Restore
Unable to move file from desktop - Security Tab - Unable to Display
I had a folder on my Desktop that just won't delete. I tried deleting it and moving it to another location. It deleted everything within the folder, yet the folder still remained. I've been having the problem of my Desktop not updating when files/folders are deleted, so I have to manually...
General Discussion
Unable to restore file (error code 0x8100001A)
Weeks ago I tried to restart backups after reconfiguring my hard drives. Now backups finish (with some files skipped) but I cannot restore, due to problems validating a zip archive. However, the zip archive mentioned is one that was deleted weeks ago, and it did not exist when the backup was made....
Backup and Restore
Unable to restore - can save a restore point
I have had this problem for quite a while. I'm able to create restore points (and they show up in the list), but I'm unable to 'restore' them... I get the system cannot restore error. I have Norton-Comcast and have deactivated 'tamper protection' with no luck.:mad:
Backup and Restore
Unable to restore, unable to login
This has been quite an odissey so far and I really need help. I have an ASUS N51Vf on which I just changed a defective hard drive with a new one, same size and specs as the old. After a clean windows 7 install all was working fine. I created a System Restore Point. No errors reported, restore...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:43.
Twitter Facebook Google+