Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't backup, error code 0x8007045D

22 Oct 2012   #1

Win 7 home prem
Can't backup, error code 0x8007045D

I have an HP tx2627cl table notebook (swivel screen), Win 7 Home prem OS, 4GB ram and a Seagate ext HD (75GB free of 279GB) which will not allow me to backup. I get error message 0x8007045D because of "an i/o device error". I can copy files to that external HD (I:), but can't use Windows Backup. I did a check disk of I:/ and got no errors. When I click on Backup to I:/, it starts, says it is creating a shadow copy, runs for a couple of minutes (about 5-6%) then I get the above error message. I have switched USP ports, and tried doing a backup from a "clean boot state" with the recommended settings--all to no avail. Any help would be greatly appreciated.

My System SpecsSystem Spec
22 Oct 2012   #2

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

Hello wxford and welcome to Seven Forums.

Are you trying to create a System Backup Image of the OS, or are you trying to backup personal data?
Imaging is not the best or recommended method to backup personal data.
Imaging is the recommended method to backup the OS partition(s).
I'm guessing you want to create a System Backup Image.

Run a System File Check to see if any errors are found.
SFC /SCANNOW Command - System File Checker

If you already haven't, you can do a Google search for 0x8007045D and see what you find.
Here's a couple links i found that may help.

Error message when you try to perform a full backup on a Windows Vista-based computer: "The request could not be performed because of an I/O device error"

If you don't find a solution, you could consider trying a different program to create backup images.
Macrium Reflect has a free version that is recommended by many here on SF.
Macrium Reflect FREE Edition - Information and download
You can also get a free version of Acronis from the Seagate website.

Seagate and Western Digital have a free version of Acronis for anyone that has one of their HD's.
Macrium, Acronis, and other programs are better and much easier to use than Windows backup imho.
I use and prefer Acronis (paid) for Backup Images because I've used it for many years without issues.

hope this helps,
My System SpecsSystem Spec
23 Oct 2012   #3

Windows 7 Professional 64 Bit
May not work at all

Windows 7 Backup appears to have been spawned from the fertile mind of some engineer inside Microsoft who had never encountered a real backup program and had no idea what a real backup program was supposed to do or how it was supposed to work. (Flame off -- sorry, but I have designed a backup program before that is still being sold, so yes this is my opinion, but it's an opinion based on been there, done that, if anybody on my team had come up with a design as lame as Microsoft's built-in Windows Backup I would have fired them on the spot).

So anyhow, I was getting the exact same error from Windows Backup. I did the recommended chkdsk /r on the external USB3 hard drive, no problems. I also checked the Windows logs, no problems reported there either. So I attached the drive to my Linux server and exported it to my Windows system via iSCSI (one thing Microsoft *did* do very well was their iSCSI initiator, which is the best on any OS anywhere). That way I could check the Linux logs to see whether it was encountering any actual I/O errors on the USB drive. And don't you know it, about 18% of the way through, Windows 7 Backup gives me this error *again* -- and there's no errors at all reported on the Linux side, which happily tells me that the drive is fully operational and all hunky!

Checking the Microsoft tech support forums, it appears that this issue has been reported repeatedly to Microsoft multiple times since 2008, with various ineffectual handwaving on the part of Microsoft as to why it happens but no solutions. My only solution was to roll my eyes, do a network backup to a network share, and start investigating a real backup program... which is a topic for another post.

So a) run a chkdsk /r on the drive (or the GUI equivalent, right-click on the drive in explorer, go to Tools, and tell it to check all blocks), but b) know that it may never work and Microsoft has no solution if it doesn't, they will just handwave that it must be someone else's fault. Which means c) the solution is likely another backup program. So it goes.
My System SpecsSystem Spec

23 Oct 2012   #4

Windows 7 Professional 64 Bit

And just to reiterate -- backing up to a CIFS network share that was sharing the exact same 2TB drive worked fine. Backing up to the 2TB physical drive directly (or via iSCSI even) did not regardless of how I formatted it in Windows, failing 100% of the time with the above error. Bizarre. But apparently a long-standing bug in Windows Backup that Microsoft has known about for years but never resolved for whatever reason. About the only good thing that can be said about Windows Backup is that since it saves its data as a bunch of zip files, you can always get at your data regardless of whether the program itself actually works right.

The good news is that when I look at the low-level API's for backup in Windows 7, they're actually quite good, certainly better than in MacOS and *way* better than Linux (which has no easy way to listen for and record filesystem change events for an entire filesystem for use by an incremental backup program, forcing a very slow and expensive directory tree walk every time, something that annoys me at work where I have to back up 4TB of source code directories and user directories off of Linux-based storage to a snapshotting backup appliance in a process that takes six hours of 'rsync' grinding away every night). Just need to find a program that uses them properly... one has to exist... hrm...
My System SpecsSystem Spec

 Can't backup, error code 0x8007045D

Thread Tools

Similar help and support threads
Thread Forum
ERROR code 0x8007045D
Few days ago my windows crashed.My laptop was rebooting again and again.I tried to re-install windows 7 but when setup comes to "installing windows" gets stuck on the second step "gathering files required". this step is completed to 68% but after this it never goes beyond.i tried to...
Installation & Setup
Error code 0x8007045D when doing fresh install
So I launched my PC the other day and was greeted with a BSOD. System repair didn't work so I decided now would be a good time to install the Samsumg 840 EVO SSD that has just been sitting in my room for a while. So I unplugged the harddrive and then plugged in the SSD, but when installing I was...
Installation & Setup
Error code 0x8007045D when re-installing Windows 7
Hi, I'm trying to fix my brother's Dell Inspiron N5030 because he couldn't get windows to boot after running startup repair several times. So I made a WIN 7 bootable USB using Wintoflash, booted the usb, and ran the startup repair utility 2-3 times with no luck. Then I tried to re-install...
Installation & Setup
Error code 0x8007045D
I'm having trouble with my hard drive, it's a WD elements 320gb hard drive and when I try to put anything on it or take thing off it it give me this message saying it was unable to do it because of an unexpected error "error 0x8007045D: the request could not be performed because of an I/O device...
Hardware & Devices
Windows 7 - error code 0x8007045D?
I can's get past "error code 0x8007045D" while installing Windows 7. I'm working off the CD Disk that was sent to me. Any help?
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:47.
Twitter Facebook Google+