Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: D Drive partition has been unallocated and no longer exists

09 Jul 2013   #1

32bit Windows 7 Ultimate
D Drive partition has been unallocated and no longer exists

I have two HDD's installed. Disk 0 is partitioned as C and D, and Disk 1 is E. I also created 3 desktop
shortcuts for each partition.
I was trying to restore back and old Acronis backup to the D drive and must have done something wrong as it's completely obliterated it.
The D drive shortcut now has a big blue question mark next to it!
Went into W7's disk management which shows two disk entries -
Disk 0 has two entries, namely C 58.59gb ntfs and another entry of 407.17gb unallocated (presumably the old D: drive).
Disk 1 has an entry of HDD E 465.75gb ntfs (which will be my E: drive)
I'm getting a bit out of my depth here and don't want to completely screw things up more than they are, so how do l get my D drive back?

NB There was nothing on the D drive in the first place.

My System SpecsSystem Spec
09 Jul 2013   #2

Microsoft Community Contributor Award Recipient


NB There was nothing on the D drive in the first place.
If so, format the partition in disk management.
Partition or Volume - Create New
My System SpecsSystem Spec
10 Jul 2013   #3

32bit Windows 7 Ultimate

Thanks theog, reply appreciated.
Think l have solved the problem by trial and error.
I did go into disk management like you suggested, but right clicked on the unallocated space entry until it got to naming the drive which l did as D.
Everything now seems to be working fine but l will bear your comments in mind for future use if needed.
My System SpecsSystem Spec


 D Drive partition has been unallocated and no longer exists

Thread Tools

Similar help and support threads
Thread Forum
Cannot partition unallocated space on 4TB hard drive
I just bought a 4TB hard drive to replace my old one which was damaged. However it only allows me to partition 2TB and leaves the remaining 1.64TB as unallocated. I've tried easeus but it does not allow me to do anything with the unallocated space. I want to create 3 partitions with that...
Hardware & Devices
How can you tell Windows a restore point no longer exists?
It is part of a larger problem though. Because I store my system images on an other drive then the drive windows is installed on it cannot find them and as such the restore point doesn't work. Though in the screenshot I want those entries to be removed as the backup for that has been removed. ...
Backup and Restore
Partition an unallocated hard drive??
I was confused with trying to partition the hard drive since last evening. Here is my computer specifications below: Acer Aspire M3450M-ER20P Desktop 3.3GHz AMD FX-6100 Processor 8GB DDR3 system memory; Expandable up to 16GB 2TB hard disk drive 16X DVD+/-R/RW optical drive Windows 7 Home...
General Discussion
System trying to connect to static IP that no longer exists
Background: I had my Win7 desktop configured to connect to my laptop via crossover cable using a static IP. Everything with this setup worked fine. Now I no longer use this setup(the laptop is no longer around), yet my desktop is still trying to access the static IP It seems that...
Network & Sharing
Drive C partition unallocated
I have Windows 7 Ultimate 32bit installed on drive C of the internal hard disk of my laptop. Yesterday, after I put my laptop in the hibernate mode, upon resume, there is a blank screen with a message that says unable to find the operating system. After rebooting, it is still the same, with the...
Hardware & Devices
how to create a logical drive from an unallocated partition?
I have just shrunk my C: drive and the unallocated partition failed to be formatted and assigned a drive letter. I followed the completing the new simple volume wizard but it didnt work. Instead it returned an error message that I have exceeded the number of partitions allowed. All I wanted...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App