Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System Restore did not complete successfully: Silverlight

12 Oct 2013   #1

Windows 7 Professional x64
System Restore did not complete successfully: Silverlight

Background: I'm having a problem with Saving download files on IE10, but Run or Open works [Later: see my reply]. I foolishly clicked Run on a program on Tucows, and it installed a bunch of crap on my system. I've checked for viruses, all clean.

The problem: I tried to do a System Restore, but got this message:

I tried from Safe Mode, and from the F8 menu, same result.

I removed all the crap from Tucows manually, ran CCleaner, deleted all the Restore Points, turned off System Restore, rebooted, turned it back on, made a new Restore Point to test.

Now when I try to restore, its tells me that System Restore is turned off (it isn't).


My System SpecsSystem Spec
12 Oct 2013   #2

Windows 7 Professional x64

Quote   Quote: Originally Posted by nigelmercier View Post
Now when I try to restore, its tells me that System Restore is turned off (it isn't).
Fixed it!

First of all I did a reinstall of Silverlight for the original problem.

Then did the stuff in the first reply to this thread, then turned System Protection off and on again.

[Later] These actions have also fixed my IE10 download issue!
My System SpecsSystem Spec

 System Restore did not complete successfully: Silverlight

Thread Tools

Similar help and support threads
Thread Forum
System Restore did not complete successfully.
10 days ago I logged into my admin account and I ran Restore to earlier 'Restore Point'. It appeared to finish successfully and so I logged out. I have been working on my PC since then without any major problems but being logged into my 'normal' account without the admin privileges. Last night I...
Backup and Restore
System Restore Did Not Complete Successfully Error 0xc0000022
Before visitors arrive I always set a restore point and restore my Windows 7 Home Premium 64-bit system after hey leave. This time I got a message: System Restore Did Not Complete Successfully. Unspecified Error 0xc0000022 Earlier restore point = same Earliest restore point = OK. ...
Performance & Maintenance
System Restore doesn't complete
I edited the permissions on my registry and screwed something up causing sound not to work and Windows Explorer to report a memory error Error: "There is not enough free memory to run this program", so I thought I'd run system restore. But system restore does not complete and my problems are still...
Backup and Restore
Need help to restore my COMPLETE system to new PC
Hello. I made/cloned a system image of my c and E drive, (2 different physical drives) using Windows 7 backup and restore program. my system is windows 7 ultimate, C (as usual) is my windows drive - consisting of 120GB data, while E is my additional data (pics, music, etc drive. E uses 1...
Backup and Restore
System Image Restore successfully.
Hello all, Just to inform you, and to share my positive experience! To test if System Image Restore works, I have deleted all Windows 7 partitions, including the system partition of 100 MB, so I only got left, two disks, with both only unallocated space. I rebooted to check if Windows 7...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:26.
Twitter Facebook Google+