Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to Restore After HDD Failure

16 Nov 2013   #1

Windows 7 Home Premium 64 bit
Trying to Restore After HDD Failure

My 3 year old HDD (WD green 1TB) crashed the other day and I replaced it, used a System Recovery disk to boot and restored the system from a system image stored on an external WD Passport. I do not have Windows 7 disks, just the product key on the case. Everything seemed ok at first, but now I have three issues:

1. Every morning I get the window that I am not running an authorized Microsoft version of W7. I entered the product key as requested and I also used the phone activation system (with the 9 groups of numbers) and got a successful activation indication. A look in Computer/properties indicates Windows is activated.

2. Windows Update will not work, probably related to the above. Now all I get is a blank page and a spinner. I have had messages that Windows Update cannot run as the "service" is not running. A check in Admin. Tools/services indicates that both Updater Service and Windows Update are running on automatic. I also tried to run the System Update Readiness Tool (KB947821), but get an 0xc8000247 error message, and when trying to run Update Troubleshooter, I get an 0x8e5e0247 error.

3. IE9 (never have been able to update to 10 successfully) quits working then resumes when in use. I get a pop up window indicating this.

Any help would be appreciated.

My System SpecsSystem Spec
16 Nov 2013   #2
Microsoft MVP

Windows 7 Ult. x64

We should probably check the MGADIAG report to see if there is an underlying condition causing the issue.

1. Download and save this tool to your desktop:

2. Run the tool, and then click Copy - ignore any errors if they appear

3. Use CTRL+V to paste the unedited results of the tool here in your next reply
My System SpecsSystem Spec
16 Nov 2013   #3

Windows 7 Home Premium 64 bit

Here is MGADIAG results:
Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0x8004FE21
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-X73XK-4D8YY-9B82F
Windows Product Key Hash: a4fHGbin+6Y4pGeB97DzikuK0/4=
Windows Product ID: 00359-OEM-9807542-54090
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {7EAC61ED-2426-4704-8A91-08036A8E45B9}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered,
Signed By: Microsoft
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.130708-1532
TTS Error:
Validation Diagnostic:
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 100 Genuine
Microsoft Office Home and Student 2007 - 100 Genuine
Microsoft Office Small Business 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_672A8F41-307-80004005_672A8F41-349-80004005_672A8F41-244-80004005
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[7.1.7600.16395], Hr = 0x80092003
File Mismatch: C:\Windows\system32\wat\watux.exe[7.1.7600.16395], Hr = 0x80092003
File Mismatch: C:\Windows\system32\sppobjs.dll[6.1.7601.17514], Hr = 0x80092003
File Mismatch: C:\Windows\system32\sppc.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppcext.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppwinob.dll[6.1.7601.17514], Hr = 0x80092003
File Mismatch: C:\Windows\system32\slc.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\slcext.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppuinotify.dll[6.1.7600.16385], Hr = 0x80092003
File Mismatch: C:\Windows\system32\slui.exe[6.1.7601.17514], Hr = 0x80092003
File Mismatch: C:\Windows\system32\sppcomapi.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppcommdlg.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppsvc.exe[6.1.7601.17514], Hr = 0x80092003
File Mismatch: C:\Windows\system32\drivers\spsys.sys[6.1.7127.0], Hr = 0x80092003
File Mismatch: C:\Windows\system32\drivers\spldr.sys[6.1.7127.0], Hr = 0x80092003
File Mismatch: C:\Windows\system32\systemcpl.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\user32.dll[6.1.7601.17514], Hr = 0x800b0100
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{7EAC61ED-2426-4704-8A91-08036A8E45B9}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-9B82F</PKey><PID>00359-OEM-9807542-54090</PID><PIDType>8</PIDType><SID>S-1-5-21-1986910065-1566111469-2135244464</SID><SYSTEM><Manufacturer>Gateway</Manufacturer><Model>DX4831</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>P01-B1</Version><SMBIOSVersion major="2" minor="6"/><Date>20100323000000.000000+000</Date></BIOS><HWID>F9693007018400FC</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Central Standard Time(GMT-06:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ACRSYS</OEMID><OEMTableID>ACRPRDCT</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91120000-002F-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Home and Student 2007</Name><Ver>12</Ver><Val>54E9E38C0DF0340</Val><Hash>9MREcMzk6dB9C+j+wFjL1PcdQ5M=</Hash><Pid>81602-416-0107411-68288</Pid><PidType>10</PidType></Product><Product GUID="{91120000-00CA-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Small Business 2007</Name><Ver>12</Ver><Val>828737365AB3F12</Val><Hash>KttxEXhWfzM3jcxfmML2SO+CUSQ=</Hash><Pid>81606-905-6831334-64162</Pid><PidType>1</PidType></Product></Products><Applications><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/></Applications></Office></Software></GenuineResults>
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7601.17514
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: 5e017a8a-f3f9-4167-b1bd-ba3e236a4d8f
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00196-075-454090-02-1033-7601.0000-3182013
Installation ID: 003200583463656253693145956945393966551061644314668491
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 9B82F
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 11/16/2013 5:09:25 PM
Windows Activation Technologies-->
HrOffline: 0x8004FE21
HrOnline: N/A
HealthStatus: 0x000000000001EFF0
Event Time Stamp: 11:14:2013 01:45
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:
Tampered File: %systemroot%\system32\sppobjs.dll
Tampered File: %systemroot%\system32\sppc.dll|sppc.dll.mui
Tampered File: %systemroot%\system32\sppcext.dll|sppcext.dll.mui
Tampered File: %systemroot%\system32\sppwinob.dll
Tampered File: %systemroot%\system32\slc.dll|slc.dll.mui
Tampered File: %systemroot%\system32\slcext.dll|slcext.dll.mui
Tampered File: %systemroot%\system32\sppuinotify.dll|sppuinotify.dll.mui
Tampered File: %systemroot%\system32\slui.exe|slui.exe.mui|COM Registration
Tampered File: %systemroot%\system32\sppcomapi.dll|sppcomapi.dll.mui
Tampered File: %systemroot%\system32\sppcommdlg.dll|sppcommdlg.dll.mui
Tampered File: %systemroot%\system32\sppsvc.exe|sppsvc.exe.mui
Tampered File: %systemroot%\system32\drivers\spsys.sys

HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT DpgPmm CpuPm
My System SpecsSystem Spec

16 Nov 2013   #4
Microsoft MVP

Windows 7 Ult. x64

There are quite a few errors there. Lets start with this : install this update, reboot, then create a new MGADIAG report and post it in your next reply.

Description of the update for Windows Activation Technologies
My System SpecsSystem Spec
16 Nov 2013   #5

Windows 7 Home Premium 64 bit

That update will not run. I get a 0xc8000247 error.
My System SpecsSystem Spec
16 Nov 2013   #6
Microsoft MVP

Windows 7 Ult. x64

OK. Perhaps some .dll files are corrupted. Please do the following:

1. Click Start
2. In the search box, type cmd
3. In the list that appears, right-click on cmd.exe and choose Run as administrator
4. In the command window that opens, type sfc /scannow and hit enter.

If the output reports that some files could not be repaired, then re-run it up to 3 times. Report back once thats done.

More detail: SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
16 Nov 2013   #7

Windows 7 Home Premium 64 bit

Ran it 3 times, still showing corrupt files.
My System SpecsSystem Spec
16 Nov 2013   #8
Microsoft MVP

Windows 7 Ult. x64

OK. The 0xc8000247 error code is usually fixed by this fixit tool:

How do I reset Windows Update components?

Try run that, then see if you can run Windows Update I posted earlier.
My System SpecsSystem Spec
16 Nov 2013   #9

Windows 7 Home Premium 64 bit

When I run the Mr.Fixit trouble shooter, I get a message "Trouble shooter has experienced an unexplained error and cannot continue"

I went ahead and ran the Mr. Fixit Reset Update Components and it fixes:
Some security settings are missing or have been changed
Service registration is missing or corrupt

Not fixed:
Problems installing recent updates

Check for missing or corrupt files

The previously posted update still gets the 0cx8000247 error.
My System SpecsSystem Spec
16 Nov 2013   #10
Microsoft MVP

Windows 7 Ult. x64

Ouch! OK, I'm at the limit of my knowledge here, but I know someone that can troubleshoot this better than I : I'll ask NoelDP to have a look at this.

Meanwhile, see if you can follow this tutorial which culminates in the generation of a CBS folder, which you can zip and attach here in your next reply. Noel will use the information therein to see if he can diagnose the issue, and generate a fix for you.

Windows Update Posting Instructions

Edit: I've asked Noel to have a gander at this.
My System SpecsSystem Spec

 Trying to Restore After HDD Failure

Thread Tools

Similar help and support threads
Thread Forum
Image Restore Failure
I have a Dell Inspiron 580, W7 64-bit Professional, where the HDD failed. The failed HD was a SATA II drive (ST31500341AS). I had previously setup a complete system image backup and repair disc. I purchased a new HD, a SATA III (ST1000DM003). The image restores fails because it can NOT find a...
Backup and Restore
System Restore Failure
Having trouble booting Windows. Have tried system repair and restore from multiple restore points and attempted startup repair infinite loop recovery. No luck so far. I've been having battery issues and have in the past recovered by using system restore. When I start windows normally, the...
Backup and Restore
System restore failure
Hi, During a blackout the other night my comp was obviously shut off, when the power came back I turned on my computer and logged in. After about ten or fifteen seconds it gave the bsod and shut down, then continued to do that for a while. I asked a friend what to do and he suggested a system...
Installation & Setup
System Restore failure - yet another tale of woe!!
OK, I've seen loads of posts by people who have lost their system restore and I have tried all suggestions but still have the following problem: I can create a System Restore point OK but when I try and roll back to a previous point, it goes through the motions and when the desktop screen reappears...
Backup and Restore
Backup and restore catastrophic failure
I created a backup on an old drive. I then realized there was a lot of junk on the drive I could remove so I just reformated it hoping to back up windows 7 again after the drive was formatted. When I went to control panel and selected Backup and Restore after formatting my backup hard drive, it...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:30.
Twitter Facebook Google+