Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Macrium Reflect Backup Aborted Error Code 0x8004230f

09 Feb 2015   #21
XP VM User

Windows7 Professional 64bit
More information for those who need it to help me

Hi DavidE:

Quote   Quote: Originally Posted by DavidE View Post
Quote   Quote: Originally Posted by XP VM User View Post
While trying stuff
What "stuff" did you do to cause your new problems ?
Don't write a new novel, just give a short concise answer with exact details.
Nobody here can know what "stuff" you did ... unless you tell us.
Correct you are! I'll post it here and in my "new" question too for anyone who did not answer for the same reasons! New Thread Link again: Crashed computer DSKCHK deleted all Opera history

Nothing too bad...

I was reading a lot of web sites with "suggestions" for solving the VSS problem due to Norton.
So many were NOT the Windows Seven Forum.... just doing research...

I had 40-50 tabs over 8 or 9 windows open in Opera 27 (just updated a week or so ago when I did Adobe)---that's my last Restore Point before I did a new one yesterday before fooling around with "Recuva" recovery program.

Too many windows, not enough time to read them all.. Plus I was trying some commands (JUST to LOOK they said) in Command prompt.

UNFORTUNATELY when the web browser went away----those sites are LONG LOST and I took some notes on paper... but I can't write very very long web addresses on paper, I trust the Browsers to keep a "history" of where I've been... that's the history everyone keeps trying to delete, its better to keep it alive..

I close computer regularly and re-fresh the browser opening up all of the old history to pick up where I left off.... but yesterday I had a lot of windows open and in middle of work when I get my usual "out of memory" warning (I usually shut down and refresh all history upon opening Opera again--that lets me browse for hours and hours ok)

So "stuff" covers a lot of activity.... I have NO IDEA which command or whatever web page I was reading that crashed and took down everything... sorry! (Norton "SAFE" is always on so I don't go if it warns me its a bad page or site).

I have one or two background programs operating always like CPU monitor and others I got from XP world---in compatibility mode as Windows Seven does not have them.... other than that the computer is run lean... unless on a project when no web use is done.

Sorry so long...

But you asked....

Will post in both threads to inform others.

Thanks DaivdE!

Thank you all who read it.

P.S. Full memory 8 GB on computer 2 sets of 4GB chips.

My System SpecsSystem Spec
09 Feb 2015   #22
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

I think the way you are going you will never fix your VSS service. You chose to ignore the Macrium page that gave the fixes and now you are inflicting more damage on your system with useless exercises.

I suggest you forget about Macrium and use the AOMEI Backupper instead. That does not use the VSS service and makes images just as well as Macrium. Here is a short review of it.

AOMEI Backupper Review 2015 - TopTenREVIEWS
My System SpecsSystem Spec
09 Feb 2015   #23
XP VM User

Windows7 Professional 64bit
Thanks for more advice

Hi whs:

Thanks for staying with me on this issue, with further advice....

Quote   Quote: Originally Posted by whs View Post
I think the way you are going you will never fix your VSS service. You chose to ignore the Macrium page that gave the fixes and now you are inflicting more damage on your system with useless exercises.

I suggest you forget about Macrium and use the AOMEI Backupper instead. That does not use the VSS service and makes images just as well as Macrium. Here is a short review of it.

AOMEI Backupper Review 2015 - TopTenREVIEWS
I have learned many new concepts here on Windows Seven Forum.

One is due to the unreliabitlity of the backup programs, I should have two.

So certainly getting AOMEI was high on my list (but I'm going to get it via paid site, not free to avoid any PUPs etc downloaded).

That still leaves me with just "one" backup system if Macrium is not able to be used.

So here is the plan: (advice please if its wrong)

Step zero (convince the owner of the computer that before first backup is even completed, due to surprise of lack of VSS on laptop, they will have to put forth another $49 for second backup program.

Step 1. Get AOMEI program from its paid website. Thanks for duplicating the link here for me, as I've lost all my pages here I had gone to in Opera and saved open for reference (assume version 2.2 standard is freeware, professional is their paid version of the same 2.2 I assume).

Step 2. Make the TWO backups after installing AOMEI and making sure it works (testing it? I don't think with my knowledge I should try that out about restoring a test area/partition/drive and just hope it works?? when I need it from this review(below) and advice on Windows Seven Forum.

Step 3. With two backups on two drives (one put on shelf) in hand.... return to the "unsolved" problem of fixing the VSS with more confidence now that I have the missing "backup" for not only my registery (as was recommendd here i.e. EURNT, but backed up everything.

Step 4. Then, with the fixed VSS system working again (maybe turning on the "automatic" from "manual" in the System window I posted earlier might do the trick? but I should not play that until I have a backup)--might be that simple.

Step 5. Make two additional backups using the already purchased Macrium system on the two drives.

Step 6. Returning to the issue in the Windows Seven Forum of the lost files/lost browser history of Opera as it had a lot of "temopory" day to day work on the history (i.e. reseraching items to buy for non-computer items that I have no memory of where I found them on the web and have to spend all that time even thinking up what they were again... unless I can get back the browser history... hopefully the new program won't overwrite all of the history files by installing it before I have a change to fix it).


Thanks for reading and any advice, change in order of steps, elimination of steps, other programs?

Speaking of other programs (for those who want to read further).... there are these others listed (I asw them before but didn't raise it with anyone here on Windows Seven Forum as everyone seemed to like AOMEI second to liking Macrium)

(I use Acronis on broken XP that will not save using other methods---it creates a totally encrypted backup that I can't be certain has the data in it---so even though its rated 10.0 I have to skip it unless this laptop needs something like that too)

Macrium Reflect Backup Aborted Error Code 0x8004230f-aomei-other-backup-systems-ps17518.jpg

Macrium Reflect Backup Aborted Error Code 0x8004230f-aomei-others-backups-top-10-ps17519.jpg

My System SpecsSystem Spec

21 Feb 2015   #24
XP VM User

Windows7 Professional 64bit
Thanks! Thanks! and more Thanks!

Hi Everyone!!

I wish to thank all who posted and helped me to get this far.

Summary of where I am:

1. Discussions on what types of Backup Programs work the best, settled on two: Macrium Reflex and AOEMI Backerupper as the best to choose.

2. Recommendation from all was to have not just one type of backup program, but two in case one fails, as they are only software and prone to all the trouble third party software can have.

3. Downloaded and Installed Macrium, but it did not work due to problems with VSS system on this laptop.

4. Thanks to the assistance here, I got AOMEI Backerupper to work and successfully made a backup using its own VSS "shadow copy" system

5. Confident I had at least "one" backup recently, we then Fixed/Repaired the problem on Windows 7 Registry about broken/taken over VSS System.

6. I then was able to use Macrium Reflect I purchased to make a second backup copy (first for Macrium that works!) using the native, repaired Windows 7 VSS system.

7. I then was able to get "free!!!" a permanent, successfully registered Professional copy of the AOMEI Backupper ver. 2.2 and it works so everything is ok there...

So in honor of all these accomplishments I'm closing most of the open threads that had problems with getting /obtaining/ installing/ using the various Backup systems we discussed here.

Now I'm going around to distribute as promised, some reps to those who helped me the most to succeed in this complicated backup jungle out there....

One final item left over.....

I started a new thread....... about AOMEI and getting its rescue boot disk downloaded... I got a few replies here: Question about WAIK vs WIN PE lost the info-search no find inmythreads
but I think I still have the questions in "red" numbers not answered, unless I read the items wrong


(Remember I lost a bunch of Word Pad documents---explained in another thread.... Welcome to Seven Forums [6] ((at post # 227))

........ and Opera history where I stored the pages I got from everyone here and opened them up for easy reference all vanished.... Crashed computer DSKCHK deleted all Opera history . I will return to those threads to solve those problems now that I have backups current (and of course I'll do another backup before playing with Registry etc if that is needed to fix any of these new problems).

Thanks for all your help in this complicated (at least to me!!!) issue.

My System SpecsSystem Spec
12 Sep 2018   #25

Windows XP SP3, 32-bit
backup image software VSS errors 0x8004230f, 0x80042301, 0x8000ffff.

This issue has arisen (for me) under Windows XP SP3, where Macrium Reflect Free 6.3.1855 immediately aborts/abends/fails to "create an image of the partition required to backup and restore Windows." Macrium uses Windows' Volume Shadow Copy service (or Volume Snapshot Service or VSS) to write its images/snapshots … and it is this VSS service that is throwing the errors to Macrium … that Macrium, in turn, is passing on to the user.

The various VSS error messages included:

ERROR: COM call "m_pVssObject->AddToSnapshotSet((LPWSTR)volume.c_str(), GUID_NULL, &SnapshotID)" failed. 0x8004230f VSS_E_UNEXPECTED_PROVIDER_ERROR

ERROR: COM call "m_pVssObject->BackupComplete(&pAsync)" failed. 0x80042301 VSS_E_BAD_STATE

Backup aborted! – Failed to Create Volume Snapshot. Result code: 0x8004230f

Event 12293 Source VSS Volume Shadow Copy Service error: Error calling a routine on the Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details Cannot ask provider {00000000-0000-0000-0000-000000000000} if volume is supported. [0x8000ffff] [hr = 0x8000ffff].

Error: 0x8000FFFF (when trying to run vssadmin commands at the DOS prompt)

Restore Point, invoking VSS, worked without issue.

There's a lot of information out there about this issue, provided by other insightful contributors. To save others a lot of time & trouble, I gathered up a lot of it here, with links to sources.

Possible Solution 1

First what VSS does, basically, is take a "snapshot" of the condition of the drive as the backup/image/clone process starts. Then, if an attempt to change a file is made before the process is complete, VSS plays "middle-man," and makes a copy of the file before the change … and uses THAT copy in the imaging/cloning process when the time comes. In that way, the ENTIRE backup/image/clone WILL be correct, as of the moment the snapshot was created.

Before VSS was ever implemented (in Windows XP), Macrium had created a system tool called PSSnap.sys (Paramount Software Snap-In) to do the same thing. Macrium has kept it in the install, so it can be used as a back up solution whenever VSS fails; it drops into C:\Windows\system32\drivers.

Here is a Macrium post explaining VSS in plain-English:
Backup Internals: What is VSS, how does it work and why do we use it?

And here is Microsoft trying to do the same:
404 - Content Not Found | Microsoft Docs)

There is even a Macrium menu option to force a VSS bypass, to use PSSnap.sys instead. Follow the path OtherTasks/EditDefaults/Advanced/VSSOptions/ Then choose "Exclude all VSS writers to resolve specific shapshot failures."

RESULT: In my case, it was grayed-out. And it was in several other releases of v5 & v6 also. Guessing that it is not an option in the Free product.

Other source(s):
Macrium Reflect Backup Failures Solved - Windows 10 Forums (referenced menu option at bottom)

Possible Solution 2

Macrium acknowledges the product sometimes has problems imaging/cloning where one, but not both, drives involved are not 512k sector based. Macrium suggests verifying via the Windows System Information tool.

Follow the path Programs/Accessories/SystemTools/SystemInformation or run msinfo32.exe. Verify the value of 'bytes/sector' under Components/Storage/Disks. My Advanced Technology Format (ATF) HGST drive (built upon 4096k sectors, but emulating 512k sectors as needed for backward compatibility) reports there as 512k bytes/sector. And I've cloned ONTO that drive using Macrium.

RESULT: Running 512k emulation must be acceptable to Macrium and so it's not likely the source of my problem.

VSS fails due to disks with a non-standard sector size - KnowledgeBase - Macrium Reflect Knowledgebase
VSS fails due to disks with a non-standard sector size

Possible Solution 3

Ensure all these (possibly) required services in Windows are available to run. Again, Macrium uses VSS (Volume Shadow Copy service) to take 'snapshots' of imaged drives. Follow the path ControlPanel/AdministrativeTools/Services or run services.msc to verify that the following services are NOT set to Disabled:

Remote Procedure Call (RPC) ("Automatic" is the default XP setting; it's a vital service, do not ever disable it.)
Volume Shadow Copy (depends on RPC) ("Manual" setting suffices)
MS Software Shadow Copy Provider (depends on RPC) ("Manual" setting suffices)
COM+ Event System (depends on RPC) ("Manual" setting suffices)
System Event Notification (depends on COM+ Event System) ("Automatic" is the default XP setting)
COM+ System Application (depends on RPC) ("Manual" setting suffices)
Distributed Transaction Coordinator (MS-DTC) (Macrium delivered a 0x8004d01b error when it was disabled) (depends on RPC) (depends on Security Accounts Manager) ("Manual" setting suffices)
Security Accounts Manager (depends on RPC) ("Automatic" is the default XP setting; with Service Pack 2 and going forward, this service cannot be stopped.)

RESULT: Ensuring these conditions had no effect toward solving my problem.

vss error 0x8004230f
VSS Troubleshooting
Quick Solved Volume Shadow Copy Service Errors (for Windows 10/8/7) (detailed information about Windows XP services and their dependencies)

Possible Solution 4

Macrium talks about conflicts with other backup/imaging/cloning software packages, recommending they be un-installed and, if already un-installed, how to delete, recreate and/or modify registry keys that still reference un-installed backup/imaging/cloning software. I inspected the keys referenced and found no irregularities.

RESULT: This avenue did not provide any solution to my problem.


Possible Solution 5

There is much discussion & recommendation regarding re-registering VSS components as a solution, due to some type of registration corruption.

Macrium provides a short external/free-standing program automating re registration called VSSFix … as well as offering users a menu path to it OtherTasks/FixVSSProblems. VSSFix creates a backup vss.reg file as part of the process. VSSFix apparently does what many other sources suggested doing manually (or with their own provided batch files), as described below:

Use Registry Editor to back up, then delete, this key:

Follow the path ControlPanel/AdministrativeTools/Services or run services.msc then right-click the following services one at a time and, for each, click Restart:
COM+ Event System
COM+ System Application
Microsoft Software Shadow Copy Provider
Volume Shadow Copy
If a service is not running, hence not available to restart, start it, then restart it.

Open an elevated DOS command prompt and run 'vssadmin list writers' If you see a list of writers described as stable and/or without error, the re registration is successfully completed. Otherwise continue as follows:

Type the following commands at the elevated DOS prompt:

cd C:\WINDOWS\system32 [required positioning, or subsequent commands may fail ]
net stop vss [ stops Volume Shadow Copy service ]
net stop swprv [ stops MS Software Shadow Copy Provider service ]
regsvr32 ole32.dll
regsvr32 oleaut32.dll
regsvr32 vss_ps.dll
vssvc /register
regsvr32 /i swprv.dll [ re-registers MS Software Shadow Copy Provider service ]
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 vssui.dll [ Error results under Windows XP; this dll is part of VSS only under Vista (or later) ]
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll [ Error results if Microsoft MSXML 4.0 SP 1 is not installed]
regsvr32 "%programfiles%\Microsoft SQL Server\80\Tools\Binn\sqlvdi.dll" [ Error results if no version of Microsoft SQL Server is installed]
vssvc /register [ I have no idea why some contributors ran this command a second time, but I rolled with it ]
net start vss [ ensures Volume Shadow Copy service is started ]
net start swprv [ ensures MS Software Shadow Copy Provider is started ]
vssadmin list writers [ output confirms that writers are now listed, stable and without error ]
vssadmin list providers [ output confirms that MS Software Shadow Copy service is now a provider. Unless you have installed other third-party providers, this should be the ONLY provider listed ]

RESULT: Following these procedures carefully—twice—AND running VSSFix had no effect. However a number of other contributors reported success.

Source(s): (at bottom, VSSFix download) (at bottom, VSSFix download)
VSS Troubleshooting

Possible Solution 6

If that doesn't work, another approach recommended was to rebuild a possibly damaged COM+ catalog: (to avoid a full repair reinstall of Windows)

Follow the path Control Panel/AdministrativeTools/ComponentServices or run comexp.msc

Expand at left

Export a copy of the "MS Software Shadow Copy Provider" service (and the associated .cab file) that will be saved as

Right-click to delete "MS Software Shadow Copy Provider" If delete is not an option, then choose Properties/Advanced/Disable Deletion/OK. Now you can delete it.

Export, then delete, the following registry key:

Locate the file C:\Windows\System32\Clbcatq.dll and rename it to ~Clbcatq.dll

Reboot the computer in Safe Mode.

Open the Registry, export, then delete the key

Locate the C:\Windows\Registration folder and rename it (or delete it).

Reboot the machine normally.

At elevated DOS prompt, type regsvr32 C:\windows\system32\ole32.dll

Open the Control Panel. Choose Add or Remove Programs. At left, choose Add/RemoveWindowsCompoents

If the components already selected seem appropriate in general, just click the Next button. COM+ is reinstalled automatically as part of this process, even if no other changes are selected.


Follow the path Control Panel/AdministrativeTools/ComponentServices or run comexp.msc

Expand ComponentServices/Computers/MyComputer/COM+Applications

Right click on COM+Applications. Click New. Click Application. Click Next. Choose "Install pre-built application." Click Next. Browse to the copy of "MS Software Shadow Copy Provider.msi" that was earlier exported, choose it, then allow the wizard to complete the installation.


At the DOS prompt

cd C:\WINDOWS\system32
regsvr32 /i swprv.dll (re-registers MS Software Shadow Copy Provider service)
There should be a success dialog box. Click OK.

Restart and you should find it all working. To verify, at an elevated DOS prompt:

vssadmin list writers (confirm that writers are listed and stable, without error)
vssadmin list providers (confirm list of providers appears correct)

If all is not working properly, try installing the COM+ catalog (the registry key that you exported) and rebooting.

RESULT: Following these procedures carefully had no effect.

VSS Troubleshooting

Possible Solution 7

There is a very promising solution posted at:
Quite a few posters stated this solved the problem … when all else had failed.

The root cause is identified as Macrium "side-loading" a new "disk signature" to an imaged/cloned drive. Indeed the drive I am trying to source to image—and that is running Macrium—is a Macrium-cloned drive.

A disk signature is intended to permanently and uniquely identify the drive. It is created during the drive's first partitioning and is normally never altered thereafter, not by formatting, re-partitioning or any other Windows process. It is stored inside the MBR (Master Boot Record) on MBR partitioned disks, as a unique 4-byte value, typically presented as an 8-character hex-string.

However Macrium DOES ALWAYS change the disk signature in the imaged or cloned drive since, if the user leaves both the source and target drives installed after the imaging/cloning, it creates a situation known as "disk signature collision," Where Windows is presented with two physically distinct drives that are identified (logically) as being the exact same drive.

To resolve the collision, Windows XP (or earlier) will simply change one of the disk signatures, without significant consequence. Vista (or later) versions, will mark one of the drive's as inactive and unrecognized. Unfortunately, beginning with the release of Vista, the unique disk signature is integrated, during Windows installation, into the boot process (presumably to complement Microsoft's efforts to prevent activation a unique license key on more than one machine). Hence if the disk signature is changed on such a drive, an installation of Windows Vista (or later versions) on that drive will no longer boot. This means that this possible solution CANNOT be used under Vista (or later) versions of Windows, only XP (or earlier).

To avoid this issue of possible collision, Macrium creates a brand-new disk signature in the imaged or cloned drive and (somehow) updates it throughout the cloned system/drive where ever needed so that Windows XP (and earlier) will boot.

However, in that Macrium "side-loads" the new disk signature via direct writes to these needed locations, rather than "asking" Windows to change it (which, again, would be problematic under Vista or later), Windows is never actually "formally notified" that there is a new drive now in place. Accordingly, no updating is performed by Windows on keys that require such in the case of a new drive … and that apparently includes keys for MS Software Shadow Copy Provider, rendering the service inoperable.

The solution (in XP or earlier versions) is to change the disk signature by one random digit using an MBR-management tool. Then, upon rebooting, Windows will "see" it has a new drive and update appropriate keys as needed. (Then it will require a second reboot to return to business-as-usual.)

The drive's unique disk signature can be retrieved (in Windows XP) by:

* DOS Prompt/diskpart/sel disk n/detail disk . The correct drive number, typically 0, replaces n. That number can be determined by following the path
ControlPanel/AdministrativeTools/ComputerManagement/Storage/DiskManagement or by running diskmgmt.msc. Each disk's numbering is noted in the left hand panel.

* DOS Prompt, then change to the MBRFix folder. Run "MbrFix /drive 0 readsignature"

I proceeded as follows:

I backed up all my data (which I store in a folder separate from the OS folders) using a straight-forward copy, in case the hard drive bricked.
I downloaded MBRFix (from the URL specified below), unZIPped it and deleted the 64-bit version, leaving only the correct 32-bit version of MBRFix.exe in place.
While in a Windows session, while minimizing the apps running, I opened an elevated DOS prompt and changed to the folder containing MBRFix.exe.
Then I ran the following commands:
MbrFix /drive 0 listpartitions (making sure just one more time that 0 is the correct drive number)
MbrFix /drive 0 readsignature (retrieved the current disk signature one more time, just to be sure)
MbrFix /drive 0 savembr BackupMbr0.bin (made a just-in-case MBR backup)
MbrFix /drive 0 writesignature value , where I entered my current disk signature (in place of value), except I changed one hex character, from a F to a E.
Confirmed the change - entered Y.
Exited DOS & rebooted.
Windows started in the normal fashion. After about 10 seconds into the session, Windows popped a dialog box stating
"Windows has finished installing new devices. The software that supports your device requires that you restart your computer. You must restart your computer before the new settings will take effect. Do you want to restart your computer now?"
I replied Yes and Windows rebooted.
Windows again started in normal fashion and into a normal session.
Everything was normal, Restore Points were undisturbed. I ran MBRFix again, verified that the disk signature had been changed as I intended. The vssadmin lists looked good.

RESULT: The sweet smell … of failure. Following these procedures carefully had no effect toward solving my problem.

Other Source(s): (The only download source I could locate for an earlier freeware version of MBRFix and early enough to support XP.)

Possible Solution 8

This solution assumes the same root cause as the prior possible solution, and is also discussed & recommended in the same TechSpot boards noted above.

Follow the path ControlPanel/System/Hardware/DeviceManager
Pull down View/ShowHiddenDevices
Scroll down to StorageVolumes, and click it to open/expand it
One-by-one, delete all the devices listed under StorageVolumes. (Most all of them will be listed as "Generic Volume.")

The problem should, supposedly, now be solved.

This Device Manager is displaying the list that Windows keeps of every single storage device that has ever been connected to the system. That includes every single USB ever connected to the system, that being why you see so many storage devices listed. That list also includes the imaged/cloned hard drive that is problematic. It sounds as though, by deleting all the items in this list, when you reboot, you are forcing Windows to recognize the cloned/imaged drive as a new drive, thereby accomplishing the same effect (as accomplished by changing the disk signature in the Possible Solution directly above).

Notably, this should give users of Vista (or higher) an alternate and use-able solution to this particular root cause, as the disk signature is NOT being changed, but rather the deletion is forcing Windows to re-detect the drive and its existing disk signature.

A posted message from Acronis Tech Support at the TechSpot board, near the very end, admitted "The cause of this problem is a change of Windows volume information in the registry after cloning." The Tech advised (instead of using Device Manager) to delete all entries under the keys:


RESULT: I know already know that disk signature isn't the issue, so why bother?

VSS Troubleshooting

Possible Solution 9

This approach actually harkens back to Possible Solution 1, the use of PSSnap.sys instead of VSS.

It turns out that on 2018-03-17, at version 7.1.2963, Macrium deprecated the option to run PSSnap.sys because it was conflicting with a Windows 7 patch (KB 4088875, 2018-03-14) intended to provide protection against "Spectre" and "Meltdown." The conflict delivered a BSOD. Macrium created a tool (called removesnap.exe) to resolve the issue … and then deprecated PSSnap.sys going forward.

This suggests that, under Windows XP (or Vista), a user could revert to a release earlier than 7.1.2963 and let PSSnap invoke to bypass the VSS errors.

However, that is NOT what occurred when I originally ran my 6.3.1855 standalone installer, obtained as a download from the main Macrium download process; as stated up-front, Macrium aborted/abended/failed and did not revert to PSSnap.sys. I also downloaded a 6.3.1849 standalone installer by following a Macrium backdoor URL; that installation failed in the same manner. Both were obtained & tested in September, 2018.

From that, I surmised that Macrium has altered the compile of its installer so that, at this point, any installer sourced direct from Macrium enforces the deprecation of PSSnap.sys.

Accordingly, I searched for earlier-version standalone installers from online sources OTHER THAN Macrium. Since v6 is a solid, mature and stable product, I restricted my search to v6 and earlier. Under that constraint, the most recent release I could locate was 6.3.1835. I also downloaded standalones of 5.1.5603, 5.2.6526 and 6.1.685. Again, all from non-Macrium sources.

RESULT: SUCCESS! Every one of those versions immediately fell back onto using PSSnap.Sys immediately after being thrown errors from VSS. In fact, the progress screen specifically stated it was doing so. Even though the Macrium menu option to force use PSSnap.sys was grayed-out and not selectable. But it should be duly noted that, just below that, also grayed-out, is the option "Automatically retry without VSS on failure." But it HAS been pre-selected. This being the likely option bringing PSSnap.sys to bear after the VSS errors.

Of course, the actual root cause of the VSS errors remains unresolved and unknown, relegated to remaining one of the many mysteries of our Universe.

My System SpecsSystem Spec

 Macrium Reflect Backup Aborted Error Code 0x8004230f

Thread Tools

Similar help and support threads
Thread Forum
Macrium Reflect or Windows Backup?
I'm just trying out backup\imaging options and it seems to me that Windows Backup is considerably easier to use than Macrium. Doing a Backup, anyway. Maybe it's not so clever when it comes to a restore. Comments?
Backup and Restore
Can Acronis or Macrium Reflect backup Truecrypt?
I have created a 100GB truecrypt file I intend to use a backup software and set daily auto incremental backups. . Lets say On day 1 (Aug 1), I created a full backup and scheduled daily incremental backups everyday (from day 2 onwards the backup software will be creating...
Backup and Restore
backup(macrium reflect)
I have latest (free) version of macrium reflect. when macrium reflect Is updated do I need to d/l the winpe files again??. will previous ISO still work with future updates.
Backup and Restore
BSOD; Macrium Reflect backup, error 0x00000019
So I was running Macrium Reflect after I did a clean install of Windows 7 Ultimate on my friends laptop and I got a BSOD BAD_POOL_HEADER. A few weeks ago, on my grandmas laptop it got a BSOD BAD_POOL_CALLER. Is this in error in Intel systems because both are Intel and both have had an issue...
BSOD Help and Support
Macrium windows image backup aborted
I've been trying to make image back-up from my reserved system and windows installation partition but i keep getting the message operation aborted as shown in the attachments. any one has an idea in how to solve the issue.
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:52.
Twitter Facebook Google+