Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Issue with Robocopy only copying folders, not files, in Windows 7

02 Mar 2015   #1

Windows 7 Professional, 64-bit
Issue with Robocopy only copying folders, not files, in Windows 7

Last week I used a robocopy tutorial on this site to create a backup script, and it was working fine. Today I tried to run this script, inputting new destination information but leaving everything else the same, and now it is copying all of the folders, but none of the files.

It counts a total of 509 Dirs but 0 files--no skipped, no mismatch, no failed.

My syntax/options are as follows:
robocopy "source folder" "destination folder" /E /tee /log.Public_backup log.txt
robocopy "source folder" "destination folder" /E /tee /log.Training_backup log.txt

Does anyone see what might be causing this problem or have suggestions?

The source folder is directory:\folder and the destination folder is directory:\folder\subfolder\subfolder, if that matters.

My System SpecsSystem Spec
04 Mar 2015   #2

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

It should default to all files (*.*), but you could put the *.* in the command to see if it makes a difference.
robocopy "source folder" "destination folder" *.* /E /tee /log.Public_backup log.txt

If that doesn't work can you post the actual commands you are using, with the real folder names ?
My System SpecsSystem Spec
04 Mar 2015   #3

Windows 7 Professional 64-bit

I just downloaded and installed RichCopy 4, good move on my part? Will I be able to do CMD-line with RichCopy like RoboCopy?
My System SpecsSystem Spec

09 Mar 2015   #4

Windows 7 Professional, 64-bit

@DavidE, I will try that next time I run into this issue. I was eventually able to get it to work--I removed the options and replaced them with the /MIR option, and then edited the commands so they were back to their original state--when I ran that, it worked and copied the files as well as the folders.

However, last Friday my supervisor attempted to run the Robocopy and told me that it only copied the folders for him. Not sure what the difference is between when it works and when it doesn't.

I will try your suggestion if this issue reoccurs and post an update to this thread.

Thanks for your help.
My System SpecsSystem Spec

 Issue with Robocopy only copying folders, not files, in Windows 7

Thread Tools

Similar help and support threads
Thread Forum
What robocopy command copy all folders and files with original dates
I want to copy the contents of pen drive to E drive. The pendrive drive is F. Now i want all the folders and files to have the same date it was as in the pen drive, when i stored . Normally when i copy, all the files retain original date but folders get todate. Meaning less if date...
General Discussion
Robocopy not copying all folders
Hi, I want to use Robocopy to backup the data from my external hardrive D to a file called 'Backup' in a cluster storage W. I only want to backup the modified and new files. In other words, I don't want to back up all the files in D every time I run Robocopy. This is what I wrote by reading...
Backup and Restore
Robocopy not copying My Document files
Hi, I just started using Robocopy to backup my files to my JBOD recently and I noticed that it does not copy anything in My Document folder. Here is the result log for Robocopy regarding the backup. Even though it says that it copied 22831 files the destination folder says it has not been modified...
Backup and Restore
Robocopy copying folders from the wrong place
I've set up a back up batch file to copy my Documents, Pictures, Music, and Videos folders from my computer to an external hard drive. However, while running the Documents backup, it seems to find, the pictures, music, and videos folders all inside the documents folders labelled "My Music", etc. ...
General Discussion
Robocopy - Copying Folders With Spaces in The Title.
Hey guys, This may sound like a really silly question, but I'm just getting to grips with using Robocopy. How do you copy folders with spaces in the title? E.g: T:\Admin Tools I keep getting an error. Any help would be great thanks.
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:38.
Twitter Facebook Google+